Cinnamon dopo inserimento password la chiede di nuovo

Spiego l’oggetto.

Cinnamon ha sempre funzionato benissimo.
Questa mattina dopo inserita la password la richiede di nuovo.
Come se fosse un loop.
Con Gnome 3 tutto funziona regolarmente.

Dove metto le mani?

Grazie

Spiegati meglio: tu inserisci la password alla schermata di login, entri dentro cinnamon, e compare un ulteriore pannello dentro a cinnamon che ti chiede la tua password, immagino?

Per Bebo
Quando metto la password e do invio scompare la s schermata che chiede il login e dopo 4/5 secondi ricompare.
Lo stesso accade con il secondo utente “ospite” che creai per far andare altri della famiglia.
Spero di essere riuscito a spiegare.

Grazie

Cioe’ non entri mai dentro al tuo desktop environment (con le barre e le icone per capirci), ma vieni continuamente rigettato alla schermata di login?

Hai fatto aggiornamenti recentemente? Hai provato ad usare un diverso Desktop Environment? Puoi accedere testualmente premendo CTRL+ALT+F2 (o F3…F6), e installando ad es un DE diverso (‘dnf grouplist -v’ e dopo ad es ‘dnf install @xfce-desktop-environment’) oppure tornare indietro ad uno stato precedente un aggiornamento con ‘dnf history’ e ‘dnf history undo X’ dove X e’ un ID di un’azione che vuoi annullare (quest’ultima operazione potrebbe non funzionare se non esistessero piu’ i pacchetti dello stato precedente da poter scaricare).

Con Gnome 3 tutto va bene.
Unica nota su Gnome 3: alla splash image mi segnala che esiste un errore ma non so come riuscire a leggere di cosa si tratta.

AGGIORNAMENTO.
Ho reinstallato Cinnamon e xfce.
Stesso problema con tutti e due.
Una volta inserita la password invece di lanciare Cinnamon ritorna all’inizio e richiede la password.

Ciao,

ho aperto un post qualche giorno fa proprio su cinnamon. anche a me dà lo stesso problema, nel senso che devo inserire due volte la password in quanto dopo averla inserita la prima volta anzichè entrare nel DE si presenta nuovamente la schermata in cui richiede la password. il problema credo sia lightdm… se uso altri de es: gnome o mate non riscontro tale anomalia. ho provato (come mi è stato suggerito) di cambiare Login Manager e sostituire lightdm con altro es: sddm, slim ecc… ho provato con slim e con sddm e il problema non lo fa… da qui sono giusto alla conclusione che è lightdm.

Domanda domandosa:
quale procedura devo usare per sostituire lightdm con altro login manager? quale login manager mi consigliate?

Grazie e buon anno

Da qua: https://www.if-not-true-then-false.com/2018/fedora-switch-display-manager/
dicono:

[code]# dnf install sddm

systemctl disable gdm # or kdm, lxdm, lightdm, xdm

systemctl enable sddm

reboot[/code]

Provane un po’ e vedi quali ti sembrano meglio. Sconsiglio pero’ gdm e kdm perche’ si trascinano dietro mezzo gnome o kde, rispettivamente.

Premessa lavoro con PC 32bit.
Ho fatto quanto indicato.
Al reboot si blocca con il prompt lampeggiante in alto a sinistra ed il cursore lampeggiante al centro dello schermo.
Al momento in cui s rivo (21,06 del 09/01) sto cercando nei miei Dvd quello con una Fedora live.

Attendo eventuali suggerimenti

Aggiornamento 9.57 del 10 / 01
Ho caricato f18 live.
Non so dove mettere le mani per mettere in disable sddm ed enable gdm
Attendo lumi.

Ciao, per tornare allo stato precedente puoi fare le stesse azioni che fa systemctl enable/disable a mano, che non sono altro che dei link simbolici.

Quindi, monta la partizione di root incriminata da una qualunque live. Assumendo che sia stata montata in ‘/media/’, devi prima rimuovere il link simbolico presente in /etc/systemd/system/display-manager.service, e farlo puntare di nuovo a gdm:

[email protected]# cd /media [email protected]# rm ./etc/systemd/system/display-manager.service [email protected]# ln -s /usr/lib/systemd/system/gdm.service ./usr/lib/systemd/system/gdm.service

Attenzione ai punti! Devi rimuovere il .service DENTRO /media, quindi li’ ci va un punto, e poi devi creare un link simbolico che puntera’ al percorso assoluto corretto (una volta che avra’ restartato la macchina).

Facci sapere.