creazione di collegamento ad altra directory in /etc/fstab [RISOLTO]

salve,
ringraziando ancora palir1927 per avermi salvato la vita (o quasi…), mi ricollego a https://forum.fedoraonline.it/viewtopic.php?id=26621 per sapere se e come sia possibile automatizzare la procedura di montaggio delle cartelle “vecchie” inserendo una formula opportuna in /etc/fstab.
Oppure se occorre lanciare necessariamente uno script all’avvio, nel qual caso sia chiaro che NON sono un programmatore e dovrei avere più di qualche dritta.
Grazie a tutti della collaborazione e a buon rendere!

Ciao, riesci gia’ a montarle a mano? Con che comando? Da li’ poi si puo’ partire per metterle nello fstab

sì, certo, col solito comando mount, dopo aver seguito le preziose indicazioni di palir1927 nel https://forum.fedoraonline.it/viewtopic.php?id=26621.
Immagino però che non si possa trapiantarlo di peso dentro fstab e pretendere che funzioni, o sbaglio?

Ciao,
dovresti provare ad inserire questa riga in “/etc/fstab”:

UUID=bf0304c9-ff99-4b0b-a763-e4ffbc0ff551 /home/Aiace/AIACE/	ext4    defaults        1 1

Se è già montato il file system (manualmente) esegui questi due punti:

cd /
umont -f /home/Aiace/AIACE/

A questo punto esegui il comando:

mount -a

E la directory dovrebbe essere montata.
Se qualcosa va storto condividi l’output.

Ciao
Palir1927

grazie PALIR1927, vediamo se ho capito bene:

PRIMA faccio questo

DOPO inserisco in “/etc/fstab” la riga

UUID=bf0304c9-ff99-4b0b-a763-e4ffbc0ff551 /home/Aiace/AIACE/	ext4    defaults        1 1

che è appunto analoga a quelle già presenti nel file, come si vede al https://forum.fedoraonline.it/viewtopic.php?id=26621.

A quel punto devo riavviare perché sia attivo tale nuovo inserimento?
Oppure (supponendo di NON riavviare), basta digitare subito il comando

mount -a

per trovare la directory immediatamente disponibile?

ANCORA
Come chiedevo, c’è modo di automatizzare tale procedura a ogni avvio, in maniera che non debba farla ogni volta a mano, dato che in fondo poi, una volta nel sistema, le cartelle mi serve di utilizzarle comunque?

Stasera provo a eseguire tutto quanto indicato e darò un feedback.

Si esegui questo due punti:

cd /
umount -f /home/Aiace/AIACE/

Inserisci in “/etc/fstab” la riga

UUID=bf0304c9-ff99-4b0b-a763-e4ffbc0ff551 /home/Aiace/AIACE/	ext4    defaults        1 1

In questo modo se tutto va bene ad ogni avvio del sistema verrà montata in automatico.

Eseguiamo un test che non ci siano errori prima di eseguire un riavvio del sistema:

mount -a

A fronte dell’esecuzione del comando “mount -a” dovresti trovarti montato al directory con tutti i file in “/home/Aiace/AIACE/”, se ci sono degli errori condividi l’output.
Altrimenti esegui il reboot dell’OS e dovresti trovarti caricata la directory quando il sistema è up & running.

Ciao
Palir1927

bene, ho fatto alcune prove, dalle quali ho capito che ci tiravamo dietro un errore: se (come hai scoperto tu) la directory AIACE non esiste, occorre sostituire quel nome con ‘dati’ nei comandi riportati sopra.
Fatto questo cambiamento, ho eseguito quanto suggerito e sembra funzionare tutto.
Adesso vado a nanna e spengo tutto.
Quando riaccenderò la macchina, se le tue previsioni sono esatte, cioè effettivamente viene montato anche il blocco della mia /home senza intoppi all’avvio, scriverò RISOLTO in cima anche a questo post.
Siccome sono fiducioso che ciò avverrà, comincio intanto a ringraziarti da qui.
Buon proseguimento!

Cioe’ non hai testato con mount -a che la riga che hai messo in /etc/fstab sia funzionante?

Attenzione a giocare con /etc/fstab e “fidarsi” che al reboot funzioni tutto.

no, bebo,
avevo provato anche il comando mount -a.
Infatti come vedi anche questo thread è felicemente risolto! :smiley:
Però mi incuriosisce la tua affermazione

quali problemi possono intervenire?
Io ero convinto che il file /etc/fstab fosse una buona soluzione; del resto nella pagina man del comando mount si consiglia di utilizzare LABEL oppure UUID, e nel mio caso ho proprio lavorato con il secondo.
Dacci lumi, grazie…

Il problema può porsi solo se sbagli qualcosa: nel qual caso il sistema va in console di emergenza, e devi correggere il file con

# vi /etc/fstab

il file con le informazioni errate.
Ma se devi sempre montare in avvio una determinata partizione in una certa posizione, e sai quello che fai, /etc/fstab è la strada giusta.

grazie del conforto!
:smiley: :cool: :lol: