non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

Buon pomeriggio a tutti ragazzi! Ho installato fedora 29 e non ho riscontrato nessun tipo di problema, tranne che uno:

Ho una scheda nvdia 950m e nel momento in cui collego l’hdmi fedora riconosce benissimo lo schermo esterno.
L’unico, ma importante, problema è che non funziona l’audio, o meglio fuoriesce soltanto dalle casse del pc e non dallo schermo esterno.

Come posso risolvere?

Grazie mille anticipatamente!

Ciao ,
hai provato nei settaggi dal pannello di configurazione sezione “audio” ,se usi gnome ,ci dovrebbero essere alcune scelte.
Oppure ,potrebbe essere la scheda ,io qualche anno fa ,facendo un pc nuovo ,ne ho restituita una che non aveva audio in uscita e ho cambiato modello.
ciao

Credo che la 950M ha la scheda audio in uscita…oltretutto non potrei neanche restituirla…è integrata nel laptop xD
comunque uso GNOME e ho provato a provare le varie opzioni, ma nulla

come opzioni , volevo dire :
impostazioni > audio >uscita >“scegliere un dispositivo per l’uscita audio” > HDMI /display port.
altrimenti non saprei cosa dire

[quote=giupardeb]Credo che la 950M ha la scheda audio in uscita…oltretutto non potrei neanche restituirla…è integrata nel laptop xD
comunque uso GNOME e ho provato a provare le varie opzioni, ma nulla[/quote]

segui la guida e posta i risultati :

https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#No_audio_over_HDMI

sembra che il chip audio sia disabilitato al boot , nvidia su linux non è il massimo (é il peggio XD)

questo è l’output del comando aplay -l :

**** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4] Subdevices: 1/1 Subdevice #0: subdevice #0

inoltre non ho nessun modulo che si chiamano: nvidia-drm nvidia-modeset nvidia suppongo che utilizzo di default i driver nouveau

[quote=giupardeb]questo è l’output del comando aplay -l :

**** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4] Subdevices: 1/1 Subdevice #0: subdevice #0

inoltre non ho nessun modulo che si chiamano: nvidia-drm nvidia-modeset nvidia suppongo che utilizzo di default i driver nouveau[/quote]

yeah stai “usando” intel… ovvio se non hai installato gli akmod ma su questo lascio il passo a chi ne sa di piu.

Ciao giupardeb, temo tu possa stare usando due GPU, la dedicata nvidia e la integrata Intel nella CPU.

Vediamo subito. Riporta:

$ lspci |egrep “VGA|3D”

Se ci sono due righe, significa che hai due schede grafiche.

La cosa piu’ facile da fare sarebbe disabilitare una delle due da bios magari: tieni conto che la dedicata e’ piu’ potente ma meno efficiente (essendo un device separato e con piu’ prestazioni, consuma di piu’), invece la dedicata solitamente e’ meno potente ma piu’ efficiente (essendo dentro o molto vicina alla CPU).

Prova a fare una prova disabilitando una delle due dal bios (se possibile), e poi prova a vedere se funziona l’audio.
Altrimenti possiamo poi provare ad installare i driver proprietari per la nvidia, oppure usare bumblebee.

Sei sicuro che la scheda supporti l’audio su hdmi, come diceva yum_yoshi? l’hai mai provata con un sistema che sai di avere tutti i driver funzionanti, magari il windows pre-installato?

[[email protected] ~]$ lspci |egrep "VGA|3D" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) 01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Adesso che ci rifletto bene…su ubuntu, con i driver proprietari non funzionava neanche…con windows mai provato…nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l’audio over hdmi.

Per quanto riguarda le schede attive…non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l’uso del bios?

[quote=giupardeb][[email protected] ~]$ lspci |egrep "VGA|3D" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) 01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Adesso che ci rifletto bene…su ubuntu, con i driver proprietari non funzionava neanche…con windows mai provato…nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l’audio over hdmi.

Per quanto riguarda le schede attive…non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l’uso del bios?[/quote]

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria :wink:

[quote=JackDaniels][quote=giupardeb][[email protected] ~]$ lspci |egrep "VGA|3D" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) 01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Adesso che ci rifletto bene…su ubuntu, con i driver proprietari non funzionava neanche…con windows mai provato…nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l’audio over hdmi.

Per quanto riguarda le schede attive…non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l’uso del bios?[/quote]

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)[/quote]

uso il pc per sola produttività. Non ci gioco…però credo di non poterla disattivare per il semplice motivo che l’hdmi non funzionerebbe…utilizzo molto uno schermo esterno

[quote=giupardeb][quote=JackDaniels][quote=giupardeb][[email protected] ~]$ lspci |egrep "VGA|3D" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) 01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Adesso che ci rifletto bene…su ubuntu, con i driver proprietari non funzionava neanche…con windows mai provato…nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l’audio over hdmi.

Per quanto riguarda le schede attive…non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l’uso del bios?[/quote]

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)[/quote]

uso il pc per sola produttività. Non ci gioco…però credo di non poterla disattivare per il semplice motivo che l’hdmi non funzionerebbe…utilizzo molto uno schermo esterno[/quote]

no tranquillo userai hdmi con intel

dopo averla disattivata da bios crea il file : /etc/X11/xorg.conf.d/20-intel.conf e piazza dentro :

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "glamor" Option "DRI" "3" Option "TripleBuffer" "true" EndSection

[quote=JackDaniels][quote=giupardeb][quote=JackDaniels][quote=giupardeb][[email protected] ~]$ lspci |egrep "VGA|3D" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) 01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Adesso che ci rifletto bene…su ubuntu, con i driver proprietari non funzionava neanche…con windows mai provato…nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l’audio over hdmi.

Per quanto riguarda le schede attive…non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l’uso del bios?[/quote]

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)[/quote]

uso il pc per sola produttività. Non ci gioco…però credo di non poterla disattivare per il semplice motivo che l’hdmi non funzionerebbe…utilizzo molto uno schermo esterno[/quote]

no tranquillo userai hdmi con intel

dopo averla disattivata da bios crea il file : /etc/X11/xorg.conf.d/20-intel.conf e piazza dentro :

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "glamor" Option "DRI" "3" Option "TripleBuffer" "true" EndSection [/quote]

ok proverò appena posso, ma una domanda banalissima ma che ho necessità di fare: Credo che fedora 29 utilizzi wayland, ma tu mi stai facendo creare un file di configurazione per xorg (X11). Questo non potrebbe crearmi problemi?

EDIT… credo che il mio bios non permetta di disattivare la nvidia

[quote=giupardeb][quote=JackDaniels][quote=giupardeb][quote=JackDaniels]

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)[/quote]

uso il pc per sola produttività. Non ci gioco…però credo di non poterla disattivare per il semplice motivo che l’hdmi non funzionerebbe…utilizzo molto uno schermo esterno[/quote]

no tranquillo userai hdmi con intel

dopo averla disattivata da bios crea il file : /etc/X11/xorg.conf.d/20-intel.conf e piazza dentro :

[[email protected] ~]$ lspci |egrep "VGA|3D" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) 01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)[/quote]

ok proverò appena posso, ma una domanda banalissima ma che ho necessità di fare: Credo che fedora 29 utilizzi wayland, ma tu mi stai facendo creare un file di configurazione per xorg (X11). Questo non potrebbe crearmi problemi?

EDIT… credo che il mio bios non permetta di disattivare la nvidia[/quote]

nvidia usa SOLO xorg. se non riesci a disattivare nvidia attueremo il l piano BSection "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "glamor" Option "DRI" "3" Option "TripleBuffer" "true" EndSection

Okay, creo ugualmente il file /etc/X11/xorg.conf.d/20-intel.conf con queste linee:

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "glamor" Option "DRI" "3" Option "TripleBuffer" "true" EndSection