Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 19-10-2017 12:38:28

skiava
Fedora nel sangue
Da Bari
Registrato: 23-05-2007
Messaggi: 1'879

non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Ciao a tutti, dnf non mi aggiorna il pacchetto gstreamer1-pliugins.....riporto di seguito l'output di:

[[email protected] skiava]# dnf update
Adobe Systems Incorporated                       16 kB/s | 1.9 kB     00:00    
Dropbox Repository                               25 kB/s | 2.4 kB     00:00    
Fedora 26 - x86_64 - Updates                    6.5 MB/s |  16 MB     00:02    
Fedora 26 - x86_64                              8.4 MB/s |  53 MB     00:06    
MEGAsync                                         49 kB/s |  16 kB     00:00    
RPM Fusion for Fedora 26 - Free - Updates       1.2 MB/s | 311 kB     00:00    
RPM Fusion for Fedora 26 - Free                 401 kB/s | 519 kB     00:01    
Fedora 26 - x86_64 - VirtualBox                 211 kB/s |  15 kB     00:00    
Ultima verifica della scadenza dei metadati: 0:00:00 fa il gio 19 ott 2017 13:31:55 CEST.
Dipendenze risolte.

 Problema: cannot install the best update candidate for package gstreamer1-plugins-ugly-1.12.2-1.fc26.x86_64
  - nothing provides gstreamer1-plugins-ugly-free(x86-64) = 1.12.3 needed by gstreamer1-plugins-ugly-1.12.3-1.fc26.x86_64
================================================================================
 pacchetto                Arch    Versione        Repository               Dim.
================================================================================
Skipping packages with broken dependencies:
 gstreamer1-plugins-ugly  x86_64  1.12.3-1.fc26   rpmfusion-free-updates  196 k

Riepilogo della transazione
================================================================================
Ignorati  1 pacchetto

Nothing to do.
Fatto!
[[email protected] skiava]# exit

qualcuno mi potrebbe aiutare?
grazie.

Ultima modifica di skiava (19-10-2017 12:39:08)


L I N U X - coming soon on every computer!!

Non in linea

#2 19-10-2017 13:00:18

antowen
Collaboratore
Da Ostrava
Registrato: 21-03-2010
Messaggi: 1'255
Sito web

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Sicura che non e' gia aggiornato?

rpm -qa | grep gstreamer1

Antonio G. Fedora 28 Mate
antowen.com

Non in linea

#3 19-10-2017 13:03:01

skiava
Fedora nel sangue
Da Bari
Registrato: 23-05-2007
Messaggi: 1'879

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

[[email protected] ~]$ rpm -qa | grep gstreamer1
gstreamer1-plugins-ugly-1.12.2-1.fc26.x86_64
gstreamer1-plugins-bad-free-1.12.3-1.fc26.x86_64
gstreamer1-plugins-base-1.12.3-1.fc26.x86_64
gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64
gstreamer1-plugins-good-1.12.3-1.fc26.x86_64
gstreamer1-libav-1.12.3-1.fc26.x86_64
gstreamer1-1.12.3-1.fc26.x86_64
gstreamer1-plugins-bad-free-gtk-1.12.3-1.fc26.x86_64
gstreamer1-plugins-bad-freeworld-1.12.3-1.fc26.x86_64
[[email protected] ~]$ 

L I N U X - coming soon on every computer!!

Non in linea

#4 19-10-2017 13:21:24

antowen
Collaboratore
Da Ostrava
Registrato: 21-03-2010
Messaggi: 1'255
Sito web

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Prova a installare le dipendenze a mano

dnf install lame-libs liba52 mpg123-libs totem-nautilus totem

Vediamo che dice

Ultima modifica di antowen (19-10-2017 13:21:54)


Antonio G. Fedora 28 Mate
antowen.com

Non in linea

#5 19-10-2017 14:39:40

palir1927
Fedora nel sangue
Da Neo Tokyo 3
Registrato: 15-03-2007
Messaggi: 1'996
Sito web

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

skiava ha scritto:
[[email protected] ~]$ rpm -qa | grep gstreamer1
gstreamer1-plugins-ugly-1.12.2-1.fc26.x86_64
gstreamer1-plugins-bad-free-1.12.3-1.fc26.x86_64
gstreamer1-plugins-base-1.12.3-1.fc26.x86_64
gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64
gstreamer1-plugins-good-1.12.3-1.fc26.x86_64
gstreamer1-libav-1.12.3-1.fc26.x86_64
gstreamer1-1.12.3-1.fc26.x86_64
gstreamer1-plugins-bad-free-gtk-1.12.3-1.fc26.x86_64
gstreamer1-plugins-bad-freeworld-1.12.3-1.fc26.x86_64
[[email protected] ~]$ 

Secondo me è un problema di coesistenza di pacchetti e versioni.

Sul mio sistema ho installato solo questi pacchetti:

[[email protected] ~]#[[email protected] ~]# rpm -qa | grep gstreamer1-plugins
gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64
gstreamer1-plugins-base-1.12.3-1.fc26.i686
gstreamer1-plugins-base-1.12.3-1.fc26.x86_64
gstreamer1-plugins-bad-free-gtk-1.12.3-1.fc26.x86_64
gstreamer1-plugins-bad-free-1.12.3-1.fc26.x86_64
gstreamer1-plugins-good-1.12.3-1.fc26.x86_64

E se provo ad installare il pacchetto "gstreamer1-plugins-ugly" mi esegue il downgrade del pacchetto "gstreamer1-plugins-ugly-free":

[[email protected] ~]# dnf install gstreamer1-plugins-ugly
Last metadata expiration check: 0:53:27 ago on Thu 19 Oct 2017 14:42:10 CEST.
Dependencies resolved.
==============================================================================================================================
 Package                                   Arch                Version                      Repository                   Size
==============================================================================================================================
Installing:
 gstreamer1-plugins-ugly                   x86_64              1.12.1-3.fc26                rpmfusion-free              196 k
Downgrading:
 gstreamer1-plugins-ugly-free              x86_64              1.12.1-1.fc26                fedora                       99 k

Transaction Summary
==============================================================================================================================
Install    1 Package
Downgrade  1 Package

Total download size: 295 k
Is this ok [y/N]: 

Come hai eseguito l'installazione?
Se hai installato i pacchetti manualmente, potresti provare con "dnf remove gstreamer1-plugins-ugly*" e re-installare sempre con il comando "dnf install gstreamer1-plugins-ugly*"

Facci sapere
Ciao

Ultima modifica di palir1927 (19-10-2017 14:40:39)


Mienai kizu kokaro mushibamu dake na no ni, yami no naka ni ima mo yadaru omoi wo asaekire...

Non in linea

#6 19-10-2017 16:51:37

camerte
Appena sbarcato sul forum
Registrato: 27-09-2017
Messaggi: 30

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Io ho KDE e con DNFdragora vedo installati:

gstreamer1-plugins-ugly 1.12.1
gstreamer1-plugins-ugly-free 1.12.1

Vedo come disponibile "gstreamer-plugins-ugly versione 1.12.3" ma "gstreamer-plugins-ugly-free" è fermo alla versione 1.12.2.

Forse questo è il motivo del downgrade alla 1.12.1 per entrambi i pacchetti.

Ultima modifica di camerte (19-10-2017 16:53:14)


Quando le cose vanno male, non andare con loro.

Non in linea

#7 19-10-2017 17:26:14

marcomotta
Moderatore
Da Roma
Registrato: 18-01-2009
Messaggi: 2'789
Sito web

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Ho lo stesso errore in aggiornamento: penso che sia un disallineamento dei repository, e che occorra aspettare. Nel frattempo non farei niente.


La filosofia è una disciplina con obiettivi, ma senza regole. La matematica è una disciplina con regole, ma senza obiettivi.
Un giorno ho incontrato un uomo che non aveva né obiettivi né regole. Studiava filosofia della matematica.

Non in linea

#8 19-10-2017 17:26:45

skiava
Fedora nel sangue
Da Bari
Registrato: 23-05-2007
Messaggi: 1'879

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Riporto di seguito il responso di:
soluzione 1:

[[email protected] skiava]# dnf install lame-libs liba52 mpg123-libs totem-nautilus totem
Ultima verifica della scadenza dei metadati: 0:54:38 fa il gio 19 ott 2017 16:38:06 CEST.
Il pacchetto lame-libs-3.99.5-8.fc26.x86_64 è già installato, viene ignorato.
Il pacchetto liba52-0.7.4-28.fc26.x86_64 è già installato, viene ignorato.
Il pacchetto mpg123-libs-1.25.6-1.fc26.x86_64 è già installato, viene ignorato.
Il pacchetto totem-nautilus-1:3.24.0-1.fc26.x86_64 è già installato, viene ignorato.
Il pacchetto totem-1:3.24.0-1.fc26.x86_64 è già installato, viene ignorato.
Dipendenze risolte.
Nothing to do.
Fatto!
[[email protected] skiava]#

soluzione 2:

[[email protected] skiava]# dnf remove gstreamer1-plugins-ugly
Dipendenze risolte.
==============================================================================================================================
 pacchetto                                 Arch                Versione                      Repository                  Dim.
==============================================================================================================================
Rimozione in corso:
 gstreamer1-plugins-ugly                   x86_64              1.12.2-1.fc26                 @@commandline              518 k
Rimozione dipendenze inutilizzate:
 gstreamer1-plugins-ugly-free              x86_64              1.12.2-1.fc26                 @@commandline              275 k

Riepilogo della transazione
==============================================================================================================================
Rimossi  2 pacchetti

Spazio liberato: 793 k
Procedere [s/N]: s
Esecuzione del controllo di transazione
Controllo di transazione eseguito con successo.
Test di transazione in corso
Test di transazione eseguito con successo
Transazione in corso
  Preparazione in corso                      :                                                                            1/1 
  Eliminazione in corso                      : gstreamer1-plugins-ugly-1.12.2-1.fc26.x86_64                               1/2 
  Eliminazione in corso                      : gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64                          2/2 
  Verifica in corso                          : gstreamer1-plugins-ugly-1.12.2-1.fc26.x86_64                               1/2 
  Verifica in corso                          : gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64                          2/2 

Eliminati:
  gstreamer1-plugins-ugly.x86_64 1.12.2-1.fc26                gstreamer1-plugins-ugly-free.x86_64 1.12.2-1.fc26               

Fatto!
[[email protected] skiava]# dnf install gstreamer1-plugins-ugly
Ultima verifica della scadenza dei metadati: 0:56:41 fa il gio 19 ott 2017 16:38:06 CEST.
Dipendenze risolte.
==============================================================================================================================
 pacchetto                                 Arch                Versione                     Repository                   Dim.
==============================================================================================================================
Installazione in corso:
 gstreamer1-plugins-ugly                   x86_64              1.12.1-3.fc26                rpmfusion-free              196 k
Installazione dipendenze:
 gstreamer1-plugins-ugly-free              x86_64              1.12.1-1.fc26                fedora                       99 k

Riepilogo della transazione
==============================================================================================================================
Installati  2 pacchetti

Dimensione totale dello scaricamento: 295 k
Dimensione installata: 792 k
Procedere [s/N]: s
Scaricamento dei pacchetti:
(1/2): gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64.rpm                                  370 kB/s |  99 kB     00:00    
(2/2): gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64.rpm                                       356 kB/s | 196 kB     00:00    
------------------------------------------------------------------------------------------------------------------------------
Totale                                                                                        187 kB/s | 295 kB     00:01     
Esecuzione del controllo di transazione
Controllo di transazione eseguito con successo.
Test di transazione in corso
Test di transazione eseguito con successo
Transazione in corso
  Preparazione in corso                      :                                                                            1/1 
  Installazione in corso                     : gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64                          1/2 
  Installazione in corso                     : gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64                               2/2 
  Verifica in corso                          : gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64                               1/2 
  Verifica in corso                          : gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64                          2/2 

Installati:
  gstreamer1-plugins-ugly.x86_64 1.12.1-3.fc26                gstreamer1-plugins-ugly-free.x86_64 1.12.1-1.fc26               

Fatto!
[[email protected] skiava]# dnf update
Ultima verifica della scadenza dei metadati: 0:57:04 fa il gio 19 ott 2017 16:38:06 CEST.
Dipendenze risolte.

 Problema 1: cannot install the best update candidate for package gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64
  - nothing provides gstreamer1-plugins-ugly-free(x86-64) = 1.12.3 needed by gstreamer1-plugins-ugly-1.12.3-1.fc26.x86_64
 Problema 2: problem with installed package gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64
  - package gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64 requires gstreamer1-plugins-ugly-free(x86-64) = 1.12.1, but none of the providers can be installed
  - cannot install both gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64 and gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64
  - cannot install both gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64 and gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64
  - cannot install the best update candidate for package gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64
  - nothing provides gstreamer1-plugins-ugly-free(x86-64) = 1.12.3 needed by gstreamer1-plugins-ugly-1.12.3-1.fc26.x86_64
==============================================================================================================================
 pacchetto                               Arch              Versione                   Repository                         Dim.
==============================================================================================================================
Esclusione dei pacchetti con conflitti:
(aggiungere '--best --allowerasing' alla lina di comando per forzarne l'aggiornamento):
 gstreamer1-plugins-ugly-free            x86_64            1.12.2-1.fc26              updates                            99 k
Skipping packages with broken dependencies:
 gstreamer1-plugins-ugly                 x86_64            1.12.3-1.fc26              rpmfusion-free-updates            196 k

Riepilogo della transazione
==============================================================================================================================
Ignorati  2 pacchetti

Nothing to do.
Fatto!
[[email protected] skiava]# 

i pacchetti non li ho installati manualmente ma di default e successivamente con dnf update mi ha riscontrato questo problema.


L I N U X - coming soon on every computer!!

Non in linea

#9 19-10-2017 17:27:44

skiava
Fedora nel sangue
Da Bari
Registrato: 23-05-2007
Messaggi: 1'879

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

marcomotta ha scritto:

Ho lo stesso errore in aggiornamento: penso che sia un disallineamento dei repository, e che occorra aspettare. Nel frattempo non farei niente.

ok bene.


L I N U X - coming soon on every computer!!

Non in linea

#10 20-10-2017 07:43:06

skiava
Fedora nel sangue
Da Bari
Registrato: 23-05-2007
Messaggi: 1'879

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Buongiorno a tutti, stamattina ho rifatto l'update e mi ha restituito il seguente responso:

[[email protected] skiava]# dnf update
Ultima verifica della scadenza dei metadati: 0:04:27 fa il ven 20 ott 2017 08:35:30 CEST.
Dipendenze risolte.

 Problema 1: cannot install the best update candidate for package gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64
  - nothing provides gstreamer1-plugins-ugly-free(x86-64) = 1.12.3 needed by gstreamer1-plugins-ugly-1.12.3-1.fc26.x86_64
 Problema 2: problem with installed package gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64
  - package gstreamer1-plugins-ugly-1.12.1-3.fc26.x86_64 requires gstreamer1-plugins-ugly-free(x86-64) = 1.12.1, but none of the providers can be installed
  - cannot install both gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64 and gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64
  - cannot install both gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64 and gstreamer1-plugins-ugly-free-1.12.2-1.fc26.x86_64
  - cannot install the best update candidate for package gstreamer1-plugins-ugly-free-1.12.1-1.fc26.x86_64
  - nothing provides gstreamer1-plugins-ugly-free(x86-64) = 1.12.3 needed by gstreamer1-plugins-ugly-1.12.3-1.fc26.x86_64
==============================================================================================================================
 pacchetto                               Arch              Versione                   Repository                         Dim.
==============================================================================================================================
Esclusione dei pacchetti con conflitti:
(aggiungere '--best --allowerasing' alla lina di comando per forzarne l'aggiornamento):
 gstreamer1-plugins-ugly-free            x86_64            1.12.2-1.fc26              updates                            99 k
Skipping packages with broken dependencies:
 gstreamer1-plugins-ugly                 x86_64            1.12.3-1.fc26              rpmfusion-free-updates            196 k

Riepilogo della transazione
==============================================================================================================================
Ignorati  2 pacchetti

Nothing to do.
Fatto!
[[email protected] skiava]# 

cosa mi consigliate di fare?

Ultima modifica di skiava (20-10-2017 07:49:53)


L I N U X - coming soon on every computer!!

Non in linea

#11 20-10-2017 11:16:39

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'661

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Come dice marcomotta "aspettare" ricordandoci che chi predispone gli aggiornameti sono volontari, non passeranno mesi ma 2 o 3 giorni diamogleli smile


Ciao
Andrea Malfatti

Non in linea

#12 20-10-2017 11:57:41

skiava
Fedora nel sangue
Da Bari
Registrato: 23-05-2007
Messaggi: 1'879

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

ok tranquillo  :beer:


L I N U X - coming soon on every computer!!

Non in linea

#13 20-10-2017 17:09:53

camerte
Appena sbarcato sul forum
Registrato: 27-09-2017
Messaggi: 30

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Come dice marcomotta "aspettare" ricordandoci che chi predispone gli aggiornameti sono volontari, non passeranno mesi ma 2 o 3 giorni diamogleli...

Calcolando che è anche venerdì...
big_smile


Quando le cose vanno male, non andare con loro.

Non in linea

#14 26-10-2017 19:34:28

deltafox
Pinguino avanzato
Da Stalingrado d'Italia
Registrato: 29-10-2008
Messaggi: 155

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Avendo lo stesso problema di skiava, qualcuno ha notizie in merito al problema ???

Ultima modifica di deltafox (26-10-2017 19:34:48)


Fedora 64 bit Xfce

Non in linea

#15 28-10-2017 08:29:35

arkanoid
Moderatore
Da Trento
Registrato: 06-05-2010
Messaggi: 2'142
Sito web

Re: non mi aggiorna il pacchetto gstreamer1-plugins-ugly x86_64......

Se aggiorni, dando una rinfrescata ai metadati, ottieni sempre lo stesso problema?

# dnf upgrade --refresh

|| FAS: juliuxpigface || IRC: jpigface || GITHUB: pigjuliux ||

Non in linea

Piè di pagina