Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 03-04-2018 15:03:36

Salvatore47
Pinguino avanzato
Registrato: 24-08-2013
Messaggi: 300

[Risolto] calligra 3.1.0 errore nei repository

Da una settimana avviando l'aggiornamento mi segnala il seguente errore:

# dnf update
Ultima verifica della scadenza dei metadati: 0:02:53 fa il mar 03 apr 2018 15:52:21 CEST.
Dipendenze risolte.

 Problema 1: cannot install both calligra-core-3.1.0-2.fc27.x86_64 and calligra-core-3.0.1-16.fc27.x86_64
  - package calligra-plan-3.0.1-16.fc27.x86_64 requires calligra-core = 3.0.1-16.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package calligra-core-3.0.1-16.fc27.x86_64
  - problem with installed package calligra-plan-3.0.1-16.fc27.x86_64
 Problema 2: cannot install both calligra-core-3.1.0-2.fc27.x86_64 and calligra-core-3.0.1-16.fc27.x86_64
  - package calligra-plan-3.0.1-16.fc27.x86_64 requires calligra-core = 3.0.1-16.fc27, but none of the providers can be installed
  - package calligra-karbon-3.1.0-2.fc27.x86_64 requires calligra-core = 3.1.0-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package calligra-plan-3.0.1-16.fc27.x86_64
  - cannot install the best update candidate for package calligra-karbon-3.0.1-16.fc27.x86_64
 Problema 3: cannot install both calligra-core-3.1.0-2.fc27.x86_64 and calligra-core-3.0.1-16.fc27.x86_64
  - package calligra-plan-3.0.1-16.fc27.x86_64 requires calligra-core = 3.0.1-16.fc27, but none of the providers can be installed
  - package calligra-l10n-3.1.0-2.fc27.noarch requires calligra-core = 3.1.0-2.fc27, but none of the providers can be installed
  - package calligra-plan-libs-3.0.1-16.fc27.x86_64 requires calligra-plan = 3.0.1-16.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package calligra-l10n-3.0.1-16.fc27.noarch
  - problem with installed package calligra-plan-libs-3.0.1-16.fc27.x86_64
 Problema 4: package calligra-plan-libs-3.0.1-16.fc27.x86_64 requires libflake.so.15()(64bit), but none of the providers can be installed
  - cannot install both calligra-libs-3.1.0-2.fc27.x86_64 and calligra-libs-3.0.1-16.fc27.x86_64
  - cannot install both calligra-libs-3.0.1-9.fc27.x86_64 and calligra-libs-3.1.0-2.fc27.x86_64
  - cannot install the best update candidate for package calligra-plan-libs-3.0.1-16.fc27.x86_64
  - cannot install the best update candidate for package calligra-libs-3.0.1-16.fc27.x86_64
=================================================================================================================================
 pacchetto                          Arch                      Versione                          Repository                  Dim.
=================================================================================================================================
Esclusione dei pacchetti con conflitti:                                                                                          
(aggiungere '--best --allowerasing' alla lina di comando per forzarne l'aggiornamento):
 calligra-core                      x86_64                    3.1.0-2.fc27                      updates                    8.4 M
 calligra-libs                      x86_64                    3.0.1-9.fc27                      fedora                     6.0 M
 calligra-libs                      x86_64                    3.1.0-2.fc27                      updates                    5.9 M
Skipping packages with broken dependencies:
 calligra-karbon                    x86_64                    3.1.0-2.fc27                      updates                     57 k
 calligra-l10n                      noarch                    3.1.0-2.fc27                      updates                    5.0 M

Riepilogo della transazione
=================================================================================================================================
Ignorati  5 pacchetti

Nothing to do.
Fatto!

Ciao

Ultima modifica di Salvatore47 (04-04-2018 19:04:44)

Non in linea

#2 04-04-2018 09:33:54

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 679

Re: [Risolto] calligra 3.1.0 errore nei repository

come dice l'output prova ad aggiungere

# dnf update --best --allowerasing

oppure se non funziona,  visto che il problema è il conflitto con la versione vecchia ,  dai un remove calligra e poi install .

ciao

Non in linea

#3 04-04-2018 10:02:32

marcomotta
Moderatore
Da Roma
Registrato: 18-01-2009
Messaggi: 2'800
Sito web

Re: [Risolto] calligra 3.1.0 errore nei repository

Sembra che tu abbia dei pacchetti duplicati. Probabilmente un aggiornamento è stato interrotto tempo fa. Prova

# dnf remove --duplicates

Se dovesse fallire, fornisci l'output di

# dnf repoquery --duplicates

La filosofia è una disciplina con obiettivi, ma senza regole. La matematica è una disciplina con regole, ma senza obiettivi.
Un giorno ho incontrato un uomo che non aveva né obiettivi né regole. Studiava filosofia della matematica.

Non in linea

#4 04-04-2018 19:02:42

Salvatore47
Pinguino avanzato
Registrato: 24-08-2013
Messaggi: 300

Re: [Risolto] calligra 3.1.0 errore nei repository

Rimuovendo Calligra e dopo installo --> tutto OK

Grazie

Ciao

Non in linea

Piè di pagina