Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 17-04-2018 22:29:59

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 25

[Risolto] Downgrade hplip

Buonasera a tutti,

una domanda di carattere generale: è possibile installare tramite dnf (o gnome-software) una versione precedente di un software (in questo caso hplip) che appartine ai repositories della release di fedora precedente?
Nello specifico: ho aggiornato a F28 e la versione installata di hplip (3.18.3-1) non mi permette di utilizzare lo scanner della mia multifunzione (una HP Photosmart b110), mentre la stampante funziona correttamente. La stessa cosa mi era successa dopo un aggiornamento con F27, tuttavia in quel caso avevo fatto un downgrade di hplip e bloccato la versione con il plugin versionlock di dnf. Con F28 questo non funziona in quanto la versione installata è la prima di F28.
Alternativa è scaricare il file .run dal sito ma prima preferirei vedere se funziona con dnf.

Grazie

Ultima modifica di jack_71 (22-04-2018 12:33:35)

Non in linea

#2 18-04-2018 07:25:46

marcomotta
Moderatore
Da Roma
Registrato: 18-01-2009
Messaggi: 2'800
Sito web

Re: [Risolto] Downgrade hplip

# dnf downgrade --release 27 hplip

Se non riesci, puoi provare

# dnf downgrade --release 27 --allowerasing hplip

(ma con cautela, guardando bene, prima di confermare, se rimuove qualche pacchetto che ti serve).


La filosofia è una disciplina con obiettivi, ma senza regole. La matematica è una disciplina con regole, ma senza obiettivi.
Un giorno ho incontrato un uomo che non aveva né obiettivi né regole. Studiava filosofia della matematica.

Non in linea

#3 18-04-2018 15:56:44

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'000
Sito web

Re: [Risolto] Downgrade hplip

jack_71 ha scritto:

non mi permette di utilizzare lo scanner della mia multifunzione

E' un bug o e' un comportamento desiderato dagli sviluppatori? Nel primo caso lo segnalerei su bugzilla, e, se e' una cosa risolvibile, a breve potresti trovare il pacchetto aggiornato nei repo updates.


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#4 18-04-2018 18:31:41

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 25

Re: [Risolto] Downgrade hplip

L'ultima versione su F27 mi aveva creato lo stesso problema (da qui il downgrade, in quel caso risolutivo), poi ho scoperto che la stessa versione non supportava F27, non so se fosse questa la causa.

Proverò il comando suggerito.

Grazie

Non in linea

#5 18-04-2018 19:11:15

marcomotta
Moderatore
Da Roma
Registrato: 18-01-2009
Messaggi: 2'800
Sito web

Re: [Risolto] Downgrade hplip

Se l'ultima versione per Fedora 27 non funzionava correttamente, potresti dover ripetere due volte il comando per il downgrade. Se dopo aver dato con successo il comando il programma non va, prova a rieseguire il comando una seconda volta.


La filosofia è una disciplina con obiettivi, ma senza regole. La matematica è una disciplina con regole, ma senza obiettivi.
Un giorno ho incontrato un uomo che non aveva né obiettivi né regole. Studiava filosofia della matematica.

Non in linea

#6 18-04-2018 20:36:17

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 25

Re: [Risolto] Downgrade hplip

Perfetto, ho dato due volte il comando e tutto ha ripreso a funzionare, evidentemente la versione 3.17.9-2 di F27 è l'ultima che permette l'utilizzo della funzione scanner della mia multifunzione. Ora blocco con versionlock.

Grazie mille per il supporto

Non in linea

#7 18-04-2018 21:08:33

marcomotta
Moderatore
Da Roma
Registrato: 18-01-2009
Messaggi: 2'800
Sito web

Re: [Risolto] Downgrade hplip

Grazie a te per avermi fatto conoscere il plugin versionlock.


La filosofia è una disciplina con obiettivi, ma senza regole. La matematica è una disciplina con regole, ma senza obiettivi.
Un giorno ho incontrato un uomo che non aveva né obiettivi né regole. Studiava filosofia della matematica.

Non in linea

Piè di pagina