Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 03-11-2018 19:55:05

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 24

[Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

Buonasera a tutti, apro questa discussione in questa sezione in quanto non vedo ancora una sezione dedicata a F29.
Ho appena aggiornato e come già in passato il primo problema che mi si pone difronte è il mancato funzionamento dello scanner della mia multifunzione HP Photosmart B110.
In passato ho risolto facendo il downgrade di hplip alla versione 3.17.9-2 di F27 che pare essere l'ultima che mi permette il funzionamento anche dello scanner (la stampante funziona correttamente e compare in Impostazioni/Dispositivi/Stampanti così come la posso gestire via browser con cups); bloccando la versione dei pacchetti con versionlock il funzionamento era garantito.
Ora se do il comando

dnf downgrade --release 27 hplip*

il risultato è

Fedora Modular 27 - x86_64                       13 kB/s |  47 kB     00:03    
Errore: Sincronizzazione cache non riuscita per il repo 'fedora-modular'

Se invece do il comando

dnf downgrade --release 28 hplip*

il risultato è

Fedora Modular 28 - x86_64                       19 kB/s |  26 kB     00:01    
Fedora Modular 28 - x86_64 - Updates             19 kB/s |  25 kB     00:01    
Fedora 28 - x86_64 - Updates                    3.5 kB/s |  22 kB     00:06    
Fedora 28 - x86_64                               11 kB/s |  26 kB     00:02    
RPM Fusion for Fedora 28 - Free - Updates       7.3 kB/s | 9.3 kB     00:01    
RPM Fusion for Fedora 28 - Free                 7.8 kB/s |  10 kB     00:01    
RPM Fusion for Fedora 28 - Nonfree - Updates    7.3 kB/s | 9.4 kB     00:01    
RPM Fusion for Fedora 28 - Nonfree              7.8 kB/s |  10 kB     00:01    
skype (stable)                                  2.3 kB/s | 2.9 kB     00:01    
TeamViewer - x86_64                             2.3 kB/s | 2.5 kB     00:01    
Modular dependency problems:

 Problema 1: conflicting requests
  - nothing provides module(platform:f28) needed by module reviewboard:2.5:20180206144254:e0c83381-0.noarch
 Problema 2: conflicting requests
  - nothing provides module(platform:f28) needed by module stratis:1:20180927214347:337c62b4-0.x86_64
 Problema 3: conflicting requests
  - nothing provides module(platform:f28) needed by module libgit2:0.26:20181006095632:9c690d0e-0.x86_64
Errore: 
 Problema 1: conflicting requests
  - package hplip-libs-3.18.6-9.fc28.x86_64 requires python(abi) = 3.6, but none of the providers can be installed
  - package hplip-libs-3.18.3-1.fc28.x86_64 requires python(abi) = 3.6, but none of the providers can be installed
  - python3-3.6.6-1.fc28.i686 has inferior architecture
  - python3-3.6.5-1.fc28.i686 has inferior architecture
  - cannot install both python3-3.6.6-1.fc28.x86_64 and python3-3.7.1-1.fc29.x86_64
  - cannot install both python3-3.6.5-1.fc28.x86_64 and python3-3.7.1-1.fc29.x86_64
  - package python3-libdnf-0.22.0-6.fc29.x86_64 requires python(abi) = 3.7, but none of the providers can be installed
  - problem with installed package python3-libdnf-0.22.0-6.fc29.x86_64
 Problema 2: conflicting requests
  - package hplip-3.18.6-9.fc28.x86_64 requires hplip-libs(x86-64) = 3.18.6-9.fc28, but none of the providers can be installed
  - package hplip-3.18.3-1.fc28.x86_64 requires hplip-libs(x86-64) = 3.18.3-1.fc28, but none of the providers can be installed
  - package hplip-libs-3.18.6-9.fc28.x86_64 requires python(abi) = 3.6, but none of the providers can be installed
  - package hplip-libs-3.18.3-1.fc28.x86_64 requires python(abi) = 3.6, but none of the providers can be installed
  - package python3-3.6.6-1.fc28.i686 requires python3-libs(x86-32) = 3.6.6-1.fc28, but none of the providers can be installed
  - package python3-3.6.5-1.fc28.i686 requires python3-libs(x86-32) = 3.6.5-1.fc28, but none of the providers can be installed
  - python3-libs-3.6.6-1.fc28.i686 has inferior architecture
  - python3-libs-3.6.5-1.fc28.i686 has inferior architecture
  - cannot install both python3-libs-3.6.6-1.fc28.x86_64 and python3-libs-3.7.1-1.fc29.x86_64
  - cannot install both python3-libs-3.6.5-1.fc28.x86_64 and python3-libs-3.7.1-1.fc29.x86_64
  - package python3-3.7.1-1.fc29.x86_64 requires python3-libs(x86-64) = 3.7.1-1.fc29, but none of the providers can be installed
  - cannot install both python3-3.6.6-1.fc28.x86_64 and python3-3.7.1-1.fc29.x86_64
  - cannot install both python3-3.6.5-1.fc28.x86_64 and python3-3.7.1-1.fc29.x86_64
  - package python3-pyqt5-sip-4.19.12-9.fc29.x86_64 requires python(abi) = 3.7, but none of the providers can be installed
  - problem with installed package python3-pyqt5-sip-4.19.12-9.fc29.x86_64
 Problema 3: conflicting requests
  - cannot install both hplip-common-3.18.6-9.fc28.x86_64 and hplip-common-3.18.6-9.fc29.x86_64
  - cannot install both hplip-common-3.18.3-1.fc28.x86_64 and hplip-common-3.18.6-9.fc29.x86_64
  - package hplip-libs-3.18.6-9.fc29.x86_64 requires hplip-common(x86-64) = 3.18.6-9.fc29, but none of the providers can be installed
  - package libsane-hpaio-3.18.6-9.fc29.x86_64 requires hplip-libs(x86-64) = 3.18.6-9.fc29, but none of the providers can be installed
  - problem with installed package libsane-hpaio-3.18.6-9.fc29.x86_64
  - package libsane-hpaio-3.18.6-9.fc28.x86_64 requires hplip-libs(x86-64) = 3.18.6-9.fc28, but none of the providers can be installed
  - package libsane-hpaio-3.18.3-1.fc28.x86_64 requires hplip-libs(x86-64) = 3.18.3-1.fc28, but none of the providers can be installed
  - package hplip-libs-3.18.6-9.fc28.x86_64 requires python(abi) = 3.6, but none of the providers can be installed
  - package hplip-libs-3.18.3-1.fc28.x86_64 requires python(abi) = 3.6, but none of the providers can be installed
  - package python3-3.6.6-1.fc28.i686 requires python3-libs(x86-32) = 3.6.6-1.fc28, but none of the providers can be installed
  - package python3-3.6.5-1.fc28.i686 requires python3-libs(x86-32) = 3.6.5-1.fc28, but none of the providers can be installed
  - package python3-libs-3.6.6-1.fc28.i686 requires libgdbm.so.5, but none of the providers can be installed
  - package python3-libs-3.6.6-1.fc28.i686 requires libgdbm_compat.so.4, but none of the providers can be installed
  - package python3-libs-3.6.5-1.fc28.i686 requires libgdbm.so.5, but none of the providers can be installed
  - package python3-libs-3.6.5-1.fc28.i686 requires libgdbm_compat.so.4, but none of the providers can be installed
  - gdbm-libs-1:1.14.1-4.fc28.i686 has inferior architecture
  - cannot install both gdbm-libs-1:1.14.1-4.fc28.x86_64 and gdbm-libs-1:1.18-1.fc29.x86_64
  - package python2-libs-2.7.15-11.fc29.x86_64 requires libgdbm.so.6()(64bit), but none of the providers can be installed
  - cannot install both python3-3.6.6-1.fc28.x86_64 and python3-3.7.1-1.fc29.x86_64
  - cannot install both python3-3.6.5-1.fc28.x86_64 and python3-3.7.1-1.fc29.x86_64
  - package python2-2.7.15-11.fc29.x86_64 requires python2-libs(x86-64) = 2.7.15-11.fc29, but none of the providers can be installed
  - package python3-pyyaml-4.2-0.1.b4.fc29.x86_64 requires python(abi) = 3.7, but none of the providers can be installed
  - package python-unversioned-command-2.7.15-11.fc29.noarch requires python2 = 2.7.15-11.fc29, but none of the providers can be installed
  - problem with installed package python3-pyyaml-4.2-0.1.b4.fc29.x86_64
  - problem with installed package python-unversioned-command-2.7.15-11.fc29.noarch
(prova ad aggiungere '--allowerasing' alla linea di comando per sostituire i pacchetti in conflitto o '--skip-broken' per saltare i pacchetti non installabili)

Per quel poco che ci posso capire mi pare che il downgrade in questo caso non possa essere una soluzione percorribile. C'è un'altra strada?
Mi conviene pensare ad una stampante nuova (anche se sarebbe un peccato, la stampante per ora funziona e al limite posso scansionare direttamente su scheda di memoria ma la scansione salva solo in jpg)?

Grazie

Ultima modifica di jack_71 (26-04-2019 19:10:15)

Non in linea

#2 03-11-2018 23:04:33

tempus
Moderatore
Da Lombardia
Registrato: 16-11-2010
Messaggi: 2'312

Re: [Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

jack_71 ha scritto:

Buonasera a tutti, apro questa discussione in questa sezione in quanto non vedo ancora una sezione dedicata a F29.
[...]

Sezione prontamente creata grazie al buon frafra, discussione spostata

[...]downgrade di hplip alla versione 3.17.9-2 di F27[...]

Ho rigenerato al volo il pacchetto per F29 usando copr e ho cambiato il valore Epoch. I pacchetti così generati prevalgono su pacchetti hplip attualmente installati, ancorché abbiano versione successiva.

# dnf install hplip
# dnf copr enable temporalia/hplip_legacy 
# dnf upgrade

Glisso su indagini circa l'opportunità di questo downgrade, la cui necessità assumo sia stata preventivamente indagata e che, in senso stretto, esula dall'argomento scelto per la discussione.

Sconsiglio quanto segue da qua in poi

In teoria

# dnf downgrade --allowerasing --disablerepo=fedora-modular --disablerepo=updates-modular --release 27 "hplip*" 

sembrerebbe ovviare al primo errore in DNF che hai riscontrato. Tale operazione tuttavia trascinerebbe una elevata serie di dipendenze da F27. L'ultima versione per F27 è 3.18.6-5.fc27, per la versione 3.17.9-2.fc27 si dovrebbe pure disabilitare il repo updates e questo forzerebbe un downgrade ancora più gravoso, tale da travolgere anche systemd.
Sconsiglio di effettuare questo downgrade. Illustro questa opzione solo per evidenziare come un semplice downgrade a ben due release precedenti può trascinare con sé elementi vitali del sistema operativo, è operazione da controllare con cura.

Un'altra opzione parrebbe essere

# dnf download --disablerepo=fedora-modular --disablerepo=updates-modular --disablerepo=updates --release 27 "hplip*.x86_64"
# rpm -Uvh ./hplip-* --nodeps --force

È  una procedura poco ortodossa e relativamente meno pericolosa, ma potrebbe condurre a esiti incerti anche se l'eventuale area problematica sarebbe comunque circoscritta ad hplip.
Sconsiglio anche questo approccio.


$ apropos [argomento]                         $ man [voce del manuale]
https://docs.fedoraproject.org/     |     https://apps.fedoraproject.org/     |     https://doc.fedoraonline.it

In linea

#3 04-11-2018 16:02:27

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 24

Re: [Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

Innanzitutto grazie per i pacchetti; ho seguito le istruzioni hai indicato e bloccato la versione dei pacchetti e adesso lo scanner funziona. Evidentemente dalla versione 3.18 per qualche motivo la parte scanner della multifunzione non va, pur funzionando correttamente la stampante. Non so se perdo qualcosa di particolare usando una versione più datata. Passare ad un'altra stampante non sarebbe stato un grosso problema visto i costi limitati che hanno adesso ma cambiare una periferica che ancora funziona e considerato che non ne faccio un utilizzo intensivo sarebbe stato un peccato.
Quanto agli altri due esempi, li tengo come cultura; onestamente non essendo troppo esperto quando inizio a vedere troppi messaggi che non capisco a fondo preferisco non procedere, in particolare quando pare vengano toccate delle librerie visto che il sistema pare comunque funzionare egregiamente.

Grazie ancora per il supporto

Non in linea

#4 20-01-2019 17:14:48

MotoBruno
Fedora nel sangue
Da Svizzera Mendrisio
Registrato: 23-12-2007
Messaggi: 1'011

Re: [Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

Ciao a tutti.
Mi accodo a questa discussione in quanto si tratta sempre di HPLIP.
Ho usato l'installazione automatica ieri e durante la stessa mi ha avvisato che avrebbe usato dei pacchetti di f28 (io uso f29) e alla fine dell'installazione mi avvisa che non puó installare un plugin per mancanza del system tray. Che cos'é e come posso ovviare?
Per il resto, stampa e scanning funzionano bene.
Grazie

Non in linea

#5 25-04-2019 22:46:30

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 24

Re: [Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

Buonasera a tutti,

riporto in vita questo thread in quanto con l'arrivo prossimo di F30 (a cui ho già aggiornato il sistema) si ripropone  il problema dello scanner. Con l'aggiornamento del sistema le versioni installate sono:

hplip-3.18.12-9.fc30.x86_64
hplip-common-3.18.12-9.fc30.x86_64
hplip-libs-3.18.12-9.fc30.x86_64
libsane-hpaio-3.18.12-9.fc30.x86_64

Come già con l'aggiornamento a F29 lo scanner non funziona, al tempo la soluzione era stata i files nella versione 3.17.9-2 rigenerata appositamente per F29 gentilmente da tempus; come si può procedere per avere la stessa versione anche per F30 (lo stesso problema poi immagino mi si riproporrà anche per le versioni successive, almeno finché non cambierò hardware)?

Grazie

Non in linea

#6 26-04-2019 15:58:14

tempus
Moderatore
Da Lombardia
Registrato: 16-11-2010
Messaggi: 2'312

Re: [Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

Ripercorri il post #2, dovrebbe essere sufficiente.
L'ultimo SRPM utilizzato per le build (e riciclabile per build future) lo puoi ottenere sempre da copr.


$ apropos [argomento]                         $ man [voce del manuale]
https://docs.fedoraproject.org/     |     https://apps.fedoraproject.org/     |     https://doc.fedoraonline.it

In linea

#7 26-04-2019 19:09:47

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 24

Re: [Risolto] Downgrade hplip per fuzionamento scanner su multifunzione HP

Perfetto!

Grazie mille per il supporto.

Non in linea

Piè di pagina