Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 24-03-2019 15:53:23

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Domande sparse qui raccolte

Salve. Sto facendo il mio primo giro su Fedora 29 ed ho alcuni problemi che riassumo.

Primo: on trovo i miei programmi fra quelli disponibili nel package manager di Gnome. Non trovo Shotcut, non trovo VLC, Avidemux, DisplayCAL ed i plugin di GIMP. Non li trovo né cercandoli per nome, nè scorrendo tutte le rispettive categorie. Tra l'altro Avidemux, DisplayCAL ed i plugin di GIMP sono presenti nel gestore software di Fedora 29 Cinnamon. Non accedono, tutti i DE, alle stesse repository? In Gnome le repo terze sono attive.

Secondo: l'installer non imposta la pass di amministratore, tantomeno permette di farla corrispondere a quella utente. Perciò non posso elevarmi a su ed installare COPR, dove avrei trovato Avidemux e DisplayCAL.

Terzo: assumendo che gli archivi .rpm siano l'equivalente dei .deb nelle derivate da Debian, chiedo come mai alcuni si installino correttamente (Master PDF, Lightworks, DaVinci) ed altri consistano di brevi script che con il double click lanciano l'app di gestione ma questa non installa alcunché, né comunica alcun errore; per esempio gli rpm binary di Avidemux.

Grazie in anticipo dell'attenzione.

EDIT
Non riesco a comprimere niente di accettabile in jpg entro 10 miseri KiloBytes per l'avatar. Resterebbero le solite gif o png a 4 colori...

Ultima modifica di AntonGiulioGiovanGianPaul (24-03-2019 16:10:33)

Non in linea

#2 24-03-2019 16:52:30

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'074
Sito web

Re: Domande sparse qui raccolte

Ciao e benvenuto su Fedora e su FOL!

1. Probabilmente ti mancano gli rpmfusion: https://rpmfusion.org/Configuration

Diventa root (vedi risposta 2, o usa direttamente sudo e prependilo al comando qui sotto):

# dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Fedora ha deciso di separare alcuni pacchetti contenenti componenti non-free in un repo a parte, in questo modo fedora e i suoi pacchetti nei repo base sono utilizzabili senza problemi di diritti/royalties.

Da terminale, per vlc ad es.:

# dnf install vlc

2. Per abilitare l'account di root in fedora c'e' una flag un po' nascosta nell'installer; personalmente quindi non ho dovuto fare questa operazione, ma teoreticamente dovresti poter accedere all'account root tramite sudo.
Ad es:

fatto, sei root!
Personalmente non mi piace usare sudo, lo considero una sicurezza in meno, pero' c'e' chi lo preferisce.
Se vuoi separare i tuoi account, definisci una password all'account root (diventando root come sopra) e poi con:

# passwd

oppure direttamente da utente:

$ sudo passwd root

e poi dovrai togliere il tuo account dal gruppo wheel, che e' quello che gli da la capacita' di impersonare root.

3. graficamente non so cosa succeda, anche perche' non ci hai detto che versione di fedora stai usando, se la workstation o una spin, e nemmeno da dove hai preso quei binari.
Da terminale con un

# dnf install /percorso/locale/al/pacchetto.rpm

dovresti vedere le motivazioni del perche' un'installazione e' fallita.
In ogni caso sconsiglio di installare rpm a mano, in quanto si tende poi ad avere un sistema piu' incasinato. Con gli rpmfusion e qualche copr solitamente si ha tutto cio' che serve per un uso "classico".


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#3 24-03-2019 20:20:15

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Re: Domande sparse qui raccolte

Grazie, in effetti mancava fusion; dopodiché ho installato quasi tutto. Infatti, al tentativo con DisplayCAL (via copr) il terminale ha risposto:

Copr repo for DisplayCAL owned by dschubert      59  B/s | 257  B     00:04    
Fedora Modular 29 - x86_64                       16 kB/s |  26 kB     00:01    
Fedora Modular 29 - x86_64 - Updates             15 kB/s |  23 kB     00:01    
Fedora 29 - x86_64 - Updates                     15 kB/s |  23 kB     00:01    
Fedora 29 - x86_64                               17 kB/s |  26 kB     00:01    
RPM Fusion for Fedora 29 - Free - Updates       6.2 kB/s | 8.8 kB     00:01    
RPM Fusion for Fedora 29 - Free                 7.4 kB/s |  10 kB     00:01    
RPM Fusion for Fedora 29 - Nonfree - Updates    6.4 kB/s | 8.9 kB     00:01    
RPM Fusion for Fedora 29 - Nonfree              7.3 kB/s |  11 kB     00:01    
No match for argument: DisplayCAL

https://copr.fedorainfracloud.org/coprs … isplayCAL/

Ciao.

Non in linea

#4 25-03-2019 10:11:41

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'074
Sito web

Re: Domande sparse qui raccolte

Bene per rpmfusion e per root.
Non ho capito DisplayCAL, non te lo trova nonostante il repo copr installato?


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#5 25-03-2019 15:52:07

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Re: Domande sparse qui raccolte

Non ho capito DisplayCAL, non te lo trova nonostante il repo copr installato?

Così sembra.

No match for argument: DisplayCAL

Non trovo nemmeno Opera ed i plug-in di Gimp, ma qui ho risolto prendendoli da un'altra distro e mettendoli in:
/home/AntonGiulioGiovanGianPaul/.config/GIMP/2.10/plug-ins/. Funzionano tutti meno DVP che si pianta con Gimp 2.10.8; In Fedora come altrove.

C'era il server lentissimo e la connessione si interrompeva di continuo. Dev'esser stato il micro-onde del maresciallo Lo Cascio. Riprovo appena posso.

non ci hai detto che versione di fedora stai usando, se la workstation o una spin, e nemmeno da dove hai preso quei binari

Credevo di si; anche se non in modo esplicito. La versione installata adesso è la 29 (Workstation) di default: quindi Gnome. Quella provata tempo fa, la 29 Cinnamon. Il gestore software era diverso, senza icone grafiche, ma sotto Gimp c'erano raggruppati una decina di plugin che nel gestore di Gnome 3.3 non appaiono.

I Binary di Avidemux li ho scaricati dal sito degli sviluppatori

Ciao

Ultima modifica di AntonGiulioGiovanGianPaul (25-03-2019 15:52:53)

Non in linea

#6 25-03-2019 16:13:31

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'074
Sito web

Re: Domande sparse qui raccolte

1. Per DisplayCAL, sembra che il tipo non abbia aggiornato il repo, anche se ci ha piazzato li' il file.
Dovresti risolvere puntando direttamente all'RPM:

# dnf install https://copr-be.cloud.fedoraproject.org/results/dschubert/DisplayCAL/fedora-29-x86_64/00726363-DisplayCAL/DisplayCAL-3.5.0.0-1.fc29.x86_64.rpm

e magari scrivendo un messaggio al tizio dicendogli di dare un 'createrepo' alle cartelle contenenti gli RPM.

2. Non so che plugin usi per gimp, ma con una rapida ricerca ne ho trovati un po' nei repo:

# dnf search gimp |grep -iB1 plug
gmic-gimp.x86_64 : G'MIC plugin for GIMP
gimp-data-extras.noarch : Extra files for GIMP
gimpfx-foundry.noarch : Additional GIMP plugins
gimp-elsamuko.noarch : Script collection for the GIMP
gimp-save-for-web.x86_64 : Save for web plug-in for GIMP
gimp-lensfun.x86_64 : Gimp plugin to correct lens distortion
gimp-devel.i686 : GIMP plugin and extension development kit
gimp-devel.x86_64 : GIMP plugin and extension development kit
gimp-separate+.x86_64 : Rudimentary CMYK support for The GIMP
gimp-resynthesizer.x86_64 : Gimp plug-in for texture synthesis
gimp-wavelet-denoise-plugin.x86_64 : Gimp wavelet denoise plugin
gimp-wavelet-decompose.noarch : Decomposing image plug-in for Gimp
gimp-high-pass-filter.noarch : High-pass filter script for the GIMP
gimp-layer-via-copy-cut.x86_64 : Layer via copy/cut plug-in for GIMP
gimp-lqr-plugin.x86_64 : Content-aware resizing plug-in for the GIMP
gimp-devel-tools.x86_64 : GIMP plugin and extension development tools
xsane-gimp.x86_64 : GIMP plug-in providing the SANE scanner interface
gimp-luminosity-masks.noarch : Luminosity mask channels plug-in for Gimp
ufraw-gimp.x86_64 : GIMP plugin to retrieve raw image data from digital cameras
gimp-dds-plugin.x86_64 : A plugin for GIMP allows you to load/save in the DDS
GREYCstoration-gimp.x86_64 : GREYCstoration image denoising and interpolation plugin for gimp
gimp-normalmap.x86_64 : Plugin that enabled the creation of normal maps
gimp-heif-plugin.x86_64 : A plugin for loading and saving HEIF images
gimp-fourier-plugin.x86_64 : A simple plug-in to do fourier transform on your image
gimp-focusblur-plugin.x86_64 : Simulate an out-of-focus blur
gutenprint-plugin.x86_64 : GIMP plug-in for gutenprint

Probabilmente scorrendoseli a mano ne troverai molti altri


3. Opera non lo trovi perche' non e' nei repo fedora ne in rpm fusion. ma gli sviluppatori di opera forniscono un repo con gli rpm che fanno loro a https://rpm.opera.com/rpm/

per installarlo:

# tee /etc/yum.repos.d/opera.repo <<RPMREPO
[opera]
name=Opera packages
type=rpm-md
baseurl=https://rpm.opera.com/rpm
gpgcheck=1
gpgkey=https://rpm.opera.com/rpmrepo.key
enabled=1
RPMREPO

# dnf install opera-stable

4. Avidemux lo trovi nei repo rpmfusion-free, lo puoi installare con un:

# dnf install avidemux

Ultima modifica di bebo_sudo (26-03-2019 10:01:26)


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#7 25-03-2019 19:45:21

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Re: Domande sparse qui raccolte

Grazie. Avidemux l'avevo già installato. Opera, OK.

Poi ho  collegato il cavo ethernet e fatto una ricerca per Gimp. Sono usciti molti plugin, quasi tutti. Di quelli che mi interessano c'è separate+, resynthesizer, wavelet-denoise, layer-via-copy-cut, liquid rescale, luminosity-masks, xsane, david's batch, GREYCstoration, focusblur. Però manca refocus, ad esempio.

La questione DisplayCAL è invece grave perché puntando l'rpm il programma si installa ma non si lancia: né dalla grafica né col terminale; ne DisplayCAL né le sei utilities a corredo.

L'ultima voce del log > applications:

"spice-vdagent
Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0"

Scriverò una mail all'autore, perché la calibrazione e profilazione del monitor è essenziale e non ci sono alternative su Liinux: meglio, ce n'è una ma richiede una sonda proprietaria.

Ciao.

Non in linea

#8 25-03-2019 23:08:33

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'074
Sito web

Re: Domande sparse qui raccolte

Lanciando DisplayCAL da terminale, da qualche informazione su quale errore potrebbe essere?

Se e' un programma che ti serve, potresti provare a compilartelo. Qui https://displaycal.net/#install dicono che basti un setup.py, forse perche' e' un programma python?


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#9 26-03-2019 15:32:03

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Re: Domande sparse qui raccolte

Lanciando DisplayCAL da terminale, da qualche informazione su quale errore potrebbe essere?

displaycal 3.5.0.0 2018-02-18T15:11:01.986371Z
fedora 29 Twenty Nine x86_64
Python 2.7.15 (default, Oct 15 2018, 15:26:09) 
[GCC 8.2.1 20180801 (Red Hat 8.2.1-2)]
ImportError: No module named faulthandler
ImportError: No module named wx

Traceback (most recent call last):
  File "/usr/bin/displaycal", line 6, in <module>
    main()
  File "/usr/lib64/python2.7/site-packages/DisplayCAL/main.py", line 92, in main
    from wxaddons import wx
  File "/usr/lib64/python2.7/site-packages/DisplayCAL/wxaddons.py", line 10, in <module>
    from wxfixes import wx
  File "/usr/lib64/python2.7/site-packages/DisplayCAL/wxfixes.py", line 19, in <module>
    import wx
ImportError: No module named wx
Warning: handle_error(): ImportError: No module named wx

Se e' un programma che ti serve, potresti provare a compilartelo. dicono che basti un setup.py, forse perche' e' un programma python?

Si è un programma python ma ho risolto scaricando l'rpm a questo indirizzo.

Prima, cioè prima di sovrascrivere la precedente installazione con l'ultima, DisplayCAL non compariva fra le app installate nel Gestore Software e non poteva essere disinstallato nemmeno dal terminale:

No match for argument: displaycal
Error: No packages marked for removal

Ora tutto a posto. Grazie

Ultima modifica di AntonGiulioGiovanGianPaul (26-03-2019 21:40:26)

Non in linea

#10 27-03-2019 10:28:10

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'074
Sito web

Re: Domande sparse qui raccolte

Penso non potesse essere disinstallato perche' si chiama DisplayCAL, e dnf/yum sono case-sensitive.

Quell'errore segnala la mancanza del modulo wx, ossia della libreria grafica wxPython. Il pacchetto RPM che hai installato a mano la richiede esplicitamente:

$ rpm -qpR /tmp/DisplayCAL.rpm 
..
wxPython >= 2.8.11

mentre quello da copr no:

$ rpm -qpR /tmp/DisplayCAL-3.5.0.0-1.fc29.x86_64.rpm |grep -i wx
$

Sarebbe da provare ad installare DisplayCAL da copr e il pacchetto python2-wxpython a parte, verificare se risolve, e segnalare anche questo sul copr.


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#11 27-03-2019 17:24:37

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Re: Domande sparse qui raccolte

Si DisplayCAL richiede wxPython, solo che  l'rpm di COPR non lo risolve. Installando prima python2-wxpython e poi DisplayCAL via repo il programma funziona. Resta la curiosità di sapere perché non compaia nel gestore grafico fra le applicazioni installate; dove invece appare quando installato a mano.

Per il 'case sensitive' (nella tipografia al piombo gli inglesi mettevano le maiuscole in alto nel cassetto dei caratteri) bisognerebbe mettersi daccordo, perché alcune applicazioni sono gestibili solo rispettando le maiuscole, altre solo quando chiamate in minuscolo...

$ Shotcut
bash: Shotcut: command not found...
Similar command is: 'shotcut'
$ LibreOffice
bash: LibreOffice: command not found...
Similar command is: 'libreoffice'

Ciao.

EDIT
DispayCAL non compare nel gestore software grafico nemmeno quando installato a mano.

Ultima modifica di AntonGiulioGiovanGianPaul (27-03-2019 21:17:02)

Non in linea

Piè di pagina