Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 06-05-2019 18:38:19

erika80
Pinguino avanzato
Registrato: 02-03-2006
Messaggi: 383

[Fedora 30] - Problemi Di Upgrade

Buongiorno a tutti,
so che sono nella sezione sbagliata ma non ho trovato quella dedicata alla versione 30 di fedora.
Vi presento in breve la casistica che mi si è presentata: cercando di eseguire da linea di comando l'upgrade alla nuova release (per inciso, in passato, gli upgrade alle precedenti vrsioni non hanno mai dato problemi).
Di seguito posto il codice e gli errori che ne sono usciti:

[[email protected] ~]# dnf upgrade --refresh
Adobe Systems Incorporated                      5.6 kB/s | 2.9 kB     00:00    
Fedora Modular 29 - x86_64                       23 kB/s |  25 kB     00:01    
Fedora Modular 29 - x86_64 - Updates             29 kB/s |  23 kB     00:00    
Fedora 29 - x86_64 - Updates                     19 kB/s |  23 kB     00:01    
Fedora 29 - x86_64                               36 kB/s |  25 kB     00:00    
RPM Fusion for Fedora 29 - Free - Updates       2.1 kB/s | 9.4 kB     00:04    
RPM Fusion for Fedora 29 - Free                 3.7 kB/s |  10 kB     00:02    
RPM Fusion for Fedora 29 - Nonfree - Updates    7.4 kB/s | 9.6 kB     00:01    
RPM Fusion for Fedora 29 - Nonfree               20 kB/s |  10 kB     00:00    
skype (stable)                                  7.0 kB/s | 2.9 kB     00:00    
TeamViewer - x86_64                              13 kB/s | 2.5 kB     00:00    
Fedora 29 - x86_64 - VirtualBox                  13 kB/s | 2.9 kB     00:00    
Dependencies resolved.
Nothing to do.
Complete!
[[email protected] ~]# dnf install dnf-plugin-system-upgrade
Package python3-dnf-plugin-system-upgrade-4.0.4-1.fc29.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[[email protected] ~]# dnf system-upgrade download --releasever=30
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Adobe Systems Incorporated                      760  B/s | 2.9 kB     00:03    
Fedora Modular 30 - x86_64                       23 kB/s |  19 kB     00:00    
Fedora Modular 30 - x86_64 - Updates             20 kB/s |  23 kB     00:01    
Fedora 30 - x86_64 - Updates                     54 kB/s |  24 kB     00:00    
Fedora 30 - x86_64                               22 kB/s |  18 kB     00:00    
RPM Fusion for Fedora 30 - Free - Updates        21 kB/s | 9.4 kB     00:00    
RPM Fusion for Fedora 30 - Free                  12 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree - Updates     22 kB/s | 9.6 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree               26 kB/s |  10 kB     00:00    
skype (stable)                                  5.9 kB/s | 2.9 kB     00:00    
TeamViewer - x86_64                              13 kB/s | 2.5 kB     00:00    
Fedora 30 - x86_64 - VirtualBox                  34 kB/s | 6.9 kB     00:00    
Failed to synchronize cache for repo 'virtualbox'
Ignoring repositories: virtualbox
Error: 
 Problem 1: package python2-hawkey-0.31.0-2.fc29.x86_64 requires libdnf(x86-64) = 0.31.0-2.fc29, but none of the providers can be installed
  - libdnf-0.31.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-hawkey-0.31.0-2.fc29.x86_64
 Problem 2: package python3-hawkey-0.28.1-1.fc30.x86_64 requires libdnf(x86-64) = 0.28.1-1.fc30, but none of the providers can be installed
  - cannot install both libdnf-0.28.1-1.fc30.x86_64 and libdnf-0.31.0-2.fc29.x86_64
  - problem with installed package python3-hawkey-0.31.0-2.fc29.x86_64
  - package python2-libdnf-0.31.0-2.fc29.x86_64 requires libdnf(x86-64) = 0.31.0-2.fc29, but none of the providers can be installed
  - python3-hawkey-0.31.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-libdnf-0.31.0-2.fc29.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

posso chiedere qualche consiglio in merito?
In particolare non vorrei che seguendo i suggerimenti dati nella shell poi il sistema diventasse instabile o qualcosa di peggio.
Grazie in anticipo.
Erika.

Edit: discussione spostata in sezione F30

Ultima modifica di tempus (10-05-2019 11:57:46)

Non in linea

#2 06-05-2019 19:46:35

QuarkF
Pinguino avanzato
Registrato: 01-04-2013
Messaggi: 270

Re: [Fedora 30] - Problemi Di Upgrade

Se segui il consiglio in fondo al codice che hai riportato?

erika80 ha scritto:
try to add '--allowerasing' to command line to replace conflicting packages

Ovvero

# dnf system-upgrade download --releasever=30 --allowerasing

Fai solo attenzione, prima di dare la conferma, a cosa propone di rimuovere.
A me capita di dover aggiungere "--allowerasing" praticamente a tutti i salti di versione.


Al mondo ci sono 10 tipi di persone: quelle che conoscono la numerazione binaria e quelle che non la capiscono.

In linea

#3 07-05-2019 07:58:48

erika80
Pinguino avanzato
Registrato: 02-03-2006
Messaggi: 383

Re: [Fedora 30] - Problemi Di Upgrade

Buongiorno,
grazie mille per il consiglio in questo momento sto eseguendo la procedura di upgrade e vediamo che ne esce.
Grazie ancora millissime ed a dopo (spero) smile
Erika

Non in linea

#4 07-05-2019 11:19:10

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 679

Re: [Fedora 30] - Problemi Di Upgrade

oltre a "--allowerasing" converrebbe aggiungere anche

 -- best 

e poi è consigliato escludere ,per l'aggiornamento, i repo non Fedora

 dnf config-manager --set-disabled nomerepository 

finito aggiornamento

 dnf config-manager --set-enabled nomerepository 

ciao

Ultima modifica di yum_yoshi (07-05-2019 11:24:37)

Non in linea

Piè di pagina