Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 04-12-2019 16:34:25

ElCriptado
Innamorato del forum
Registrato: 26-02-2008
Messaggi: 740

aggiornamento di transito

Salve a tutti. Sto aggiornando su un PC di un amico che è da molto che non aggiorna perché non ha usato il PC, ma adesso gli serve. Passo gradatamente da fedora 27 a 30. Lui ha un altro PC uguale che ha già portato a fedora 30. In questo invece appare questo bel messaggio:
dnf system-upgrade download --releasever=28
Sincronizzazione cache non riuscita per il repo 'folkswithhats', disabilitazione in corso.
Ultima verifica della scadenza dei metadati: 0:00:00 fa il mer 04 dic 2019 16:03:28 CET.
Errore:
Problema: nss-pem-1.0.3-6.fc27.i686 has inferior architecture
  - nss-pem-1.0.3-6.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-6.fc27.i686

Non capisco quale sia il problema e come fare per superarlo. Il PC è a 64 bit, e io ho installato ad entrambi i PC gemelli lo stesso software a 64 bit. Che c'entra i686?

E' installata Fedora 27 spin LXDE.

Ultima modifica di ElCriptado (04-12-2019 16:39:08)

Non in linea

#2 04-12-2019 16:57:13

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'715

Re: aggiornamento di transito

Ciao, trattandosi di un solo pacchetto io proverei a disinstallarlo

 # dnf remove --assumeno nss-pem-1.0.3-6.fc27.i686

per controllare cosa si porta dietro e se non è l'intero S.O.

 # dnf remove nss-pem-1.0.3-6.fc27.i686

una volta arrivato a Fedora 30 (fatta la 30 perchè non fare la 31? smile ) reinstallarlo (se necessario dopo aver riabilitato il repo)

# dnf install nss-pem

E controlla che il repo  'folkswithhats' sia effettivamente disabilitato prima di continuare gli aggiornamenti.


Ciao
Andrea Malfatti

Non in linea

Piè di pagina