Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 25-04-2005 08:26:32

InfoFedora
Appena sbarcato sul forum
Registrato: 19-04-2005
Messaggi: 80

aMule

Prima di installare aMule ho installato da http://www.amule.org/files/files.php?cat=12 il file wxGTK-2.6.0-1.i686.rpm; nonostante sia scritto che con una versione >=2.5.x non sia necessario installare wxBase, in fase di installazione di aMule si blocca in quanto richiede il file wxBase.
Allora ho scaricato anche il file wxBase-2.4.2-1.i586.rpm   sempre dalla stessa pagina del sito.
A questo punto ho installato facendo un doppio clic sul file aMule-2.0.0rc8-1.i586-FC3.rpm; poi ho riavviato il computer e in Applicazioni--->Internet c'è la voce aMule, aLink Creator e wxCas.
Però se clicco sopra a qualsiasi di queste 3 voci, non succede nulla.
Allora come root ho fatto queste operazioni:

[[email protected] ~]# cd /
[[email protected] /]# amule
amule: error while loading shared libraries: libwx_gtk-2.4.so.0: cannot open shared object file: No such file or directory
[[email protected] /]# whereis amule
amule: /usr/bin/amule
[[email protected] /]# locate aMule
/aMule-2.0.0rc8-1.i586-FC3.rpm

Cosa posso fare?

Non in linea

#2 25-04-2005 11:22:17

robyduck
Fedora Ambassador
Registrato: 08-12-2004
Messaggi: 8'023
Sito web

Re: aMule

Personalmente ho installato wxgtk 2.42-5.1 ma non wxbase...e amule gira a meraviglia...l'ho installato con Yum, prova.

Non in linea

#3 25-04-2005 16:21:01

InfoFedora
Appena sbarcato sul forum
Registrato: 19-04-2005
Messaggi: 80

Re: aMule

Ciao Robydicck
Mi spieghi allora la procedura per eliminare i 3 file che ho scaricato e installato? wxGTK-2.6.0-1.i686.rpm   wxBase-2.4.2-1.i586.rpm e  aMule-2.0.0rc8-1.i586-FC3.rpm?
E installare da zero aMule?

[[email protected] ~]# yum install wxgtk
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[[email protected] ~]#

[[email protected] ~]# yum check-update wxgtk
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[[email protected] ~]# whereis wxgtk
wxgtk:
[[email protected] ~]# locate wxgtk
[[email protected] ~]#

[[email protected] ~]# yum install wxBase
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[[email protected] ~]# whereis wxBase
wxBase:
[[email protected] ~]# locate wxBase
/usr/share/doc/packages/wxBase-2.4.2
/usr/share/doc/packages/wxBase-2.4.2/README.txt
/usr/share/doc/packages/wxBase-2.4.2/COPYING.LIB
/usr/share/doc/packages/wxBase-2.4.2
[[email protected] ~]#
[[email protected] ~]# yum check-update wxBase
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[[email protected] ~]#

Non in linea

#4 25-04-2005 17:38:24

InfoFedora
Appena sbarcato sul forum
Registrato: 19-04-2005
Messaggi: 80

Re: aMule

E' corretto come ho fatto? Ti posto la sessione

Analizzo se sono stati installati i 2 pacchetto RPM precedenti all'installazione di aMule:
[[email protected] ~]# rpm -qa wxBase
wxBase-2.4.2-1
[[email protected] ~]# rpm -qa wxGTK
wxGTK-2.6.0-1

Ora procedo con la disinstallazione degli stessi
[[email protected] ~]# yum remove wxBase
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package wxBase.i586 0:2.4.2-1 set to be erased
--> Running transaction check
Setting up Repos
dries                     100% |=========================|  951 B    00:00
dag                       100% |=========================| 1.1 kB    00:00
livan-stable              100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
updates-released          100% |=========================|  951 B    00:00
freshrpms                 100% |=========================|  951 B    00:00
xcyb-stable               100% |=========================|  951 B    00:00
Reading repository metadata in from local files
dries     : ################################################## 1307/1307
dag       : ################################################## 2216/2216
livan-stab: ################################################## 155/155
base      : ################################################## 2622/2622
updates-re: ################################################## 872/872
freshrpms : ################################################## 483/483
xcyb-stabl: ################################################## 34/34
--> Processing Dependency: wxBase >= 2.4.2 for package: aMule
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package aMule.i586 0:2.0.0-rc8_fc3 set to be erased
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Remove: wxBase.i586 0:2.4.2-1
  Remove: aMule.i586 0:2.0.0-rc8_fc3
Total download size: 0
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing: wxBase 1/2
Erasing: aMule 2/2

Removed: wxBase.i586 0:2.4.2-1
Dependency Removed: aMule.i586 0:2.0.0-rc8_fc3
Complete!
[[email protected] ~]# yum remove wxGTK
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package wxGTK.i686 0:2.6.0-1 set to be erased
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Remove: wxGTK.i686 0:2.6.0-1
Total download size: 0
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing: wxGTK 1/1

Removed: wxGTK.i686 0:2.6.0-1
Complete!
[[email protected] ~]# yum remove aMule
Setting up Remove Process
No Packages marked for removal
[[email protected] ~]# yum remove wxBase
Setting up Remove Process
No Packages marked for removal
[[email protected] ~]# yum remove wxGTK
Setting up Remove Process
No Packages marked for removal

Ora verifico se li ha tolti veramente:
[[email protected] ~]# rpm -qa aMule
[[email protected] ~]# rpm -qa wxBase
[[email protected] ~]# rpm -qa wxGTK
Bene li ha tolti :-)

[[email protected] ~]# whereis wxGTK
wxGTK:
[[email protected] ~]# whereis wxBase
wxBase:
[[email protected] ~]# whereis aMule
aMule:

Ora uso il comando locate x eventuali file sparsi nel sistema
[[email protected] ~]# locate wxGTK
/var/cache/yum/freshrpms/headers/wxGTK-2.4.2-5.1.fc3.fr.i386.hdr
/var/cache/yum/freshrpms/packages/wxGTK-2.4.2-5.1.fc3.fr.i386.rpm
/usr/share/doc/packages/wxGTK-2.6.0
/usr/share/doc/packages/wxGTK-2.6.0/INSTALL.txt
/usr/share/doc/packages/wxGTK-2.6.0/README.txt
/usr/share/doc/packages/wxGTK-2.6.0/COPYING.LIB
/usr/share/doc/packages/wxGTK-2.6.0/README-GTK.txt
/usr/share/doc/packages/wxGTK-2.6.0

[[email protected] ~]# locate wxBase
/usr/share/doc/packages/wxBase-2.4.2
/usr/share/doc/packages/wxBase-2.4.2/README.txt
/usr/share/doc/packages/wxBase-2.4.2/COPYING.LIB
/usr/share/doc/packages/wxBase-2.4.2

[[email protected] ~]# locate aMule
/aMule-2.0.0rc8-1.i586-FC3.rpm
/usr/share/amuleweb/aMule.tmpl
/usr/share/doc/aMule-2.0.0rc8
/usr/share/doc/aMule-2.0.0rc8/ABOUT-NLS
/usr/share/doc/aMule-2.0.0rc8/license.txt
/usr/share/doc/aMule-2.0.0rc8/Doxyfile
/usr/share/doc/aMule-2.0.0rc8/README
/usr/share/doc/aMule-2.0.0rc8/amulesig.txt
/usr/share/doc/aMule-2.0.0rc8/Changelog
/usr/share/doc/aMule-2.0.0rc8/socks4.protocol
/usr/share/doc/aMule-2.0.0rc8/ED2K-Links.HOWTO
/usr/share/doc/aMule-2.0.0rc8/TODO
/usr/share/doc/aMule-2.0.0rc8/INSTALL
/usr/share/doc/aMule-2.0.0rc8/EC_Protocol.txt
/usr/share/doc/aMule-2.0.0rc8/amule-win32.HOWTO.txt
/usr/share/doc/aMule-2.0.0rc8
[[email protected] ~]#

Ora immagino che debba cancellare tutti i file che si vedono col comando locate, giusto?
Poi passare all'installazione del file che hai scritto tu (wxGTK 2.42-5.1) ed infine a quello del programma vero e proprio (aMule-2.0.0rc8-1.i586-FC3.rpm)

Attendo notizie prima di iniziare

Non in linea

#5 25-04-2005 17:57:45

robyduck
Fedora Ambassador
Registrato: 08-12-2004
Messaggi: 8'023
Sito web

Re: aMule

Sì la procedura per l'eliminazione dei pacchetti è corretta, può darsi che ti lasci qualche cartella (come giustamente hai verificato con locate) ma non importa più di tanto se vuoi reinstallarlo lo stesso. Ci scrive sopra perché è la stessa versione (l'ultima), giusto?
Non devi installarti i pacchetti prima e poi amule, se no Yum a cosa serve? Fai direttamente un Yum install amule e dai invio, se manca qualche pacchetto Yum te lo dirà e ti chiederà se proseguire con tutto. Una volta che dici di sì installa tutti i pacchetti necessari.
Buon Yum!

Non in linea

#6 25-04-2005 18:32:45

InfoFedora
Appena sbarcato sul forum
Registrato: 19-04-2005
Messaggi: 80

Re: aMule

fatto ;-)

Non in linea

Piè di pagina