#1 18-08-2017 08:40:21

martin
Innamorato del forum
Da Firenze
Registrato: 02-06-2008
Messaggi: 901

errore in fase di upgrade

Ciao a tutti, aggiornando da f24 a f 25 è andata via la corrente al portatile  per un mio errore mentre stava aggiornando  i file.
Ho cercato  di ricominciare ma mi da il seguente errore

[casacoppola@localhost ~]$ su -
Password: 
[root@localhost ~]# dnf system-upgrade download --releasever=25
Ultima verifica della scadenza dei metadati: 1:52:04 fa il Fri Aug 18 07:43:24 2017.
Dipendenze risolte.
Errore: L'operazione porterà alla rimozione dei seguenti pacchetti protetti: systemd, dnf, sudo, systemd-udev.
[root@localhost ~]# dnf system-upgrade reboot
Errore: system is not ready for upgrade
[root@localhost ~]# dnf system-upgrade download --releasever=25
Ultima verifica della scadenza dei metadati: 1:53:01 fa il Fri Aug 18 07:43:24 2017.
Dipendenze risolte.
Errore: L'operazione porterà alla rimozione dei seguenti pacchetti protetti: systemd-udev, sudo, systemd, dnf.
[root@localhost ~]# 

cosa posso fare  ?

grazie  a tutti

martino


"I care"

martin

Non in linea

#2 18-08-2017 10:08:35

frafra
Amministratore
Da Milano
Registrato: 14-05-2014
Messaggi: 2'009
Sito web

Re: errore in fase di upgrade

Prova a fare prima un normale aggiornamento e poi un distro-sync.

Non in linea

#3 18-08-2017 10:14:49

martin
Innamorato del forum
Da Firenze
Registrato: 02-06-2008
Messaggi: 901

Re: errore in fase di upgrade

[root@localhost ~]# dnf system-upgrade download --releasever=25 --distro-sync
Ultima verifica della scadenza dei metadati: 3:30:10 fa il Fri Aug 18 07:43:24 2017.
Dipendenze risolte.
Errore: L'operazione porterà alla rimozione dei seguenti pacchetti protetti: systemd, sudo, dnf, systemd-udev.

fa la stessa cosa


"I care"

martin

Non in linea

#4 18-08-2017 10:17:39

frafra
Amministratore
Da Milano
Registrato: 14-05-2014
Messaggi: 2'009
Sito web

Re: errore in fase di upgrade

Intendevo i seguenti comandi:

# dnf upgrade
# dnf distro-sync

Brutta cosa quando salta la corrente, stiamo assistendo ad un po' troppi problemi di questo tipo.

Non in linea

#5 18-08-2017 10:22:06

martin
Innamorato del forum
Da Firenze
Registrato: 02-06-2008
Messaggi: 901

Re: errore in fase di upgrade

[root@localhost ~]# dnf upgrade
Ultima verifica della scadenza dei metadati: 1:26:51 fa il Fri Aug 18 09:52:21 2017.
Dipendenze risolte.
================================================================================
 Package             Arch        Versione              Repository          Dim.
================================================================================
Rimozione in corso:
 kernel              x86_64      4.4.14-200.fc22       @@commandline        0  
 kernel-core         x86_64      4.4.14-200.fc22       @@commandline       43 M
 kernel-modules      x86_64      4.4.14-200.fc22       @@commandline       18 M

Riepilogo della transazione
================================================================================
Rimossi  3 pacchetti

Dimensione installata: 61 M
Procedere [s/N]: s
Esecuzione del controllo di transazione
Controllo di transazione eseguito con successo.
Test di transazione in corso
Test di transazione eseguito con successo
Transazione in corso
  Eliminazione in corso                      : kernel-4.4.14-200.fc22.x86   1/3 
  Eliminazione in corso                      : kernel-modules-4.4.14-200.   2/3 
  Eliminazione in corso                      : kernel-core-4.4.14-200.fc2   3/3 
  Verifica in corso                          : kernel-4.4.14-200.fc22.x86   1/3 
  Verifica in corso                          : kernel-modules-4.4.14-200.   2/3 
  Verifica in corso                          : kernel-core-4.4.14-200.fc2   3/3 

Eliminati:
  kernel.x86_64 4.4.14-200.fc22            kernel-core.x86_64 4.4.14-200.fc22   
  kernel-modules.x86_64 4.4.14-200.fc22   

Completo!
[root@localhost ~]# dnf distro-sync
Ultima verifica della scadenza dei metadati: 1:27:59 fa il Fri Aug 18 09:52:21 2017.
Errore: package gnome-packagekit-common-3.22.1-2.fc25.x86_64 requires gnome-packagekit(x86-64) = 3.22.1-2.fc25, but none of the providers can be installed.
package gstreamer1-plugins-bad-free-gtk-1.10.5-1.fc25.x86_64 requires gstreamer1-plugins-bad-free = 1.10.5-1.fc25, but none of the providers can be installed.
package iproute-tc-4.11.0-1.fc25.x86_64 requires iproute(x86-64) = 4.11.0-1.fc25, but none of the providers can be installed.
package libcrypt-nss-2.24-9.fc25.x86_64 requires glibc(x86-64) = 2.24-9.fc25, but none of the providers can be installed.
package libpeas-gtk-1.20.0-3.fc25.x86_64 requires libpeas(x86-64) = 1.20.0-3.fc25, but none of the providers can be installed.
package libvirt-libs-2.2.1-2.fc25.x86_64 requires libxenlight.so.4.7()(64bit), but none of the providers can be installed.
problem with installed package nss-pem-1.0.3-3.fc25.i686.
package opencv-contrib-3.1.0-8.fc25.x86_64 requires libopencv_core.so.3.1()(64bit), but none of the providers can be installed.
package perl-libintl-perl-1.26-1.fc25.x86_64 requires perl(:MODULE_COMPAT_5.24.0), but none of the providers can be installed.
package python2-pycurl-7.43.0-6.fc25.x86_64 requires libcurl(x86-64) >= 7.51.0, but none of the providers can be installed.
package python2-rpm-4.13.0.1-1.fc25.x86_64 requires rpm-libs(x86-64) = 4.13.0.1-1.fc25, but none of the providers can be installed.
package systemd-pam-231-17.fc25.x86_64 requires systemd = 231-17.fc25, but none of the providers can be installed.
package libcrypt-nss-2.24-9.fc25.i686 requires glibc(x86-32) = 2.24-9.fc25, but none of the providers can be installed.
package python3-rpm-4.13.0.1-1.fc25.x86_64 requires rpm-libs(x86-64) = 4.13.0.1-1.fc25, but none of the providers can be installed
(provare ad aggiungere '--allowerasing' alla linea di comando per sostituire i pacchetti in conflitto)
[root@localhost ~]# 

stavolta non è colpa dell'enel- non avevo attaccato bene il cavo di alimentazione

[root@localhost ~]# dnf distro-sync --allowerasing
Ultima verifica della scadenza dei metadati: 2:02:08 fa il Fri Aug 18 09:52:21 2017.
Dipendenze risolte.
Errore: L'operazione porterà alla rimozione dei seguenti pacchetti protetti: sudo, systemd, systemd-udev, dnf.
[root@localhost ~]# 

Ultima modifica di martin (18-08-2017 10:55:32)


"I care"

martin

Non in linea

#6 18-08-2017 17:16:46

martin
Innamorato del forum
Da Firenze
Registrato: 02-06-2008
Messaggi: 901

Re: errore in fase di upgrade

per cancellare  ogni traccia dei pacchetti fc 25 ho provato a dare dnf clean packages ma non elimina nulla.

Ho visto che tutti i files stanno in var/lib/dnf/system-upgrade.

Se cancello  tutti questi files  sono in grado di ripartire dalla versione installata di fc24 e ricominciare ?

Se provassi a passare a fc26 cosa succederebbe ?

Grazie:  non mi vengono altre idee

aspetto  qualche indicazione: dopo aver fatto il grosso errore di partenza non voglio accumularne altri


"I care"

martin

Non in linea

#7 07-10-2017 11:34:37

marcomotta
Fedora nel sangue
Da Roma
Registrato: 18-01-2009
Messaggi: 2'674
Sito web

Re: errore in fase di upgrade

$ dnf repoquery --duplicates

La filosofia è una disciplina con obiettivi, ma senza regole. La matematica è una disciplina con regole, ma senza obiettivi.
Un giorno ho incontrato un uomo che non aveva né obiettivi né regole. Studiava filosofia della matematica.

Non in linea

Piè di pagina