#1 01-12-2017 19:02:52

olgraz
Pinguino avanzato
Da bracciano
Registrato: 24-02-2011
Messaggi: 323

Wifi non funziona

Buonasera a tutti,

Ho  installato F.26 lxqt su di un vecchio portatile Acer Extensa 5620z con un 1 G di ram, l'installazione è andata regolarmente l'unico problema il wifi  non funziona.
Qualcuno può aiutarmi?

Non in linea

#2 01-12-2017 20:06:47

antoniom
Fedora Ambassador
Da Varese provincia sud
Registrato: 05-09-2008
Messaggi: 519

Re: Wifi non funziona

olgraz ha scritto:

Buonasera a tutti,

Ho  installato F.26 lxqt su di un vecchio portatile Acer Extensa 5620z con un 1 G di ram, l'installazione è andata regolarmente l'unico problema il wifi  non funziona.
Qualcuno può aiutarmi?

sarebbe interessante sapere che scheda wi-fi monta: da terminale digita lspci e facci vedere il risultato (scommetterei che è una scheda broadcomm)

Ultima modifica di antoniom (01-12-2017 20:10:12)

Non in linea

#3 01-12-2017 20:23:48

olgraz
Pinguino avanzato
Da bracciano
Registrato: 24-02-2011
Messaggi: 323

Re: Wifi non funziona

Si è una Broadcom

[larisa@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 04)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 04)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 04)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 04)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 04)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 04)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f4)
00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 04)
02:00.0 Ethernet controller: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
04:00.0 Network controller: Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01)
0f:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0f:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
0f:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0f:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
[larisa@localhost ~]$ 

Non in linea

#4 01-12-2017 22:52:08

antoniom
Fedora Ambassador
Da Varese provincia sud
Registrato: 05-09-2008
Messaggi: 519

Re: Wifi non funziona

olgraz ha scritto:

Si è una Broadcom

[larisa@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 04)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 04)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 04)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 04)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 04)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 04)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f4)
00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 04)
02:00.0 Ethernet controller: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
04:00.0 Network controller: Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01)
0f:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0f:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
0f:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0f:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
[larisa@localhost ~]$ 

secondo me se installi akmod-wl  e kernel-devel tutto dovrebbe funzionare....

Non in linea

#5 01-12-2017 23:05:19

vinlinux
Appena sbarcato sul forum
Registrato: 16-11-2017
Messaggi: 80

Re: Wifi non funziona

antoniom ha scritto:

secondo me se installi akmod-wl  e kernel-devel tutto dovrebbe funzionare....

Concordo. Voglio solo ricordare all'OP che il pacchetto akmod-wl lo trova nei repo
RPMFusion (in particolare sono i nonfree) che se non hai già installato puoi
attivare con:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Sulla mia vm di Fedora 27 ottengo:

$ dnf info akmod-wl 
Last metadata expiration check: 0:06:12 ago on Fri 01 Dec 2017 10:53:58 PM CET.
Available Packages
Name         : akmod-wl
Version      : 6.30.223.271
Release      : 14.fc27
Arch         : x86_64
Size         : 5.5 M
Source       : wl-kmod-6.30.223.271-14.fc27.src.rpm
Repo         : rpmfusion-nonfree
Summary      : Akmod package for wl kernel module(s)
URL          : https://www.broadcom.com/support/download-search/?pf=Wireless+LAN+Infrastructure
License      : Redistributable, no modification permitted
Description  : This package provides the akmod package for the wl kernel modules.

e il link rimanda alle info sui moduli dei driver installabili da akmod-wl:

These packages contain Broadcom's IEEE 802.11a/b/g/n hybrid Linux.. device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based hardware

In grassetto quello che dovrebbe fare al caso nostro.

Ultima modifica di vinlinux (01-12-2017 23:54:11)


Il Fini non giustifica i Renzi - Anonimo

Non in linea

#6 02-12-2017 07:52:30

olgraz
Pinguino avanzato
Da bracciano
Registrato: 24-02-2011
Messaggi: 323

Re: Wifi non funziona

secondo me se installi akmod-wl  e kernel-devel tutto dovrebbe funzionare....

E come devo procedere con l'installazione, nel senso, cosa installo prima akmod-wl o kernel-devel?

Non in linea

#7 02-12-2017 22:32:02

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'610

Re: Wifi non funziona

olgraz ha scritto:

E come devo procedere con l'installazione, nel senso, cosa installo prima akmod-wl o kernel-devel?

Non ha impotanza l'ordine, lo sceglie il comando di installazione smile
In un terminale, da root, lancia questo comando

# dnf install akmod-wl kernel-devel

e oltre ai due pacchetti segnalati, se necessario installerai tutti i pacchetti dipendenti.


Ciao
Andrea Malfatti

Non in linea

#8 03-12-2017 09:04:52

olgraz
Pinguino avanzato
Da bracciano
Registrato: 24-02-2011
Messaggi: 323

Re: Wifi non funziona

Ho installato ambedue i pacchetti ma il wifi continua a non funzionare.

Non in linea

#9 03-12-2017 11:32:26

antoniom
Fedora Ambassador
Da Varese provincia sud
Registrato: 05-09-2008
Messaggi: 519

Re: Wifi non funziona

olgraz ha scritto:

Ho installato ambedue i pacchetti ma il wifi continua a non funzionare.


hai riavviato?? sarei curioso di vedere anche l'output di lsmod...

Non in linea

#10 06-12-2017 09:39:56

olgraz
Pinguino avanzato
Da bracciano
Registrato: 24-02-2011
Messaggi: 323

Re: Wifi non funziona

hai riavviato?? sarei curioso di vedere anche l'output di lsmod...

Purtroppo non posso soddisfare la tua curiosità, Il portatile si avvia ma lo schermo rimane nero. Illuminando lo schermo con una torcia si vede la scrivania, probabilmente e partita la lampada dell'illuminazione. Mi hanno detto che bisogna cambiare lo schermo ma per un computer così vecchio (12 anni circa) non vale la pena spenderci i soldi.

Grazie a tutti per le risposte, alla prossima.

Ultima modifica di olgraz (06-12-2017 23:46:03)

Non in linea

Piè di pagina