Fedora Online Forum

Lavori in corso! I nostri pinguini sono all'opera e risolveranno i problemi il prima possibile ;-)

#1 13-02-2018 18:59:50

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'646

[Risolto] Orologio di sistema, F27 e dualboot con windows 7

Salve a tutti,
ogni tanto, per utilizzare sketcup, sono obbligato ad avviare windows 7 (di sketcup ora c'è una versione online utilizzabile da qualsiasi SO ma lo ho trovato lento).
Passando da un SO all'altro l'ora di sistema su Fedora mi viene cambiata, dovrei dire al sistema di utilizzare l'orologio di sistema come UTC anzichè RTC (o è il contrario?) ma non trovo il file di configurazione o un system_config_qualcosa per farlo.
Avete qualche idea?
Grazie

Ultima modifica di andreamal (14-02-2018 23:20:48)


Ciao
Andrea Malfatti

Non in linea

#2 14-02-2018 17:46:07

d68qdq8dq
Pinguino avanzato
Registrato: 03-07-2014
Messaggi: 228

Re: [Risolto] Orologio di sistema, F27 e dualboot con windows 7

Dovresti aggiungere, se non ricordo male, nel file /etc/adjtime una linea contenente:

LOCAL

Non in linea

#3 14-02-2018 17:49:10

frafra
Amministratore
Da Milano
Registrato: 14-05-2014
Messaggi: 2'249
Sito web

Re: [Risolto] Orologio di sistema, F27 e dualboot con windows 7

Linux parte dal presupposto che l'orologio sia UTC, Windows pensa sia l'ora locale roll
Il mio consiglio è quello di dire a Windows di usare UTC (mi pare si possa da 7 in poi). In alternativa:

# timedatectl set-local-rtc 1

Non in linea

#4 14-02-2018 23:20:04

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'646

Re: [Risolto] Orologio di sistema, F27 e dualboot con windows 7

d68qdq8dq ha scritto:

Dovresti aggiungere, se non ricordo male, nel file /etc/adjtime una linea contenente:

LOCAL

Il "LOCAL" c'è già sad

$ cat /etc/adjtime 
0.000000 1518530404 0.000000
1518530404
LOCAL
frafra ha scritto:

Linux parte dal presupposto che l'orologio sia UTC, Windows pensa sia l'ora locale roll
Il mio consiglio è quello di dire a Windows di usare UTC (mi pare si possa da 7 in poi). In alternativa:

# timedatectl set-local-rtc 1

E si che windows sia una piaga (e non solo per l'orologio) lo so, alla fine ho impostato su windows l'orologio come UTC, però ho un timore, non è che con un aggiornamento me lo ripristino come RTC? soprattutto in ufficio dove devo usare windows mi è capitato di dover reimpostare qualche opzione solo perché alla MS pensano che sia meglio.

Per chi fosse interessato si deve creare una voce nel registro oppure creare un file di testo utc.reg con questo contenuto:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001

e riavviare windows


Ciao
Andrea Malfatti

Non in linea

Piè di pagina