Fedora Online Forum

Lavori in corso! I nostri pinguini sono all'opera e risolveranno i problemi il prima possibile ;-)

#1 05-03-2018 22:13:42

silvio
Fedora nel sangue
Da Mercato San Severino (Sa)
Registrato: 05-01-2007
Messaggi: 1'305

Upgrade da F26 a F27 controllo transizione segnala errore php-composer

Come scritto nell'oggetto sto cercando di upgradare la mia f26 32bit a f27.
Quando arriva al amomento del controllo transizione succede questo (le righe che riporto sono circa la metà del totale):

Esecuzione del controllo di transazione
Errore: controllo di transazione vs risoluzione dipendenze:
(php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2) necessario a php-phpunit-mock-objects5-5.0.6-3.fc27.noarch
(php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2) necessario a php-phpunit-mock-objects5-5.0.6-3.fc27.noarch
(php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4) necessario a php-phpunit-mock-objects5-5.0.6-3.fc27.noarch
(php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(composer/semver) >= 1.0 with php-composer(composer/semver) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(seld/cli-prompt) >= 1.0 with php-composer(seld/cli-prompt) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(seld/phar-utils) >= 1.0 with php-composer(seld/phar-utils) < 2) necessario a composer-1.6.3-1.fc27.noarch
(php-composer(google/recaptcha) >= 1.1 with php-composer(google/recaptcha) < 2) necessario a phpMyAdmin-4.7.8-1.fc27.noarch
(php-composer(phpmyadmin/motranslator) >= 4.0 with php-composer(phpmyadmin/motranslator) < 5) necessario a phpMyAdmin-4.7.8-1.fc27.noarch
(php-composer(phpmyadmin/shapefile) >= 2.0 with php-composer(phpmyadmin/shapefile) < 3) necessario a phpMyAdmin-4.7.8-1.fc27.noarch
(php-composer(phpmyadmin/sql-parser) >= 4.2.3 with php-composer(phpmyadmin/sql-parser) < 5) necessario a phpMyAdmin-4.7.8-1.fc27.noarch
(php-composer(phpseclib/phpseclib) >= 2.0.9 with php-composer(phpseclib/phpseclib) < 3) necessario a phpMyAdmin-4.7.8-1.fc27.noarch
(php-composer(tecnickcom/tcpdf) >= 6.2 with php-composer(tecnickcom/tcpdf) < 7) necessario a phpMyAdmin-4.7.8-1.fc27.noarch
(php-composer(doctrine/instantiator) >= 1.0.4 with php-composer(doctrine/instantiator) < 2) necessario a php-phpunit-PHPUnit-5.7.27-1.fc27.noarch
(php-composer(myclabs/deep-copy) >= 1.3 with php-composer(myclabs/deep-copy) < 2) necessario a php-phpunit-PHPUnit-5.7.27-1.fc27.noarch
(php-composer(phpspec/prophecy) >= 1.6.2 with php-composer(phpspec/prophecy) < 2) necessario a php-phpunit-PHPUnit-5.7.27-1.fc27.noarch
(php-composer(phpunit/php-code-coverage) >= 4.0.4 with php-composer(phpunit/php-code-coverage) < 5) necessario a php-phpunit-PHPUnit-5.7.27-1.fc27.noarch

Ho eseguito rpm -Va --nofiles --nodigest ed anche rpm --rebuilddb ma non ho avuto alcuna segnalazione di errore.

Attendo suggerimenti  :wall:
Grazie
SIlvio


Qualcuno dice sempre che è impossibile fare qualcosa che qualcun altro sta facendo da qualche altra parte.

Non in linea

#2 05-03-2018 23:10:59

frafra
Amministratore
Da Milano
Registrato: 14-05-2014
Messaggi: 2'279
Sito web

Re: Upgrade da F26 a F27 controllo transizione segnala errore php-composer

Rimuoverlo ed installarlo dopo? smile

Non in linea

#3 05-03-2018 23:30:02

d68qdq8dq
Pinguino avanzato
Registrato: 03-07-2014
Messaggi: 229

Re: Upgrade da F26 a F27 controllo transizione segnala errore php-composer

Prova ad effettuare l'aggiornamento con:

dnf system-upgrade  --best --allowerasing

Non in linea

#4 07-03-2018 11:48:30

silvio
Fedora nel sangue
Da Mercato San Severino (Sa)
Registrato: 05-01-2007
Messaggi: 1'305

Re: Upgrade da F26 a F27 controllo transizione segnala errore php-composer

[RISOLTO]
Ho seguito l'indicazione di Frfra ed ho usato yumex per eliminare tutti i file che cominciavano per php.
L'aggiornamento è andato a buon fine ma il kernel non attiva wifi. Per questo argomento apro altra discussione.

F27 va alla grande  :clap: :yeah:


Qualcuno dice sempre che è impossibile fare qualcosa che qualcun altro sta facendo da qualche altra parte.

Non in linea

Piè di pagina