Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 31-03-2018 11:41:53

SQUB
Appena sbarcato sul forum
Registrato: 20-09-2013
Messaggi: 26

[Risolto] Problema avvio dopo aggiornamento a F27

Salve, per alcuni motivi avevo una versione di Fedora piuttosto vecchia (21) su un portatile e ho deciso di aggiornarla alla 27 dando il comando

# dnf system-upgrade download —releasever=27 —allowerasing 
# dnf system-upgrade reboot 

inizialmente non mi partiva l'aggiornamento perché dava dei problemi texlive, dopo averlo disinstallato è riuscita a scaricarsi i file necessari e ha fatto tutto, si è riavviato e a quel punto non riusciva a connettersi alla rete (purtroppo mi sono accorto tardi che l'ethernet dove mi trovavo non funzionava).

Ho pensato quindi di spegnere e riprovare a casa, dove effettivamente ha risolto il problema della rete ma poi rimane bloccato per ore dicendo semplicemente:

[***   ]A start job is running for Hold until boot process finishes up

i due errori che mi da ogni volta sono:

Failed to start login service
Failed to start cleanup of temporary directory

Non so bene che fare, tra le opzioni di boot posso scegliere anche la mia vecchia versione 21 ma non parte nemmeno lei.

I log e altre info non so come copiarli dalla rescue mode quindi se vi serve qualcosa in particolare (o se mi dite come posso salvarli da qualche parte accessibile).

Non so se può servire ma il pc ha in dual boot anche windows.

Grazie a chiunque voglia provare ad aiutarmi.

Ultima modifica di SQUB (06-04-2018 16:02:20)

Non in linea

#2 31-03-2018 18:27:50

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 670

Re: [Risolto] Problema avvio dopo aggiornamento a F27

Ciao ,
fare aggiornamento con system-upgrade è consigliato step by step , tipo 26 - 27, dalla 21 .....
Se hai la home separata , fai molto prima a  fare una installazione pulita da zero .
scarichi la live F27 la metti su una penna usb , fai installazione con partizionamento manuale, monti ma non formatti la home .

Non in linea

#3 01-04-2018 09:07:04

SQUB
Appena sbarcato sul forum
Registrato: 20-09-2013
Messaggi: 26

Re: [Risolto] Problema avvio dopo aggiornamento a F27

Grazie della risposta.
Per vedere se ho la home separata controllo sempre da live con gparted?
E quando installo da live come faccio a montare l'immagine senza formattare? C'è l'opzione?

Non in linea

#4 01-04-2018 09:55:27

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 670

Re: [Risolto] Problema avvio dopo aggiornamento a F27

se hai una partizione home , è separata .Lo vedi anche dalla live con gnome disk ; gparted, mi sembra di ricordare che su live c'è solo wayland e non puoi aprire da root  applicazioni grafiche.
Durante la procedura di installazione, selezioni ripartizione hard disk manuale ,poi selezioni la root , e nel parte di destra vedrai che c'è il posto dove flaggare riformatta , ovviamente non metti il flag alla home.
Anche se  non hai la home separata,poi sempre salvarti tutto su un unita esterna , penna,hard disk,  e poi la ricopi nella nuova.

Non in linea

#5 01-04-2018 16:29:46

SQUB
Appena sbarcato sul forum
Registrato: 20-09-2013
Messaggi: 26

Re: [Risolto] Problema avvio dopo aggiornamento a F27

Allora, ho effettuato l'installazione da 0 e ora funziona tutto. Unico problema, mi sa che ho sbagliato qualcosa in fase di installazione e ora ho la home vecchia in una partizione da 5 GB e la home nuova, e le partizioni sono fatte in modo piuttosto strano (devo aprire un nuovo thread per chiedere lumi su come risolvere il problema? In tal caso scrivo risolto e apro il nuovo thread).

Allego screen:
Schermata_da_2018_04_01_16_10_21.png

Computer è dove ho l'attuale home
Volume da 15 GB è dove ho la vecchia home (che però da gparted sembra non vedere)
OS è windows
Condivisi è una partizione dove metto file da passare da windows a fedora
La partizione da 524 MB immagino sia qualche partizione di sistema. 

Schermata_da_2018_04_01_16_10_41.png
Oltre ad avere 20GB liberi che ho tolto da windows per aggiungerli alla home attuale di fedora volevo metterci anche i 15GB della vecchia home ovviamente, ma non so come fare.

Ultima modifica di SQUB (01-04-2018 16:30:59)

Non in linea

#6 02-04-2018 09:19:07

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 670

Re: [Risolto] Problema avvio dopo aggiornamento a F27

Computer è la root , contrassegnata dal " / ", dentro ha la home . Siccome è sempre meglio averla separata ,puoi formattare la partizione non allocata in ext4 da gparted e la monti come "/home ", poi farlo da gnome disk.
Oppure bisognerebbe modificare il file fstab , ma sarebbe meglio che ti aiuti uno più bravo di me, magari aiutandoti ad unire la vecchia home con la nuova.

Non in linea

#7 06-04-2018 16:07:55

SQUB
Appena sbarcato sul forum
Registrato: 20-09-2013
Messaggi: 26

Re: [Risolto] Problema avvio dopo aggiornamento a F27

Risolto anche quel problema,riallocato tutto ciò che dovevo riallocare. Grazie yum_yoshi per l'aiuto!

Non in linea

Piè di pagina