Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 23-06-2018 19:07:36

recluta
Appena sbarcato sul forum
Da Pomezia (RM)
Registrato: 05-09-2007
Messaggi: 59

Gnome-Sound-Recorder non mi funziona correttamente

Il programma Registrazione di Suoni di Gnome (gnome-sound-recorder) non mi funziona quasi mai correttamente: sovente la voce registrata viene riprodotta in modo distorto con " effetto paperino". Il microfono usato è incorporato nella WeCam Logitech C210.
L'aiuto che ho avuto da:
https://wiki.archlinux.org/index.php/Pu … _corretti/
non ha sortito effetto. Qualche idea?
Grazie.
Recluta

Non in linea

#2 23-06-2018 21:45:22

frafra
Amministratore
Da Trondheim (Norvegia)
Registrato: 14-05-2014
Messaggi: 2'358
Sito web

Re: Gnome-Sound-Recorder non mi funziona correttamente

Frequenza errata? Capita quando si campiona a 44100 Hz anziché a 48000 Hz.
Guarda sotto "Impostare la frequenza di campionamento nella configurazione di Pulseaudio".

Non in linea

#3 24-06-2018 23:51:43

recluta
Appena sbarcato sul forum
Da Pomezia (RM)
Registrato: 05-09-2007
Messaggi: 59

Re: Gnome-Sound-Recorder non mi funziona correttamente

Ho modificato il daemon.conf come riportato sotto:

...........
...........
; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
default-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right
....................
..................

Dopodiché ho fermato e riavviato pulseaudio, i.e.:

$ pulseaudio -k
$ pulseaudio --start.

Ho lanciato il comando

$ gnome-sound-recorder

per registrare ed ascoltare la mia voce. Il comportamento continua ad essere è instabile, ovvero alcune volte la riproduzione è soddisfacente, in altre il suono riprodotto è del tutto incomprensibile.

La stessa cosa succede registrando e riproducendo la mia voce con i comandi:

$ arecord -f dat -r 48000 -D plughw:CARD=NomeMiaWebcam,DEV=0 -d 5 test.wav
Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
$ aplay  test.wav
Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo

E' da escludere un malufunzionamente HW: partendo con il mio veccio F16 funziona tutto correttamente (lasciando anche la frequenza di campionamento a 44100Hz).

Non mi sembra di aver sbagliato qualcosa.

NB.: in queste condizioni non posso utilizzare Skype.

Altri suggerimenti o riflessioni?
Saluti.
Recluta

Non in linea

#4 25-06-2018 09:17:48

frafra
Amministratore
Da Trondheim (Norvegia)
Registrato: 14-05-2014
Messaggi: 2'358
Sito web

Re: Gnome-Sound-Recorder non mi funziona correttamente

Hai iniziato a modificare il file di configurazione perché avevi questo problema o per altri motivi?
Succede solo con la webcam o anche col microfono analogico?

Secondo me default-sample-rate è solo un parametro in uscita, non va a toccare la configurazione audio della webcam.

Quando parli di "riproduzione soddisfacente" vuol dire che registra ogni tanto male ogni tanto bene o che riproduce i file audio spesso male? Infine, l'effetto è sempre quello di frequenza alzata o si tratta di altro? Perché se mi dici "incomprensibile" per me vuol dire che qualcosa rispetto a prima è cambiato.

Non in linea

#5 25-06-2018 18:44:39

recluta
Appena sbarcato sul forum
Da Pomezia (RM)
Registrato: 05-09-2007
Messaggi: 59

Re: Gnome-Sound-Recorder non mi funziona correttamente

frafra ha scritto:

Hai iniziato a modificare il file di configurazione perché avevi questo problema o per altri motivi?

Ho modificato il file di configurazione solo per questo motivo (ho inserito solo la riga che vedi non commentata)

frafra ha scritto:

Succede solo con la webcam o anche col microfono analogico?

Solo con la webcam: non uso il microfono analogico.

frafra ha scritto:

Secondo me default-sample-rate è solo un parametro in uscita, non va a toccare la configurazione audio della webcam.

Non so

frafra ha scritto:

Quando parli di "riproduzione soddisfacente" vuol dire che registra ogni tanto male ogni tanto bene o che riproduce i file audio spesso male? Infine, l'effetto è sempre quello di frequenza alzata o si tratta di altro? Perché se mi dici "incomprensibile" per me vuol dire che qualcosa rispetto a prima è cambiato.

Cerco di chiarire meglio.
Voglio dire che Gnome-sound-recorder registra ogni tanto male (in riproduzione si nota un effetto "paperino incomprensibile) e ogni  tanto bene (in riproduzione la voce si sente in modo chiaro). 
In fase di registrazione ho solo la timeline del segnale di gnome-sound-recorder che mi avverte che la registrazione è in corso. Per sapere se il processo di registrazione sia stato eseguito correttamente non vedo altro modo che non ricorrere alla riproduzione del suono registrato. Una novità da stamani: ho notato che nelle registrazioni destinate ad insuccesso, la timeline del segnale procede più lentamente e a scatti. Invece, quelle registrazioni destinate a una buona riproduzione mostrano un avanzamento della timeline quasi continuo e più veloce.


Spero di aver aggiunto elementi utili.
Recluta

Non in linea

#6 25-06-2018 19:44:16

frafra
Amministratore
Da Trondheim (Norvegia)
Registrato: 14-05-2014
Messaggi: 2'358
Sito web

Re: Gnome-Sound-Recorder non mi funziona correttamente

Grazie mille recluta.
Quando fai una prova e non ottieni cambiamenti, torna allo stato precedente, per evitarne di creare di nuovi (consiglio che vale in generale).

Potrebbe essere un problema di buffering. Particolare che accada sulla registrazione e non sulla riproduzione... Oppure una regressione del driver, ma mi pare strano.

Dai una occhiata anche a https://fedoraproject.org/wiki/How_to_d … d_problems utile se vuoi fare un bug report.

Non in linea

Piè di pagina