Fedora Online Forum

Il forum della comunità italiana di Fedora

#31 15-04-2019 10:58:46

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'883
Sito web

Re: installare olive video editor file fedora

L'RPM sembra funzionare e da la possibilita' anche di scegliere la lingua.

Ho un problema pero', cioe' non riesco a far funzionare olive, nel senso che carico un video con l'opzione "import" nel menu', mi compare nel pannello in alto a sx, ma poi non riesco a vedere la clip o a fare alcuna operazione su di essa.
E se apro olive nel terminale, ogni volta che clicco sulla clip compaiono questi warning:

2019-04-15T11:40:48 [WARNING] Unrecognized OpenGL version
2019-04-15T11:40:48 [WARNING] QOpenGLWidget: Failed to make context current
2019-04-15T11:40:48 [WARNING] composeAndFlush: makeCurrent() failed

E ho lo stesso comportamento anche con la versione compilata a mano.

A te la versione compilata a mano funziona completamente, come la flatpak?
Che pacchetto potrebbe mancarmi? io sto usando driver nvidia

Edit: segnalato agli sviluppatori: https://github.com/olive-editor/olive/issues/810

Ultima modifica di bebo_sudo (15-04-2019 11:31:07)


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#32 15-04-2019 14:38:41

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

Allora la versione che mi hai dato tu con i comandi non mi ha funzionato, cioè neanche mi compilava i sorgenti, allora ho provato  a compilare quella che stavo usando io, e ci sono riuscitoho visto che carica ma n, però non lo ancora testata per quanto riguarda il flatpak funziona tutto, però mi e successo un piccolo casino, ho installato il desktop deepin, come ho riavviato mi  si e sovrapposto al desktop del mio mate, quindi mi ha caricato due desktop, sono riuscito a ripristinare entrando in recovery di Fedora e dalla Shell ho cancellato quel desktop ma come ho fatto il reboot mi sono accorto che il terminale di mate, sovrappone le scritte, cioè non anno spazio e sono illeggibili, ho provato nelle opzioni del terminale a ripristinare a fare modifiche ma nulla, qualche soluzione?

Non in linea

#33 15-04-2019 14:47:51

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'883
Sito web

Re: installare olive video editor file fedora

Creando un nuovo utente, mate e' normale?
Tipo:

# useradd test
# passwd test

e poi fai logout e login di nuovo.

Se con il nuovo utente risolvi, hai qualche casino con i file delle impostazioni nella tua home.
Se NON risolvi, avrai qualche pacchetto strano rimasto installato, presumo. Usa dnf history come spiegato prima per tornare indietro a prima di deepin.


Poi: come hai compilato la versione "che stavi usando te"? e cosa diceva per non compilare i sorgenti? I comandi dovrebbero essere sempre quelli, l'unica cosa e' che io ho scaricato l'ultima versione "stabile" rilasciata dal team il 5 aprile 2019.

Dici che non hai testato la tua versione compilata a mano.. neanche aprirla e provare a caricare un filmato e una sequenza?


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#34 15-04-2019 17:00:56

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

allora la versione flatpak ho visto che non renderizza, mentre la versione compilata da me si....ora non so se posso caricare sreenshot ho caricare qualche filmato renderizzato per mostrare il risultato....


cmq i passi che ho fatto sono:

# dnf install make automake gcc gcc-c++ kernel-devel
#dfn groupinstall "Development Tools" "Development Libraries"
#sudo dnf install cmake qt5-devel ffmpeg-devel frei0r-devel @development-tools
#dnf install mesa-dri-drivers mesa-khr-devel mesa-libEGL mesa-libEGL-devel mesa-gbm mesa-libGL-devel mesa-libGLES-devel mesa-libGLU-devel mesa-libOpenCL-devel mesa-libOSMesa-devel mesa-vdpau-drivers mesa-vulkan-drivers

poi sono andato sul sito della qt ed ho scaricato ide si sviluppo che si chiama...

qt-unified-linux-x64-3.1.0-online.run e un file da 32 mega che praticamete installa ide di sviluppo.

per il sorgente, io ho scaricato il file zip direttamente da chrome ed astratto sul desktop

per la compilazione invece ho usato

#cmake CMakeLists.txt ; make

per la scheda grafica io uso una intel e non so proprio cosa dire

Ultima modifica di Fedoriano01 (15-04-2019 17:03:45)

Non in linea

#35 15-04-2019 17:20:08

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

file singoli importati vengono renderizzati corettamente, file importati tagliati con musica e titolo per ora niente fa scegliere tutto ma al momento del rendering finale  si interrompe

per la versione cmq ce scritto sul sorgente compilato, 0ac9dd9


anche io cmq lanciando da terminale ho dei warning

./olive-editor  
2019-04-15T12:15:26 [WARNING] libpng warning: iCCP: known incorrect sRGB profile
2019-04-15T12:15:26 [INFO] Initializing custom cursors
2019-04-15T12:15:26 [INFO] Finished initializing custom cursors
2019-04-15T12:15:26 [INFO] Initializing icons
2019-04-15T12:15:26 [INFO] Finished initializing icons
2019-04-15T12:15:27 [INFO] Initializing effects...
2019-04-15T12:15:27 [INFO] Finished initializing effects
2019-04-15T12:15:27 [WARNING] Failed to load translation file "/home/xxxxxx/Scrivania/olive/../share/olive-editor/ts/olive_it.qm" . No language will be loaded.
2019-04-15T12:15:27 [WARNING] libpng warning: iCCP: known incorrect sRGB profile

PS come hai fatto a fare la segnalazione?

Ultima modifica di Fedoriano01 (15-04-2019 17:28:09)

Non in linea

#36 15-04-2019 17:34:19

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'883
Sito web

Re: installare olive video editor file fedora

Le tue istruzioni di compilazione sono praticamente identiche alle mie, non capisco dunque come mai non sei riuscito a compilare con la mia stessa sequenza di azioni. Potresti riportare gli errori?

Anche installando tutti quei pacchetti mesa non riesco a fare niente appena import un filmato.
Ho aperto una issue sul github del progetto: https://github.com/olive-editor/olive/issues/810

Nel frattempo, posso chiederti di girare il seguente comando?

$ rpm -qa |grep -i qt

Cosi' vedo le differenze con i miei pacchetti.


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#37 15-04-2019 17:38:23

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

 rpm -qa |grep -i qt
libyui-qt-2.47.1-13.fc29.x86_64
qt5-qtsvg-5.11.3-1.fc29.x86_64
qt5-qtwebsockets-5.11.3-1.fc29.x86_64
qt5-qtbase-common-5.11.3-1.fc29.noarch
qt5-qttools-libs-help-5.11.3-1.fc29.x86_64
gstreamer1-plugins-good-qt-1.14.4-2.fc29.x86_64
qt5-qtxmlpatterns-5.11.3-1.fc29.x86_64
python3-qt5-base-5.11.3-1.fc29.x86_64
qt5-qtsensors-5.11.3-1.fc29.x86_64
qt5-qttools-common-5.11.3-1.fc29.noarch
qt5-qtwebkit-5.212.0-0.31.alpha2.fc29.x86_64
qt5-qtconnectivity-5.11.3-1.fc29.x86_64
qt-settings-29.0-1.fc29.noarch
qt5-qtbase-5.11.3-1.fc29.x86_64
qt5-qtmultimedia-5.11.3-1.fc29.x86_64
python-qt5-rpm-macros-5.11.3-1.fc29.noarch
qt5-qtwayland-5.11.3-1.fc29.x86_64
qt5-srpm-macros-5.11.3-1.fc29.noarch
qt5-qtdeclarative-5.11.3-1.fc29.x86_64
qt5-qtserialport-5.11.3-1.fc29.x86_64
python3-qt5-5.11.3-1.fc29.x86_64
python2-pyqt5-sip-4.19.13-3.fc29.x86_64
qt5-qtwebchannel-5.11.3-1.fc29.x86_64
qt5-qttools-libs-designer-5.11.3-1.fc29.x86_64
qt5-qtgraphicaleffects-5.11.3-1.fc29.x86_64
qt5-qtbase-gui-5.11.3-1.fc29.x86_64
python2-qt5-base-5.11.3-1.fc29.x86_64
python3-pyqt5-sip-4.19.13-3.fc29.x86_64
qt5-qtlocation-5.11.3-1.fc29.x86_64
python2-qt5-5.11.3-1.fc29.x86_64
libyui-mga-qt-1.0.3-0.16.gitb508e88.20140119.fc29.x86_64
qt5-qtenginio-1.6.2-20.fc29.x86_64
qt5-qtquickcontrols-5.11.3-1.fc29.x86_64
qt5-qtx11extras-5.11.3-1.fc29.x86_64

Non in linea

#38 15-04-2019 17:44:33

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'883
Sito web

Re: installare olive video editor file fedora

Ho gli stessi tuoi pacchetti per qt (piu' molti altri).

Vediamo anche:

$ rpm -qa |egrep -i "gl|mesa"

devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#39 15-04-2019 17:51:16

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

google-droid-sans-fonts-20120715-14.fc29.noarch
PackageKit-glib-1.1.12-2.fc29.x86_64
mesa-libGL-18.3.6-1.fc29.i686
mesa-libGLU-9.0.0-16.fc29.x86_64
libGLEW-2.1.0-2.fc29.x86_64
glib2-2.58.3-1.fc29.x86_64
pygtk2-libglade-2.24.0-23.fc29.x86_64
glibc-all-langpacks-2.28-27.fc29.x86_64
glibc-headers-2.28-27.fc29.x86_64
mesa-libglapi-18.3.6-1.fc29.x86_64
wxGTK3-gl-3.0.4-4.fc29.x86_64
mesa-vulkan-drivers-18.3.6-1.fc29.i686
glade-libs-3.22.1-3.fc29.x86_64
google-noto-fonts-common-20170919-2.fc29.noarch
libglvnd-core-devel-1.1.0-2.fc29.x86_64
libappstream-glib-0.7.15-1.fc29.x86_64
json-glib-1.4.4-1.fc29.x86_64
libwayland-egl-1.16.0-1.fc29.i686
google-noto-sans-sinhala-fonts-20170919-2.fc29.noarch
libglvnd-gles-1.1.0-2.fc29.x86_64
libglade2-2.6.4-19.fc29.x86_64
google-noto-emoji-color-fonts-20180814-1.fc29.noarch
gloox-1.0.14-8.fc29.x86_64
libglvnd-gles-1.1.0-2.fc29.i686
taglib-1.11.1-9.fc29.x86_64
glibc-common-2.28-27.fc29.x86_64
avahi-glib-0.7-16.fc29.x86_64
mesa-filesystem-18.3.6-1.fc29.x86_64
gegl04-0.4.14-1.fc29.x86_64
mesa-dri-drivers-18.3.6-1.fc29.i686
google-noto-sans-cjk-ttc-fonts-20170602-9.fc29.noarch
libglvnd-1.1.0-2.fc29.i686
google-crosextra-carlito-fonts-1.103-0.9.20130920.fc29.noarch
freeglut-3.0.0-9.fc29.x86_64
libglvnd-glx-1.1.0-2.fc29.x86_64
mesa-vulkan-drivers-18.3.6-1.fc29.x86_64
mesa-libgbm-18.3.6-1.fc29.i686
google-chrome-stable-73.0.3683.103-1.x86_64
libglvnd-opengl-1.1.0-2.fc29.x86_64
mesa-libOSMesa-18.3.6-1.fc29.i686
json-glib-1.4.4-1.fc29.i686
libglvnd-glx-1.1.0-2.fc29.i686
glib2-devel-2.58.3-1.fc29.x86_64
google-noto-sans-fonts-20170919-2.fc29.noarch
glibc-2.28-27.fc29.x86_64
poppler-glib-0.67.0-16.fc29.x86_64
glibc-2.28-27.fc29.i686
mesa-libGL-18.3.6-1.fc29.x86_64
mesa-libOSMesa-18.3.6-1.fc29.x86_64
mesa-filesystem-18.3.6-1.fc29.i686
ftgl-2.1.3-0.19.rc5.fc29.x86_64
libglvnd-egl-1.1.0-2.fc29.x86_64
mesa-dri-drivers-18.3.6-1.fc29.x86_64
glibmm24-2.58.0-1.fc29.x86_64
libglvnd-devel-1.1.0-2.fc29.x86_64
mesa-libglapi-18.3.6-1.fc29.i686
mesa-libxatracker-18.3.6-1.fc29.x86_64
google-noto-serif-cjk-ttc-fonts-20170602-9.fc29.noarch
glibc-devel-2.28-27.fc29.x86_64
google-droid-sans-mono-fonts-20120715-14.fc29.noarch
glx-utils-8.4.0-1.fc29.x86_64
mesa-libgbm-18.3.6-1.fc29.x86_64
glib-networking-2.58.0-2.fc29.i686
gstreamer1-plugins-ugly-free-1.14.4-1.fc29.x86_64
libglvnd-1.1.0-2.fc29.x86_64
google-noto-cjk-fonts-common-20170602-9.fc29.noarch
mesa-libEGL-18.3.6-1.fc29.x86_64
mesa-libOpenCL-18.3.6-1.fc29.x86_64
ModemManager-glib-1.8.0-4.fc29.x86_64
google-crosextra-caladea-fonts-1.002-0.11.20130214.fc29.noarch
glib2-2.58.3-1.fc29.i686
libglvnd-egl-1.1.0-2.fc29.i686
glib-networking-2.58.0-2.fc29.x86_64
pulseaudio-libs-glib2-12.2-1.fc29.x86_64
glibc-langpack-en-2.28-27.fc29.x86_64
libwayland-egl-1.16.0-1.fc29.x86_64
fftw-libs-single-3.3.8-2.fc29.x86_64
dbus-glib-0.110-3.fc29.x86_64
mesa-libEGL-18.3.6-1.fc29.i686

Non in linea

#40 15-04-2019 18:07:13

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

Puoi dirmi a me cosa manca x la lingua italiana e sRGB forse e x quello che non mi renderizza i montaggi?

Non in linea

#41 20-04-2019 01:05:42

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'883
Sito web

Re: installare olive video editor file fedora

Ciao, ho compilato e pubblicato olive su copr: https://copr.fedorainfracloud.org/coprs … ve-editor/.
Lo puoi installare con:

# dnf copr enable bebosudo/olive-editor
# dnf install olive-editor olive-editor-doc

E poi lanciare da icona nel menu' o da terminale con 'olive-editor' come normale utente.


Edit: specificato anche il pacchetto -doc, contenente la documentazione interna di olive.

Ultima modifica di bebo_sudo (21-04-2019 12:00:23)


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#42 20-04-2019 07:40:54

Fedoriano01
Appena sbarcato sul forum
Registrato: 21-08-2018
Messaggi: 66

Re: installare olive video editor file fedora

Ma una perplessità che ho se usciranno nuove versioni se si deve ricompilare sempre tutto oppure basta solo lanciare un update?

Non in linea

#43 20-04-2019 07:59:15

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'684

Re: installare olive video editor file fedora

Per ogni nuova versione va creato un nuovo file di installazione (rpm) o si deve ricompilare dai sorgenti


Ciao
Andrea Malfatti

Non in linea

#44 20-04-2019 14:21:23

AntonGiulioGiovanGianPaul
Appena sbarcato sul forum
Registrato: 24-03-2019
Messaggi: 22

Re: installare olive video editor file fedora

Fedoriano01 ha scritto:

Ma una perplessità che ho se usciranno nuove versioni se si deve ricompilare sempre tutto oppure basta solo lanciare un update?

Ciao, FedeSampdoriano.
Il software è una β precoce; di nuove versioni ne usciranno dozzine. Per questo dovrebbero essere gli sviluppatori a fare i pacchetti; quantomeno utenti entusiasti che lo usano spesso ma per cose non importanti. Grazie comunque a bebo_sudo della disponibilità.

Per lavori dove impegni tempo, nome e soldi è meglio rivolgersi a Lighworks o Resolve.

Non in linea

#45 21-04-2019 11:59:21

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'883
Sito web

Re: installare olive video editor file fedora

Fedoriano01 ha scritto:

Ma una perplessità che ho se usciranno nuove versioni se si deve ricompilare sempre tutto oppure basta solo lanciare un update?

Tu come utente Fedora, se vuoi usare il repo COPR che ho fatto io, riceverai aggiornamenti ogni volta che creero' un nuovo pacchetto, quindi ti bastera' fare un 'dnf upgrade' (o 'dnf update', e' uguale) oppure aggiornare tramite programmi GUI.

Per ora gli sviluppatori hanno rilasciato solo due versioni ufficiali, l'ultima a dicembre. La versione che ho impacchettato io e' l'ultima nightly, perche' la versione di dicembre era 1000 commit indietro (su 1500 commit totali del progetto), infatti ho messo come versione 20190420git3251a42, dove 20 aprile e' la data della nightly e 3251a42 e' l'hash della versione scaricata. Ho provato a chiedere una release "ufficiale" in modo da evitare di usare una nightly, ma non mi hanno risposto. Ed hanno rilasciato una nuova nightly build 9 ore fa.

Cerchero' di aggiornare questo pacchetto spesso, ma se vuoi chiedere un update degli RPM per una specifica versione di olive, puoi scrivermi qua nel repo che uso per generare gli RPM: https://github.com/bebosudo/olive-editor-rpm
Qui e' contenuto anche lo .spec file usato per creare i vari pacchetti.

AntonGiulioGiovanGianPaul ha scritto:

Per questo dovrebbero essere gli sviluppatori a fare i pacchetti

Gli sviluppatori fanno gia' una serie di pacchetti, in particolare per windows, mac e ubuntu, piu' i pacchetti AppImage e snap (quest'ultimo a me non funzionava, invece AppImage si').
Ho preferito creare un RPM per esercizio, e perche' preferisco usare dnf per gli aggiornamenti (molto piu' pulito e con una storia "ricostruibile"), invece di avere pacchetti sparsi nelle cartelle di download.
Inoltre talvolta mi capita di fare qualche semplice montaggio, e non avevo ancora trovato uno strumento per fare un po' piu' di un semplice taglia e cuci.


Se avete dubbi sui pacchetti, chiedete pure! (magari in una discussione separata)


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

Piè di pagina