Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 24-04-2019 12:01:05

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

Buon pomeriggio a tutti ragazzi! Ho installato fedora 29 e non ho riscontrato nessun tipo di problema, tranne che uno:

Ho una scheda nvdia 950m e nel momento in cui collego l'hdmi fedora riconosce benissimo lo schermo esterno.
L'unico, ma importante, problema è che non funziona l'audio, o meglio fuoriesce soltanto dalle casse del pc e non dallo schermo esterno.

Come posso risolvere?

Grazie mille anticipatamente!

Non in linea

#2 24-04-2019 13:25:47

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 697

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

Ciao ,
hai provato nei settaggi dal pannello di configurazione  sezione "audio" ,se usi gnome ,ci dovrebbero essere alcune scelte.
Oppure ,potrebbe essere la scheda ,io qualche anno fa ,facendo un pc nuovo ,ne ho restituita una che non aveva audio in uscita e ho cambiato modello.
ciao

Non in linea

#3 24-04-2019 14:22:01

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

Credo che la 950M ha la scheda audio in uscita..oltretutto non potrei neanche restituirla..è integrata nel laptop xD
comunque uso GNOME e ho provato a provare le varie opzioni, ma nulla

Non in linea

#4 24-04-2019 15:57:07

yum_yoshi
Innamorato del forum
Registrato: 04-02-2010
Messaggi: 697

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

come opzioni , volevo dire :
impostazioni > audio >uscita >"scegliere un dispositivo per l'uscita audio" > HDMI /display port.
altrimenti non saprei cosa dire

Non in linea

#5 24-04-2019 17:05:11

JackDaniels
Appena sbarcato sul forum
Da Cosenza
Registrato: 04-03-2019
Messaggi: 87

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

giupardeb ha scritto:

Credo che la 950M ha la scheda audio in uscita..oltretutto non potrei neanche restituirla..è integrata nel laptop xD
comunque uso GNOME e ho provato a provare le varie opzioni, ma nulla


segui la guida e posta i risultati :

https://wiki.archlinux.org/index.php/NV … _over_HDMI

sembra che il chip audio sia disabilitato al boot , nvidia su linux non è il massimo (é il peggio XD)

Ultima modifica di JackDaniels (24-04-2019 17:09:43)


Se va male ricorda che poteva andare anche peggio!

Non in linea

#6 24-04-2019 17:19:51

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

questo è l'output del comando

aplay -l 

:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

inoltre non ho nessun modulo che si chiamano: nvidia-drm nvidia-modeset nvidia suppongo che utilizzo di default i driver nouveau

Ultima modifica di giupardeb (24-04-2019 17:20:37)

Non in linea

#7 24-04-2019 17:26:52

JackDaniels
Appena sbarcato sul forum
Da Cosenza
Registrato: 04-03-2019
Messaggi: 87

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

giupardeb ha scritto:

questo è l'output del comando

aplay -l 

:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

inoltre non ho nessun modulo che si chiamano: nvidia-drm nvidia-modeset nvidia suppongo che utilizzo di default i driver nouveau


yeah stai "usando" intel...... ovvio se non hai installato gli akmod ma su questo lascio il passo a chi ne sa di piu.


Se va male ricorda che poteva andare anche peggio!

Non in linea

#8 24-04-2019 18:13:43

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'075
Sito web

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

Ciao giupardeb, temo tu possa stare usando due GPU, la dedicata nvidia e la integrata Intel nella CPU.

Vediamo subito. Riporta:

$ lspci |egrep “VGA|3D”

Se ci sono due righe, significa che hai due schede grafiche.

La cosa piu' facile da fare sarebbe disabilitare una delle due da bios magari: tieni conto che la dedicata e' piu' potente ma meno efficiente (essendo un device separato e con piu' prestazioni, consuma di piu'), invece la dedicata solitamente e' meno potente ma piu' efficiente (essendo dentro o molto vicina alla CPU).

Prova a fare una prova disabilitando una delle due dal bios (se possibile), e poi prova a vedere se funziona l'audio.
Altrimenti possiamo poi provare ad installare i driver proprietari per la nvidia, oppure usare bumblebee.

Sei sicuro che la scheda supporti l'audio su hdmi, come diceva yum_yoshi? l'hai mai provata con un sistema che sai di avere tutti i driver funzionanti, magari il windows pre-installato?


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#9 24-04-2019 19:01:02

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

[giuseppe@hp-omen ~]$ lspci |egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Sei sicuro che la scheda supporti l'audio su hdmi, come diceva yum_yoshi? l'hai mai provata con un sistema che sai di avere tutti i driver funzionanti, magari il windows pre-installato?

Adesso che ci rifletto bene..su ubuntu, con i driver proprietari non funzionava neanche..con windows mai provato..nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l'audio over hdmi.

Per quanto riguarda le schede attive..non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l'uso del bios?

Non in linea

#10 25-04-2019 08:37:07

JackDaniels
Appena sbarcato sul forum
Da Cosenza
Registrato: 04-03-2019
Messaggi: 87

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

giupardeb ha scritto:
[giuseppe@hp-omen ~]$ lspci |egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Sei sicuro che la scheda supporti l'audio su hdmi, come diceva yum_yoshi? l'hai mai provata con un sistema che sai di avere tutti i driver funzionanti, magari il windows pre-installato?

Adesso che ci rifletto bene..su ubuntu, con i driver proprietari non funzionava neanche..con windows mai provato..nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l'audio over hdmi.

Per quanto riguarda le schede attive..non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l'uso del bios?

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)

Ultima modifica di JackDaniels (25-04-2019 08:45:48)


Se va male ricorda che poteva andare anche peggio!

Non in linea

#11 25-04-2019 09:24:16

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

JackDaniels ha scritto:
giupardeb ha scritto:
[giuseppe@hp-omen ~]$ lspci |egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Sei sicuro che la scheda supporti l'audio su hdmi, come diceva yum_yoshi? l'hai mai provata con un sistema che sai di avere tutti i driver funzionanti, magari il windows pre-installato?

Adesso che ci rifletto bene..su ubuntu, con i driver proprietari non funzionava neanche..con windows mai provato..nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l'audio over hdmi.

Per quanto riguarda le schede attive..non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l'uso del bios?

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)

uso il pc per sola produttività. Non ci gioco..però credo di non poterla disattivare per il semplice motivo che l'hdmi non funzionerebbe..utilizzo molto uno schermo esterno

Non in linea

#12 25-04-2019 10:28:41

JackDaniels
Appena sbarcato sul forum
Da Cosenza
Registrato: 04-03-2019
Messaggi: 87

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

giupardeb ha scritto:
JackDaniels ha scritto:
giupardeb ha scritto:
[giuseppe@hp-omen ~]$ lspci |egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Sei sicuro che la scheda supporti l'audio su hdmi, come diceva yum_yoshi? l'hai mai provata con un sistema che sai di avere tutti i driver funzionanti, magari il windows pre-installato?

Adesso che ci rifletto bene..su ubuntu, con i driver proprietari non funzionava neanche..con windows mai provato..nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l'audio over hdmi.

Per quanto riguarda le schede attive..non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l'uso del bios?

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)

uso il pc per sola produttività. Non ci gioco..però credo di non poterla disattivare per il semplice motivo che l'hdmi non funzionerebbe..utilizzo molto uno schermo esterno

no tranquillo userai hdmi con intel

dopo averla disattivata da bios crea il file : /etc/X11/xorg.conf.d/20-intel.conf e piazza dentro :

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"              "glamor"
    Option      "DRI"            "3"
    Option      "TripleBuffer"             "true"
EndSection
     

Ultima modifica di JackDaniels (25-04-2019 10:29:05)


Se va male ricorda che poteva andare anche peggio!

Non in linea

#13 25-04-2019 18:56:01

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

JackDaniels ha scritto:
giupardeb ha scritto:
JackDaniels ha scritto:
giupardeb ha scritto:
[giuseppe@hp-omen ~]$ lspci |egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

Adesso che ci rifletto bene..su ubuntu, con i driver proprietari non funzionava neanche..con windows mai provato..nel momento in cui ho spacchettato il pc ho eliminato windows quasi immediatamente. A questo punto mi sa che la 950m non supporta l'audio over hdmi.

Per quanto riguarda le schede attive..non esiste un modo più semplice che mi permetta di attivare e disattivare le due schede senza l'uso del bios?

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)

uso il pc per sola produttività. Non ci gioco..però credo di non poterla disattivare per il semplice motivo che l'hdmi non funzionerebbe..utilizzo molto uno schermo esterno

no tranquillo userai hdmi con intel

dopo averla disattivata da bios crea il file : /etc/X11/xorg.conf.d/20-intel.conf e piazza dentro :

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"              "glamor"
    Option      "DRI"            "3"
    Option      "TripleBuffer"             "true"
EndSection
     

ok proverò appena posso, ma una domanda banalissima ma che ho necessità di fare: Credo che fedora 29 utilizzi wayland, ma tu mi stai facendo creare un file di configurazione per xorg (X11). Questo non potrebbe crearmi problemi?

EDIT.. credo che il mio bios non permetta di disattivare la nvidia

Ultima modifica di giupardeb (25-04-2019 19:27:27)

Non in linea

#14 25-04-2019 19:35:06

JackDaniels
Appena sbarcato sul forum
Da Cosenza
Registrato: 04-03-2019
Messaggi: 87

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

giupardeb ha scritto:
JackDaniels ha scritto:
giupardeb ha scritto:
JackDaniels ha scritto:

Di solito giochi o usi il pc per sola produttivitá?

il discorso nvidia lo intrapresi 10 anni fa , prima e ultima volta , procedure fastidiose la prima volta poi bisognava stare attenti a gli aggiornamenti kernel e driver. Da allora compro solo hardware puro Intel.

Disabilitarla dal Bios é il metodo piu pulito

ho dato una occhiata alla GPU intel che hai e ti assicuro che puoi anche giocarci ergo stai sereno , merdvidia ciuccia solo batteria ;-)

uso il pc per sola produttività. Non ci gioco..però credo di non poterla disattivare per il semplice motivo che l'hdmi non funzionerebbe..utilizzo molto uno schermo esterno

no tranquillo userai hdmi con intel

dopo averla disattivata da bios crea il file : /etc/X11/xorg.conf.d/20-intel.conf e piazza dentro :

[giuseppe@hp-omen ~]$ lspci |egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)

ok proverò appena posso, ma una domanda banalissima ma che ho necessità di fare: Credo che fedora 29 utilizzi wayland, ma tu mi stai facendo creare un file di configurazione per xorg (X11). Questo non potrebbe crearmi problemi?

EDIT.. credo che il mio bios non permetta di disattivare la nvidia

nvidia usa SOLO xorg. se non riesci a disattivare nvidia attueremo il l piano B

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"              "glamor"
    Option      "DRI"            "3"
    Option      "TripleBuffer"             "true"
EndSection
     

Se va male ricorda che poteva andare anche peggio!

Non in linea

#15 25-04-2019 21:39:24

giupardeb
Appena sbarcato sul forum
Registrato: 25-02-2015
Messaggi: 82

Re: non funziona l'audio HDMI (scheda grafica NVIDIA 950M)

Okay, creo ugualmente il file /etc/X11/xorg.conf.d/20-intel.conf con queste linee:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"              "glamor"
    Option      "DRI"            "3"
    Option      "TripleBuffer"             "true"
EndSection

Non in linea

Piè di pagina