Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 11-09-2019 11:48:28

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

[RISOLTO] installazione Okular

Sono su Gnome 3 e non riesco ad installare Okular. Il messaggio che mi viene restituito è il seguente:

Errore: Errore nel controllo di transazione:
  il file /usr/share/dbus-1/services/com.google.code.AccountsSSO.SingleSignOn.service entra in conflitto durante il tentativo d'installazione di gsignond-1.2.0-2.fc30.x86_64 e signon-8.60-2.fc30.x86_64

come risolvo?

grazie

Ultima modifica di doclight (12-09-2019 12:30:10)

Non in linea

#2 11-09-2019 13:30:07

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'958
Sito web

Re: [RISOLTO] installazione Okular

E' un bug conosciuto che stanno cercando di risolvere sia i packager di fedora che i team di sviluppo di entrambi i pacchetti signon e gsignond:
https://bugzilla.redhat.com/show_bug.cgi?id=1714929
https://gitlab.com/accounts-sso/signond/issues/5

Vediamo cosa succederebbe se provassimo a rimuovere signon:

# dnf remove --assumeno signon

devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#3 11-09-2019 15:36:25

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

bebo_sudo ha scritto:

E' un bug conosciuto che stanno cercando di risolvere sia i packager di fedora che i team di sviluppo di entrambi i pacchetti signon e gsignond:
https://bugzilla.redhat.com/show_bug.cgi?id=1714929
https://gitlab.com/accounts-sso/signond/issues/5

Vediamo cosa succederebbe se provassimo a rimuovere signon:

# dnf remove --assumeno signon

Mi fido a rimuoverlo? non è che serve?

Non in linea

#4 11-09-2019 15:58:34

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'958
Sito web

Re: [RISOLTO] installazione Okular

Posta quello che ti ritorna quel comando; quell' assumeno significa che dnf non eseguira' l'azione mostrata.


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#5 11-09-2019 16:31:38

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

pensavo "assumeno", invece si legge "assume no"  ;-)))) grazie

Nessuna corrispondenza per l'argomento: signon
Nessun pacchetto marcato per la rimozione.
Dipendenze risolte.
Nessuna operazione da compiere.
Fatto!

Non in linea

#6 11-09-2019 22:24:57

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'958
Sito web

Re: [RISOLTO] installazione Okular

Mmmm.. Vediamo allora:

$ rpm -qa |grep -i sign

PS: Quando posti del codice, mettilo nel tag code

[code]così[/code]

(purtroppo il form di inserimento delle risposte e' rotto e non si vedono piu' i bottoni)

Ultima modifica di bebo_sudo (11-09-2019 22:25:13)


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#7 12-09-2019 07:17:21

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

rpm-sign-libs-4.14.2.1-5.fc30.x86_64
gsignond-libs-1.2.0-3.fc30.x86_64
signon-glib-2.1-4.fc30.x86_64
gsignond-plugin-lastfm-0-0.2.20180507.git0a7a5f8.fc30.x86_64
qt5-qttools-libs-designer-5.12.4-1.fc30.x86_64
gsignond-1.2.0-3.fc30.x86_64
gsignond-plugin-oauth-0-0.6.20180513.git43fee49.fc30.x86_64
gsignond-default-config-1.2.0-3.fc30.noarch
gsignond-plugin-mail-0.3.0-2.fc30.x86_64
gsignond-plugin-sasl-0-0.6.20171111.git671022f.fc30.x86_64

Non in linea

#8 12-09-2019 09:24:14

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'958
Sito web

Re: [RISOLTO] installazione Okular

Vediamo:

# dnf remove --assumeno gsignond
# dnf update --assumeno gsignond

devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#9 12-09-2019 09:37:41

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

 
Dipendenze risolte.
=======================================================================================================================================
 Package                                     Architecture       Version                                     Repository            Size
=======================================================================================================================================
Rimozione in corso:
 gsignond                                    x86_64             1.2.0-3.fc30                                @updates             334 k
Rimozione dei pacchetti dipendenti in corso:
 gsignond-plugin-lastfm                      x86_64             0-0.2.20180507.git0a7a5f8.fc30              @fedora               51 k
 gsignond-plugin-mail                        x86_64             0.3.0-2.fc30                                @fedora               51 k
 switchboard-plug-onlineaccounts             x86_64             2.0.1-2.fc30                                @fedora              659 k
Rimozione dipendenze inutilizzate:
 signon-glib                                 x86_64             2.1-4.fc30                                  @fedora              209 k

Riepilogo della transazione
=======================================================================================================================================
Rimossi  5 pacchetti

Spazio liberato: 1.3 M
Operazione annullata.
Ultima verifica della scadenza dei metadati: 2:14:54 fa il gio 12 set 2019, 08:08:42.
Dipendenze risolte.
Nessuna operazione da compiere.
Fatto!

Non in linea

#10 12-09-2019 11:04:48

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'958
Sito web

Re: [RISOLTO] installazione Okular

Okay, proviamo allora:

# dnf remove gsignond
# dnf update

devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#11 12-09-2019 11:22:27

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

dnf remove gsinond
Nessuna corrispondenza per l'argomento: gsinond
Nessun pacchetto marcato per la rimozione.
Dipendenze risolte.
Nessuna operazione da compiere.
Fatto!
Ultima verifica della scadenza dei metadati: 0:57:16 fa il gio 12 set 2019, 11:09:54.
Dipendenze risolte.
================================================================================
 Package                  Architecture Version              Repository     Size
================================================================================
Upgrading:
 libmodulemd              x86_64       2.8.0-1.fc30         updates       185 k
 libselinux               x86_64       2.9-3.1.fc30         updates        78 k
 libselinux-utils         x86_64       2.9-3.1.fc30         updates       146 k
 python3-libselinux       x86_64       2.9-3.1.fc30         updates       162 k

Riepilogo della transazione
================================================================================
Aggiornati  4 pacchetti

Dimensione totale dello scaricamento: 571 k
Procedere [s/N]: s
Scaricamento dei pacchetti:
(1/4): libselinux-2.9-3.1.fc30.x86_64.rpm       248 kB/s |  78 kB     00:00    
(2/4): libmodulemd-2.7.0-1.fc30_2.8.0-1.fc30.x8 218 kB/s |  71 kB     00:00    
(3/4): libselinux-utils-2.9-3.1.fc30.x86_64.rpm 386 kB/s | 146 kB     00:00    
(4/4): python3-libselinux-2.9-3.1.fc30.x86_64.r 1.6 MB/s | 162 kB     00:00    
[DRPM] libmodulemd-2.7.0-1.fc30_2.8.0-1.fc30.x86_64.drpm: eseguito             
--------------------------------------------------------------------------------
Totale                                          387 kB/s | 457 kB     00:01     
I delta RPM hanno ridotto 0.6 MB di aggiornamenti a 0.4 MB (19.1% risparmiato)
Esecuzione del controllo di transazione
Controllo di transazione eseguito con successo.
Test di transazione in corso
Test di transazione eseguito con successo
Transazione in corso
  Preparazione in corso        :                                            1/1 
  Upgrading                    : libselinux-2.9-3.1.fc30.x86_64             1/8 
  Esecuzione scriptlet in corso: libselinux-2.9-3.1.fc30.x86_64             1/8 
  Upgrading                    : libselinux-utils-2.9-3.1.fc30.x86_64       2/8 
  Upgrading                    : python3-libselinux-2.9-3.1.fc30.x86_64     3/8 
  Upgrading                    : libmodulemd-2.8.0-1.fc30.x86_64            4/8 
  Pulizia                      : python3-libselinux-2.9-1.fc30.x86_64       5/8 
  Pulizia                      : libselinux-utils-2.9-1.fc30.x86_64         6/8 
  Pulizia                      : libselinux-2.9-1.fc30.x86_64               7/8 
  Pulizia                      : libmodulemd-2.7.0-1.fc30.x86_64            8/8 
  Esecuzione scriptlet in corso: libmodulemd-2.7.0-1.fc30.x86_64            8/8 
  Verifica in corso            : libmodulemd-2.8.0-1.fc30.x86_64            1/8 
  Verifica in corso            : libmodulemd-2.7.0-1.fc30.x86_64            2/8 
  Verifica in corso            : libselinux-2.9-3.1.fc30.x86_64             3/8 
  Verifica in corso            : libselinux-2.9-1.fc30.x86_64               4/8 
  Verifica in corso            : libselinux-utils-2.9-3.1.fc30.x86_64       5/8 
  Verifica in corso            : libselinux-utils-2.9-1.fc30.x86_64         6/8 
  Verifica in corso            : python3-libselinux-2.9-3.1.fc30.x86_64     7/8 
  Verifica in corso            : python3-libselinux-2.9-1.fc30.x86_64       8/8 

Aggiornati:
  libmodulemd-2.8.0-1.fc30.x86_64       libselinux-2.9-3.1.fc30.x86_64         
  libselinux-utils-2.9-3.1.fc30.x86_64  python3-libselinux-2.9-3.1.fc30.x86_64 

Fatto!

Non in linea

#12 12-09-2019 11:23:07

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

HO SBAGLIATO! rifaccio tutto

Non in linea

#13 12-09-2019 11:25:38

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

rifatto - OKULAR INSTALLATO! Grazie!

come faccio a mettere RISOLTO?

Non in linea

#14 12-09-2019 11:42:16

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 1'958
Sito web

Re: [RISOLTO] installazione Okular

Bene! Modifica il primo post della discussione e mettici [Risolto] davanti al titolo.


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#15 12-09-2019 12:30:40

doclight
Appena sbarcato sul forum
Registrato: 11-09-2019
Messaggi: 29

Re: [RISOLTO] installazione Okular

Fatto. Ma quanta pazienza hai? ;-)

Non in linea

Piè di pagina