Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 03-10-2019 14:54:33

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

[Risolto] Copia ed incolla in difficoltà

In Fedora30 lxde, sto trovando serie difficoltà ad eseguire la semplice copia di parole o righe con la selezione del mouse.
In lxterminal se seleziono parole o righe la selezione sparisce appena lascio.
In leafpad se uso il comando seleziona tutto la selezione compare e subito dopo scompare, se invece cerco di selezionare un rigo con il mouse, mentre procedo scompaiono i caratteri selezionati prima.
In una pagina web in firefox la selezione non sparisce e posso usare il comando copia, ma poi non trovo niente da incollare altrove. Neanche da quì a quì sotto.
Idee su cosa sia successo e come posso risolvere?

Ultima modifica di Zievatron (30-10-2019 22:07:37)

Non in linea

#2 04-10-2019 10:45:19

andreamal
Fedora nel sangue
Da Roma
Registrato: 16-12-2009
Messaggi: 1'698

Re: [Risolto] Copia ed incolla in difficoltà

Potrebbero essere i microswitch del mouse, ne ho uno che come tocco il tasto sinistro 2 volte su 3 mi fa da 2 a n click


Ciao
Andrea Malfatti

Non in linea

#3 05-10-2019 17:57:35

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Se fosse così, il problema dovrebbe presentarsi con qualsiasi pc che uso con lo stesso mouse.
Invece non accade. Accade solo con quello nuovo.

Non in linea

#4 13-10-2019 16:38:13

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Ho anche provato a reinstallare fedora.
Niente da fare, il problema persiste. Forse mi manca qualcosa.
Nessuno ha un'idea di cosa potrei fare?

Non in linea

#5 16-10-2019 13:03:45

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Ho fatto altre prove, anche a cambiare via di installazione, usando la spin invece della netinst.
Il problema persiste, ma ho scoperto che se uso una sessione live di lxde il problema non c'è.
Dopo l'installazione invece il problema c'è, ma solo per le sessioni di lxde, se apro la sessione in openbox il problema non c'è.
Inoltre, se tento di aprire la sessione come root, mi ritorna sempre la richiesta dell'utente. Invece, aperta una sessione lxde come utente normale posso tranquillamente diventare root in un terminale.

Non in linea

#6 16-10-2019 14:18:11

QuarkF
Pinguino avanzato
Registrato: 01-04-2013
Messaggi: 270

Re: [Risolto] Copia ed incolla in difficoltà

Possibile che ci sia un tasto premuto sulla tastiera? Magari leggermente incastrato?


Al mondo ci sono 10 tipi di persone: quelle che conoscono la numerazione binaria e quelle che non la capiscono.

Non in linea

#7 16-10-2019 16:58:09

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

A me sembrano tutti normali, ma soprattutto è la stessa tastiera che uso anche con altri computer, sempre con fedora, lxde o xfce, anche se con gli altri sono fermo alla 27. Perciò, come per il mouse, non può essere un problema di dispositivo di imput.
Inoltre dato che con la stessa spin di fedora30lxde da live funziona bene e da installata funziona bene se accedo via openbox e funziona male se accedo via lxde, non può essere nessun problema di tipo hardware.
Deve per forza essere un problema software.
Sarà una qualche impostazione in chissà quale file che per chissà quale motivo viene diversa quando è installato.
Ma come scopro qual'è?

Non in linea

#8 18-10-2019 17:55:50

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

L'odissea continua.
Da dnfdragora, ho provato ad aggiungere lxqt ed xfce.
In lxqt il copia ed incolla funziona, in xfce non funziona.
Dov'è la differenza?

Dopo questa operazione, in lxde non posso più nenache entrare. Se tento di loggarmi in lxde ottengo solo lo sfondo senza niente che si possa clickare e senza menù contestuale.

Non in linea

#9 19-10-2019 00:21:37

bebo_sudo
Collaboratore
Da Trento+Trieste
Registrato: 28-02-2011
Messaggi: 2'000
Sito web

Re: [Risolto] Copia ed incolla in difficoltà

Domanda: ipotizzo tu abbia "spannato" qualche file di config del tuo utente.

Se crei un nuovo utente nel sistema, vedi questi errori di copia-incolla e di login a xfce?


devzero.tk - github.com/bebosudo
Quando posti del codice, mettilo nel tag code! (senza spazi)            [ code]così[/ code]

Non in linea

#10 19-10-2019 17:00:54

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Nuovo utente creato. Visto che c'ero, ho anche aggiunto altri tre DE: Cinnamon, Enlightenment, Mate.
Il nuovo utente ha gli stessi problemi del primo.
LXDE è tornato accessibile.
Ora la serie degli ambienti con il problema del copia incolla è:
LXDE, XFCE, Cinnamon e Mate.
Gli ambienti esenti dal problema sono:
Enlightenment, Lxqt, Openbox.

Non in linea

#11 20-10-2019 23:05:45

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Ho provato anche deepin.
Se tento di installarlo direttamente da netinst come primo DE, qualcosa non funziona ed ottengo uno schermo bianco vuoto nel quale non si trova niente da clickare, anche clickando lo schermo non viene fuori nessun menù.
Se invece lo installo dopo, via dnfdragora, va tutto bene ed il copia incolla funziona.
Mi viene una ipotesi su questo problema. Tutti quelli che mi danno il problema (lxde, xfce, cinnamon e mate) hanno in comune "GTK", tradizione gnomica. Gli altri in cui il copia ed incolla funziona no, se ne sono discostati.
Può dipendere da questo?

Non in linea

#12 24-10-2019 14:40:38

ariovaldo
Appena sbarcato sul forum
Registrato: 21-10-2019
Messaggi: 10

Re: [Risolto] Copia ed incolla in difficoltà

Zievatron ha scritto:

In Fedora30 lxde, sto trovando serie difficoltà ad eseguire la semplice copia di parole o righe con la selezione del mouse.
In lxterminal se seleziono parole o righe la selezione sparisce appena lascio.
In leafpad se uso il comando seleziona tutto la selezione compare e subito dopo scompare, se invece cerco di selezionare un rigo con il mouse, mentre procedo scompaiono i caratteri selezionati prima.
In una pagina web in firefox la selezione non sparisce e posso usare il comando copia, ma poi non trovo niente da incollare altrove. Neanche da quì a quì sotto.
Idee su cosa sia successo e come posso risolvere?

E' un bug del programma "clipit". Prova a dare un "dnf remove clipit" e dovrebbe tornare tutto normale. Vedi anche questo link:
https://bugs.debian.org/cgi-bin/bugrepo … bug=904030


Fedora KDE spin

Non in linea

#13 25-10-2019 12:26:04

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Ma clipit non è il gestore degli appunti?
Se lo elimino e basta, resto senza un gestore degli appunti. Non dovrei avere dei problemi?

Non in linea

#14 25-10-2019 12:45:03

ariovaldo
Appena sbarcato sul forum
Registrato: 21-10-2019
Messaggi: 10

Re: [Risolto] Copia ed incolla in difficoltà

Zievatron ha scritto:

Ma clipit non è il gestore degli appunti?
Se lo elimino e basta, resto senza un gestore degli appunti. Non dovrei avere dei problemi?

E' un clipboard manager e tiene solo la "storia" di tutto ciò che salvi con CTRL+c. Io non ne ho sentito la mancanza su LXDE. Comunque speriamo che risolvano il bug.


Fedora KDE spin

Non in linea

#15 30-10-2019 22:01:34

Zievatron
Pinguino avanzato
Registrato: 03-07-2013
Messaggi: 299

Re: [Risolto] Copia ed incolla in difficoltà

Confermo che il problema è quello. Senza clipit funziona normale.

Non in linea

Piè di pagina