Fedora Online Forum

Il forum della comunità italiana di Fedora

#1 17-03-2020 20:40:09

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 29

[Risolto]Scomparsa wayland all'avvio dopo installazione nvidia drivers

Buonasera a tutti,

come da titolo, ho provato ad installare i drivers nvidia per la mia scheda grafica:

[email protected]:~$ lspci | grep -e VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560] (rev a1)

Il kernel è il seguente:

[email protected]:~$ uname -r
5.5.8-200.fc31.x86_64

Il comando usato per l'installazione è stato (riporto da dnf history):

Linea di comando   : install xorg-x11-drv-nvidia-390xx akmod-nvidia-390xx
Pacchetti modificati:
    Installati akmods-0.5.6-24.fc31.noarch                                     @updates
    Installati elfutils-libelf-devel-0.178-7.fc31.x86_64                       @updates
    Installati fonts-srpm-macros-2.0.1-3.fc31.noarch                           @updates
    Installati kernel-devel-5.5.8-200.fc31.x86_64                              @updates
    Installati kmodtool-1-37.fc31.noarch                                       @updates
    Installati mesa-libEGL-19.2.8-1.fc31.i686                                  @updates
    Installati mesa-libGLES-19.2.8-1.fc31.i686                                 @updates
    Installati mesa-libGLES-19.2.8-1.fc31.x86_64                               @updates
    Installati mesa-libgbm-19.2.8-1.fc31.i686                                  @updates
    Installati nim-srpm-macros-3-1.fc31.noarch                                 @updates
    Installati python-srpm-macros-3-53.fc31.noarch                             @updates
    Installati qt5-srpm-macros-5.13.2-1.fc31.noarch                            @updates
    Installati redhat-rpm-config-143-1.fc31.noarch                             @updates
    Installati rpm-build-4.15.1-1.fc31.x86_64                                  @updates
    Installati rust-srpm-macros-13-1.fc31.noarch                               @updates
    Installati zlib-devel-1.2.11-20.fc31.x86_64                                @updates
    Installati zstd-1.4.4-1.fc31.x86_64                                        @updates
    Installati annobin-8.78-2.fc31.x86_64                                      @fedora
    Installati dwz-0.12-11.fc31.x86_64                                         @fedora
    Installati efi-srpm-macros-4-3.fc31.noarch                                 @fedora
    Installati egl-wayland-1.1.4-1.fc31.i686                                   @fedora
    Installati egl-wayland-1.1.4-1.fc31.x86_64                                 @fedora
    Installati fakeroot-1.24-2.fc31.x86_64                                     @fedora
    Installati fakeroot-libs-1.24-2.fc31.x86_64                                @fedora
    Installati fpc-srpm-macros-1.2-2.fc31.noarch                               @fedora
    Installati ghc-srpm-macros-1.5.0-1.fc31.noarch                             @fedora
    Installati gnat-srpm-macros-4-10.fc31.noarch                               @fedora
    Installati go-srpm-macros-3.0.8-4.fc31.noarch                              @fedora
    Installati libffi-3.1-23.fc31.i686                                         @fedora
    Installati libglvnd-egl-1:1.1.1-5.fc31.i686                                @fedora
    Installati libglvnd-gles-1:1.1.1-5.fc31.i686                               @fedora
    Installati libglvnd-opengl-1:1.1.1-5.fc31.i686                             @fedora
    Installati libglvnd-opengl-1:1.1.1-5.fc31.x86_64                           @fedora
    Installati libvdpau-1.3-1.fc31.i686                                        @fedora
    Installati libwayland-client-1.17.0-2.fc31.i686                            @fedora
    Installati libwayland-server-1.17.0-2.fc31.i686                            @fedora
    Installati ocaml-srpm-macros-5-6.fc31.noarch                               @fedora
    Installati openblas-srpm-macros-2-6.fc31.noarch                            @fedora
    Installati patch-2.7.6-11.fc31.x86_64                                      @fedora
    Installati perl-srpm-macros-1-33.fc31.noarch                               @fedora
    Installati rpmdevtools-8.10-9.fc31.noarch                                  @fedora
    Installati xemacs-filesystem-21.5.34-34.20190323hgc0ed7ef9a5a1.fc31.noarch @fedora
    Installati akmod-nvidia-390xx-3:390.132-4.fc31.x86_64                      @rpmfusion-nonfree-updates
    Installati nvidia-settings-390xx-390.132-1.fc31.x86_64                     @rpmfusion-nonfree-updates
    Installati xorg-x11-drv-nvidia-390xx-3:390.132-1.fc31.x86_64               @rpmfusion-nonfree-updates
    Installati xorg-x11-drv-nvidia-390xx-kmodsrc-3:390.132-1.fc31.x86_64       @rpmfusion-nonfree-updates
    Installati xorg-x11-drv-nvidia-390xx-libs-3:390.132-1.fc31.i686            @rpmfusion-nonfree-updates
    Installati xorg-x11-drv-nvidia-390xx-libs-3:390.132-1.fc31.x86_64          @rpmfusion-nonfree-updates
Output dello scriptlet:
   1 Created symlink /etc/systemd/system/multi-user.target.wants/akmods.service → /usr/lib/systemd/system/akmods.service.

Dopo il riavvio i drivers installati e in uso sono risultati correttamente quelli nvidia invece dei nouveau, tuttavia all'accesso ho notato che invece delle solite 3 opzioni (Gnome, Gnome Classico, Gnome Xorg) me ne erano rimaste due; la sessione mancante è quella di waylan, infatti:

[email protected]:~$ echo $XDG_SESSION_TYPE
x11

Aggiungo anche che

dnf history

al termine del comando di installazione mi riporta che è stato effettuato il comando

-y install --disablerepo=* /tmp/akmods.THK8txZJ/results/kmod-nvidia-390xx-5.5.8-200.fc31.x86_64-390.132-4.fc31.x86_64.rpm
Pacchetti modificati:
    Installati kmod-nvidia-390xx-5.5.8-200.fc31.x86_64-3:390.132-4.fc31.x86_64 @@commandline

che però io non ho dato.
Ho provato a dare il comando contrario rispetto a quello di installazione:

Linea di comando   : erase xorg-x11-drv-nvidia-390xx akmod-nvidia-390xx
Pacchetti modificati:
    Removed akmod-nvidia-390xx-3:390.132-4.fc31.x86_64                      @@System
    Removed akmods-0.5.6-24.fc31.noarch                                     @@System
    Removed annobin-8.78-2.fc31.x86_64                                      @@System
    Removed dwz-0.12-11.fc31.x86_64                                         @@System
    Removed efi-srpm-macros-4-3.fc31.noarch                                 @@System
    Removed egl-wayland-1.1.4-1.fc31.x86_64                                 @@System
    Removed egl-wayland-1.1.4-1.fc31.i686                                   @@System
    Removed elfutils-libelf-devel-0.178-7.fc31.x86_64                       @@System
    Removed fakeroot-1.24-2.fc31.x86_64                                     @@System
    Removed fakeroot-libs-1.24-2.fc31.x86_64                                @@System
    Removed fonts-srpm-macros-2.0.1-3.fc31.noarch                           @@System
    Removed fpc-srpm-macros-1.2-2.fc31.noarch                               @@System
    Removed ghc-srpm-macros-1.5.0-1.fc31.noarch                             @@System
    Removed gnat-srpm-macros-4-10.fc31.noarch                               @@System
    Removed go-srpm-macros-3.0.8-4.fc31.noarch                              @@System
    Removed kernel-devel-5.5.8-200.fc31.x86_64                              @@System
    Removed kmod-nvidia-390xx-5.5.8-200.fc31.x86_64-3:390.132-4.fc31.x86_64 @@System
    Removed kmodtool-1-37.fc31.noarch                                       @@System
    Removed libglvnd-gles-1:1.1.1-5.fc31.i686                               @@System
    Removed libglvnd-opengl-1:1.1.1-5.fc31.x86_64                           @@System
    Removed libglvnd-opengl-1:1.1.1-5.fc31.i686                             @@System
    Removed mesa-libGLES-19.2.8-1.fc31.x86_64                               @@System
    Removed mesa-libGLES-19.2.8-1.fc31.i686                                 @@System
    Removed nim-srpm-macros-3-1.fc31.noarch                                 @@System
    Removed nvidia-settings-390xx-390.132-1.fc31.x86_64                     @@System
    Removed ocaml-srpm-macros-5-6.fc31.noarch                               @@System
    Removed openblas-srpm-macros-2-6.fc31.noarch                            @@System
    Removed patch-2.7.6-11.fc31.x86_64                                      @@System
    Removed perl-srpm-macros-1-33.fc31.noarch                               @@System
    Removed python-srpm-macros-3-53.fc31.noarch                             @@System
    Removed qt5-srpm-macros-5.13.2-1.fc31.noarch                            @@System
    Removed redhat-rpm-config-143-1.fc31.noarch                             @@System
    Removed rpm-build-4.15.1-1.fc31.x86_64                                  @@System
    Removed rpmdevtools-8.10-9.fc31.noarch                                  @@System
    Removed rust-srpm-macros-13-1.fc31.noarch                               @@System
    Removed xemacs-filesystem-21.5.34-34.20190323hgc0ed7ef9a5a1.fc31.noarch @@System
    Removed xorg-x11-drv-nvidia-390xx-3:390.132-1.fc31.x86_64               @@System
    Removed xorg-x11-drv-nvidia-390xx-kmodsrc-3:390.132-1.fc31.x86_64       @@System
    Removed xorg-x11-drv-nvidia-390xx-libs-3:390.132-1.fc31.i686            @@System
    Removed xorg-x11-drv-nvidia-390xx-libs-3:390.132-1.fc31.x86_64          @@System
    Removed zlib-devel-1.2.11-20.fc31.x86_64                                @@System
    Removed zstd-1.4.4-1.fc31.x86_64                                        @@System
Output dello scriptlet:
   1 Removed /etc/systemd/system/multi-user.target.wants/akmods.service.
   2 Failed to stop [email protected]: Unit name [email protected] is missing the instance name.
   3 See system logs and 'systemctl status [email protected]' for details.

e dopo il riavvio ho ottenuto:

[email protected]:~$ lspci -nnk | grep -i vga -A3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF114 [GeForce GTX 560] [10de:1201] (rev a1)
	Kernel driver in use: nouveau
	Kernel modules: nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation GF114 HDMI Audio Controller [10de:0e0c] (rev a1)
[email protected]:~$ echo $XDG_SESSION_TYPE
x11

Però ancora all'accesso ho solo due opzioni. Sicuramente qualcosa è andato storto, cosa può essere che impedisce la comparsa della sessione wayland tra quelle da scegliere all'accesso?

Grazie

Ultima modifica di jack_71 (19-03-2020 12:52:57)

Non in linea

#2 17-03-2020 21:05:06

edmondo
Innamorato del forum
Registrato: 14-08-2012
Messaggi: 851

Re: [Risolto]Scomparsa wayland all'avvio dopo installazione nvidia drivers

Ciao con i driver nvidia , waylan viene disabilitato. smile


{Fedora 16/17/18/19/20/21/22/23/24/25/26/27/28/29/30/31 gnome x86_64}

Non in linea

#3 17-03-2020 23:40:18

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 29

Re: [Risolto]Scomparsa wayland all'avvio dopo installazione nvidia drivers

Ciao,

grazie, non lo sapevo. Esiste un modo per riabilitarlo dopo la disinstallazione dei drivers?

Grazie

Non in linea

#4 18-03-2020 19:42:37

edmondo
Innamorato del forum
Registrato: 14-08-2012
Messaggi: 851

Re: [Risolto]Scomparsa wayland all'avvio dopo installazione nvidia drivers

Si rimuovi i driver , è controlla che in :

/etc/gdm/custom.conf
# GDM configuration storage

[daemon]
# Uncomment the line below to force the login screen to use Xorg
WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

la riga WaylandEnable=false abbia un cancelletto davanti al massimo se non cè mettilo. elimina il file xorg.conf se lo hai creato è in

/etc/default/grub

siano sparite le righe :

 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

smile

Ultima modifica di edmondo (18-03-2020 19:45:04)


{Fedora 16/17/18/19/20/21/22/23/24/25/26/27/28/29/30/31 gnome x86_64}

Non in linea

#5 19-03-2020 12:49:45

jack_71
Appena sbarcato sul forum
Registrato: 09-01-2018
Messaggi: 29

Re: [Risolto]Scomparsa wayland all'avvio dopo installazione nvidia drivers

Grazie.

Risolto mettendo il cancelletto davanti a WaylandEnable=false
Il file xorg.conf è vuoto mentre nel file grub la linea che mi ha indicato era già sparita.
Visto che voglio cambiare scheda video pernderò una ati/radeon...

Grazie ancora

Non in linea

Piè di pagina