Comprimere file e cartelle... con il mouse

Salve a tutti,

per un po’ di tempo (non ricordo con quali versioni di Fedora) avevo l’opzione “Comprimi…” disponibile nel menu contestuale che si attiva con il tasto dx del mouse cliccando su un file o su una cartella. Tale opzione è sparita. Peccato perché era comoda averla a disposizione così.

E’ possibile in qualche modo ripristinarla?

Grazie!

Io ce l’ho ancora, prova a verificare se hai installato il pacchetto
file-roller-nautilus

Grazie jack_71, ma dnf mi dice: “Il pacchetto file-roller-nautilus-3.40.0-1.fc34.x86_64 è già installato”…

Prova file-roller e xarchiver , ps: che DE utilizzi?

file-roller ce l’ho (si apre Gestore archivi). Ho anche xarchiver.
Ambiente Gnome.

Con F35 Gnome apro File (nautilus) evidenzio il file che mi interessa, clicco col destro,
si apre la finestra e trovo la voce “Comprimi”.

Io sono ancora con fc34, ma come dicevo me lo faceva (forse era ancora fc33 o fc32… non ricordo). Comunque quello che hai descritto è proprio ciò che facevo anche io, ma niente…

Questo su Fedora 34 installata da zero.

Già. Io non ce l’ho più. Ci sono le altre voci, ma “Comprimi” no.

Giusto per curiosità
rpm -q nautilus
cosa dice?

Risponde: nautilus-40.2-1.fc34.x86_64

Sarebbe interessante capire se il problema è legato all’utente o all’intero sistema. Ne avresti voglia di creare un nuovo utente e provare con quello se Nautilus (GNOME Files) fa la stessa cosa?

Certo, e infatti creando un nuovo utente, col nuovo utente “comprimi” c’è!
Chissà cosa avrò toccato, chissà quale applicazione o impostazione lo ha fatto sparire, senza che lo volessi. In ogni caso dev’esserci un modo per “dirgli” di rimetterlo!

Bo.
Per curiosità, qual è il risultato di questo comando?

dconf dump /org/gnome/nautilus/

e anche di questo

gsettings list-recursively org.gnome.nautilus

[[email protected] master]# dconf dump /org/gnome/nautilus/
[preferences]
default-folder-viewer=‘icon-view’
search-filter-time-type=‘last_modified’

[window-state]
initial-size=(890, 550)
maximized=false

[[email protected] master]# gsettings list-recursively org.gnome.nautilus
org.gnome.nautilus.compression default-compression-format ‘zip’
org.gnome.nautilus.icon-view captions [‘none’, ‘none’, ‘none’]
org.gnome.nautilus.icon-view default-zoom-level ‘large’
org.gnome.nautilus.icon-view text-ellipsis-limit [‘3’]
org.gnome.nautilus.window-state sidebar-width 188
org.gnome.nautilus.window-state start-with-location-bar true
org.gnome.nautilus.window-state initial-size (890, 550)
org.gnome.nautilus.window-state start-with-sidebar true
org.gnome.nautilus.window-state maximized false
org.gnome.nautilus.preferences search-filter-time-type ‘last_modified’
org.gnome.nautilus.preferences default-sort-order ‘name’
org.gnome.nautilus.preferences recursive-search ‘local-only’
org.gnome.nautilus.preferences open-folder-on-dnd-hover true
org.gnome.nautilus.preferences default-sort-in-reverse-order false
org.gnome.nautilus.preferences show-hidden-files false
org.gnome.nautilus.preferences tabs-open-position ‘after-current-tab’
org.gnome.nautilus.preferences always-use-location-entry false
org.gnome.nautilus.preferences show-image-thumbnails ‘local-only’
org.gnome.nautilus.preferences search-view ‘list-view’
org.gnome.nautilus.preferences thumbnail-limit uint64 50
org.gnome.nautilus.preferences mouse-back-button 8
org.gnome.nautilus.preferences click-policy ‘double’
org.gnome.nautilus.preferences mouse-forward-button 9
org.gnome.nautilus.preferences show-create-link false
org.gnome.nautilus.preferences show-directory-item-counts ‘local-only’
org.gnome.nautilus.preferences mouse-use-extra-buttons true
org.gnome.nautilus.preferences show-delete-permanently false
org.gnome.nautilus.preferences use-experimental-views false
org.gnome.nautilus.preferences fts-enabled true
org.gnome.nautilus.preferences default-folder-viewer ‘icon-view’
org.gnome.nautilus.preferences install-mime-activation true
org.gnome.nautilus.list-view default-zoom-level ‘standard’
org.gnome.nautilus.list-view use-tree-view false
org.gnome.nautilus.list-view default-visible-columns [‘name’, ‘size’, ‘date_modified’, ‘starred’]
org.gnome.nautilus.list-view default-column-order [‘name’, ‘size’, ‘type’, ‘owner’, ‘group’, ‘permissions’, ‘mime_type’, ‘where’, ‘date_modified’, ‘date_modified_with_time’, ‘date_accessed’, ‘date_created’, ‘recency’, ‘starred’]