F33 mate e vecchia scheda video

ieri ho installato f33 mate sul mio vecchio iMac late 2009 (qest’anno ne fa 11). Il problema è che non c’è modo di regolare la luminosità:

[[email protected] ~]$ lspci | grep VGA
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96-XT [Mobility Radeon HD 4670]
[[email protected] ~]$

Ho dovuto installare scegliendo “troubleshooting”.
Devo tenermelo così?

Hai gia’ provato quanto detto qua? Non so se sia lo stesso modello pero’

E anche qua

Ho provato a smanettare con la seconda guida e il risultato è questo

Ora non so cosa fare. È lo stesso problema che mi dava la live se non sceglievo “troubleshooting” all’avvio

Se dai

$ ls -lRa /sys/class/backlight/

che dice?

Non riesco più ad accedere ad una console.

Nel senso che accendi il pc, fa il boot, e si schianta sull’immagine sopra?
Avevi modificato la linea nel grub come indicato nella seconda guida?
Puoi modificare temporaneamente la linea di boot del kernel, premendo e sulla linea del kernel che sta per partire, poi spostandoti sulla linea che inizia con linux16 dovresti poterla modificare, cancellando i parametri che hai aggiunto te, in particolare quell’ acpi_backlight (vado a memoria, quindi potrebbe non essere tutto corretto). Una volta dentro ripristina i file come prima e rebuilda grub.

Sto cercando di capire cosa scrivere nella riga acpi_backlight

In che senso cosa scrivere? Cancella la parte acpi_backlight=vendor e dovrebbe partire normalmente, no?

No, dovevo proprio cancellare acpi_backlight=quellocheè e scrivere “nomodeset rhgb quiet”.

Tra l’altro, il comando

$ ls -lRa /sys/class/backlight/ 

non restituisce nulla

Guarda un po’ cosa ho trovato qui

Non so aiutarti ulteriormente, il lato desktop non e’ proprio il mio bread and butter purtroppo.

1 Mi Piace

Tranquillo, sei sempre molto disponibile e ti ringrazio.