Glitch Schermo gnome

Ciao,
non sono sicuro sia questa la sezione giusta. me culpa in anticipo nel caso. Allora il problema è il seguente (anche se non esclusivo di fedora):
mentre uso il Dell Xps 9380 (2018) 13’’ (fedora 34, wayland, gnome 40) capita, in maniera apparentemente randomica, che le prime file di pixel in alto della barra superiore “saltino”, come un glitch, mostrando una serie di righe verticali, lunghe appena qualche pixel. Muovendo il cursore in cima il glitch scompare. Questo capita frequentemente (ad ogni sessione può capitare diverse volte). Mi pare, ma è una soggezione personale, che la frequenza aumenti all’aumentare del carico sulla gpu integrata (specialmente con monitor esterno). Ma ripeto è solo un’impressione.
Come anticipato questo problema non è eslcusivo di fedora ma mi si è presentato con identiche modalità sia su ubuntu che pop-os, ultime versioni o lts, wayland o x11. Unico denominatore comune Gnome (sia 3.36 che 3.38 che 40). Con KDE mi pare che il problema non si presenti (ma è un DE che ho usato davvero ppoco ultimamente).

Capita poi, molto raramente, che tale glitch compaia coinvolgendo tutto lo schermo. Oggi sono riuscito ad “immortalarlo” allego l’immagine.

. Anche in questo caso muovendo il cursone il glitch va via.

A parte l’estensione e la zona coinvolta, il glitch è qualitativamente lo stesso in entrambi i casi e non compromette mai il funzionamento della macchina. Come appare sparisce senza nessun apparente altra conseguenza che il glitch stesso.

output neofetch:

OS: Fedora release 34 (Thirty Four) x86_64
Host: XPS 13 9380
Kernel: 5.11.18-300.fc34.x86_64
Uptime: 53 mins
Packages: 1789 (rpm), 11 (flatpak)
Shell: bash 5.1.0
Resolution: 1920x1080
DE: GNOME 40.0
WM: Mutter
WM Theme: Adwaita
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i7-8565U (8) @ 4.600GHz
GPU: Intel WhiskeyLake-U GT2 [UHD Graphics 620]
Memory: 3566MiB / 15647MiB

Ciao @Bonnie posta :

dmesg | fpaste 

lo scrivi nel terminale è incolla qua il link ottenuto per capire meglio comè strutturata la configurazione hardware :slightly_smiling_face:

Eccolo:

https://paste.centos.org/view/33543984

Ciao @Bonnie prova in questo modo crea un file :

sudo nano -w /etc/X11/xorg.conf.d/20-intel.conf

è dentro copi :

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
  Option "TripleBuffer" "true"
EndSection

guarda come si comporta è fammi sapere :slightly_smiling_face:

So far so good. è qualche ora che utilizzo il notebook e per ora nessun altro “episodio”. Ti aggiornerò in caso accada qualcosa. Ho anche aggiunto anche

Option "AcelMethod" "glamor"

per utilizzare OpenGL per l’accelerazione grafica. Mi pare ne guadagni un pelo in performance (lato animazioni Gnome etc…) e per ora conunque nessun problema.

Ottimo @Bonnie comunque con quella stringa non cambia più di tanto è per essere utilizzata correttamete guarda qua https://www.freedesktop.org/wiki/Software/Glamor/ tra laltro è indicata per xorg.conf non per un file 20-intel.conf è non compatibile con il server grafico wayland :slightly_smiling_face:

Ciao @edmondo, grazie ancora per le dritte. Purtroppo il problema non è sparito. Mi pare si verifichi più raramente, ma potrebbe essere tranquillamente una mia impressione.

Ciao @Bonnie hai provato a togliere la stringa :

Option "AcelMethod" "glamor"

per vedere come si comporta ? sul sito della (dell xps )consigliano il file come l’ho postato io senza aggiunta di niente ho letto diversi post che molti utenti si sono lamentati di questa anomalia ma solo su wayland su xorg non causa problemi :slightly_smiling_face:

Ciao @edmondo, grazie ancora. Il problema persiste nonostante abbia tolto la stringa. Su xorg forse non accade, ma in ogni caso preferisco le gesture di wayland. :grin:

Ciao @Bonnie con quel file su xorg si fissa il problema su wayland dovrai aspettare , perchè stanno introducendo il supporto per nvidia alchè qualche anomalia cè , comunque anche sul sito della (dell) come ti ho scritto suggeriscono quel file :slightly_smiling_face: