Installazione fedora 34 in una partizione contenente Ubuntu

Ho la seguente situazione dischi in ambiente UEFI:

 sudo parted -l
[sudo] password di petrus: 
Modello: ATA TS512GSSD230S (scsi)
Disco /dev/sda: 512GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system     Nome                  Flag
 1      1049kB  538MB   537MB       fat32           EFI System Partition  avvio, esp
 2      538MB   27,4GB  26,8GB      ext4            Ubuntu 20.4
 3      27,4GB  28,5GB  1074MB      ext4            fedora 32
 4      28,5GB  36,9GB  8420MB      linux-swap(v1)                        swap
 5      93,2GB  168GB   75,2GB      ext4            fedora 32
 6      168GB   213GB   44,8GB      ext4            fedora 32


Modello: ATA SanDisk SSD PLUS (scsi)
Disco /dev/sdb: 240GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine    Dimensione  Tipo     File system  Flag
 1      1049kB  43,1GB  43,1GB      primary  ext4


Modello: ATA WDC WD10EFRX-68F (scsi)
Disco /dev/sdc: 1000GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine    Dimensione  Tipo     File system  Flag
 1      1049kB  43,2GB  43,2GB      primary  ext4
 2      43,2GB  86,4GB  43,2GB      primary  ext4
 3      86,4GB  130GB   43,2GB      primary  ext4

sda5 contiene “/” (punto di mount)
sda6 contiene “/home”.

Ora vorrei installare in sda2, dove attualmente risiede Ubuntu, Fedora 34, sia allo scopo di fare nuova esperienza sulle installazioni, sia per avere un 2° SO a fianco di quello già presente e perfettamente funzionante.

Ho avviato l’installazione di fedora 34, già scaricata e riversata in una unità USB, ma, dopo avere assegnato il disco sda ed avere selezionato l’installazione di tipo avanzato, ho selezionato la partizione sda2, con punto di mount “/” e relativa formattazione, non riesco a farla proseguire correttamente.
Infatti, cliccando su “Fatto” la procedura di installazione viene abbandonata. Posso solo tornare alla finestra vuota di fedora 34, in modalità operativa, di prova del SO.

Non ho capito in che cosa possa avere sbagliato.
In ogni caso, non c’è dubbio che debba potere installare fedora 34 in sda2.

In assenza di consigli, ho fatto da me:

  • ho eliminato la partizione sda2 (ex Ubuntu)
  • ho installato fedora 34 con la modalità Cistom, lasciando alla procedura di installazione la generazione automatica dei punti mount.

Fedora 34 workstation si è installato:
Ora la situazione dei dischi è:

[code]
sudo parted -l
Modello: ATA TS512GSSD230S (scsi)
Disco /dev/sda: 512GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco:

Numero Inizio Fine Dimensione File system Nome Flag
1 1049kB 538MB 537MB fat32 EFI System Partition avvio, esp
2 538MB 1612MB 1074MB ext4
3 27,4GB 28,5GB 1074MB ext4 fedora 32
4 28,5GB 36,9GB 8420MB linux-swap(v1) swap
5 93,2GB 168GB 75,2GB ext4 fedora 32
6 168GB 213GB 44,8GB ext4 fedora 32
7 213GB 512GB 299GB btrfs

Modello: ATA SanDisk SSD PLUS (scsi)
Disco /dev/sdb: 240GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco:

Numero Inizio Fine Dimensione Tipo File system Flag
1 1049kB 43,1GB 43,1GB primary ext4

Modello: ATA WDC WD10EFRX-68F (scsi)
Disco /dev/sdc: 1000GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: msdos
Flag del disco:

Numero Inizio Fine Dimensione Tipo File system Flag
1 1049kB 43,2GB 43,2GB primary ext4
2 43,2GB 86,4GB 43,2GB primary ext4
3 86,4GB 130GB 43,2GB primary ext4

Modello: Sconosciuto (unknown)
Disco /dev/zram0: 8283MB
Dimensione del settore (logica/fisica): 4096B/4096B
Tabella delle partizioni: loop
Flag del disco:

Numero Inizio Fine Dimensione File system Flag
1 0,00B 8283MB 8283MB linux-swap(v1)
[[email protected] ~]$

Riavviando con fedora 34 il pc si avvia.

Avviando, invece, fedora 32, il caricamento s’interrompe indicando un blocco del profilo root.

Purtroppo sono nei guai, perchè tutto il mio mondo operativo è in fedora32.
:face_with_head_bandage: :ambulance:

Problema superato.
Infatti scegliendo una linea diversa nella selezione GRUB, fedora 32 è partito bene.