OpenVPN import certificati

Ciao a tutti,

ho un problema con l’importazione di file .ovpn.
Nello specifico quando importo il file vengono importate la CA Certificate, lo User certificate ma non la private key.
I tre file per altro vengono contestualmente salvati nella mia folder .cert/nm-openvpn/

Di fatto finchè non vado ad importarla a mano (andandola a pescare appunto da nm-openvpn) il pulsante ADD (o SALVA) è disabilitato.
Importandola a mano riesco a salvare e la VPN funziona ma se successivamente vado ad editarla ho lo stesso problema:
vedo la CA e il certificato ma la private key non c’è e fintanto che non la riseleziono manualmente da .cert/nm-openvpn/ non posso salvare eventuali modifiche (ad esempio nome utente o altro).

Con Fedora 31 (F31) non avevo questo comportamento e non so se l’ho innescato io in F32 importando nella /etc/NetworkManager/system-connections le connessioni prese da F31.
(Ho in realtà importato anche tutte le chiavi dalla folder nm-openvpn del vecchio utente di F31 al nuovo di F32)
(L’installazione di F32 è su un nuovo PC)

Online ho letto altri con questo problema (su Manjaro ad esempio) ma nessuno ha risolto.

Questo un trace di nm-connection-editor lanciato da terminale:

[[email protected] ~]$ nm-connection-editor 

(nm-connection-editor:14569): Gtk-WARNING **: 13:40:48.551: GtkGrid does not have a child property called expand

(nm-connection-editor:14569): Gtk-WARNING **: 13:40:48.551: GtkGrid does not have a child property called fill
**** Message: 13:40:48.797: Cannot save connection due to error: Invalid setting VPN: cert: No key set**
** Message: 13:40:58.914: Connection validates and can be saved
[[email protected] ~]$ nm-connection-editor 

(nm-connection-editor:14864): Gtk-WARNING **: 13:41:06.987: GtkGrid does not have a child property called expand

(nm-connection-editor:14864): Gtk-WARNING **: 13:41:06.987: GtkGrid does not have a child property called fill
** Message: 13:41:07.228: Cannot save connection due to error: Invalid setting VPN: cert: No key set
** Message: 13:41:14.761: Connection validates and can be saved

Scusa è già un po’ che non uso OpenVPN.
Questa directory l’hai creata tu, e dentro ci hai messo CA, chiave, ecc., o viene creata automaticamente (“vengono contestualmente salvati” vuol dire questo?) quando crei la VPN?

La cartella è creata automaticamente dal plugin openvnp di NetworkManager.
Nel mentre ho provato ad aggiornare F31 alla F32 ed ho lo stesso comportamento.
Ora vorrei provare ad installare una F32 su una macchina virtuale, allineare il kernel e i plugin del networkManager e vedere che fa…

Sei sicuro sicuro? Ho resuscitato dei vecchi file di configurazione, e andando a configurare OpenVPN con NetworkManager (da GNOME), non mi crea nessuna cartella ~/.cert/qualsiasicosa, devo farlo a mano.

Ad ogni modo, sono su Fedora 32, installazione fresca (non ho importato /etc/NetworkManager/system-connections) e mi fa uguale a te: quando vai a editare la VPN, la User private key non si vede e va nuovamente impostata.

C’è un bug aperto su bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1832718

E anche sull’issue tracker di GNOME: https://gitlab.gnome.org/GNOME/NetworkManager-openvpn/-/issues/50

Fantastico…oggi ho fatto 1000 ricerche e non mi sono accorto di queste due segnalazioni…
mi sono erroneamente affidato solo ai crawler di Google :slight_smile:

Comunque installando una F32 fresh, senza update funziona correttamente, sarà stato introdotto da qualche update del kernel o update di plugin del Network Manager

Grazie a tutti cmq per le risposte, attendiamo fiduciosi :slight_smile:

E se provi a fare l’update? Si rompe o continua a funzionare?
Perché se si rompe (o in ogni caso) sarebbe utile segnalarlo, senza attendere fiduciosi :wink: così da far capire agli sviluppatori che con la versione presente sulla ISO di installazione funziona, e con l’ultimo aggiornamento no.