Problema con Samba

Salve a tutti,
Come da oggetto, ho problemi con la condivisione dei file in cartelle comuni.
Questa la configurazione di smb.conf

[global]
	interfaces = lo enp2s0 tun0
	hosts deny = 0.0.0.0/24
	hosts allow = 192.168.3.200 192.168.1.0/24 except 192.168.1.4 192.168.1.7 127.0.0.1
	read only = no
	encrypt password = yes
	smb passwd file = /etc/samba/smbpasswd
	browseable = yes
	log file = /var/log/samba/log.%m
	max log size = 50
	local master = yes
	os level = 34
	workgroup = MYGROUP
	server string = Server Samba Comp1
	netbios name = Seiscomp
	security = user
	map to guest = Bad User
	passdb backend = tdbsam
[Seiscomp data directories]
	comment = Seiscomp data directories
	path = /sismologia/seiscomp3/var/lib/archive
	guest ok = yes
	read only = no
	writable = yes
	create mode = 0777 # fully accessed
	directory mode = 0777 # fully accessed

[Cartella condivisa]
	comment = Cartella condivisa
	path = /shared_folder
	read only = no
	guest ok = yes
	writable = yes

[Cartella Personale]
	comment = Cartella personale
	path = /home/%S
	writable = yes
	valid users = %S

Ho anche impostato selinux in questo modo:

samba_create_home_dirs --> off
samba_domain_controller --> on
samba_enable_home_dirs --> on
samba_export_all_ro --> on
samba_export_all_rw --> on
samba_load_libgfapi --> off
samba_portmapper --> off
samba_run_unconfined --> on
samba_share_fusefs --> off
samba_share_nfs --> on
sanlock_use_samba --> off
tmpreaper_use_samba --> off
use_samba_home_dirs --> off
virt_use_samba --> off
smbd_anon_write --> on

Il problema è che non riesco ad entrare nelle cartelle personali ne a scrivere sulle directory comuni da windows con accesso tramite password. Sulla cartella condivisa invece, riesco a leggere e scrivere un file aperto dalla cartella, ma non a spostare un file nuovo.
Da linux dentro la cartella comune, non posso scrivere con alcun utente, solo da root e far diventare proprietario nobody:nobody i file. Inoltre, le cartelle ed i file che stanno sotto la cartella condivisa ed il cui proprietario è sempre nobody:nobody, non vengono aperte, come se fossero vuote.

Credo sia un problema di permessi, ma non riesco a capire quale.

Grazie