Problemi comando FSTRIM

ciao,
seguendo un consiglio di @edmondo
ho digitato

$ sudo systemctl enable fstrim 

per attivarlo, ma ecco cosa risponde il sistema:

The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit’s
.wants/ or .requires/ directory.
• A unit’s purpose may be to act as a helper for some other unit which has
a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
D-Bus, udev, scripted systemctl call, …).
• In case of template units, the unit is meant to be enabled with some
instance name specified.

Preciso che ho appena installato F34 su un SSD nuovo (mai adoperato) e ho già fatto l’upgrade.

Ciao @aiace il primo comando che avevo scritto era status :

systemctl status fstrim.service

la scritta che restituisce con enable significa che non è impostato il paramentro WantedBy=

cat /usr/lib/systemd/system/fstrim.service

[Unit]
Description=Discard unused blocks on filesystems from /etc/fstab
Documentation=man:fstrim(8)
ConditionVirtualization=!container

[Service]
Type=oneshot
ExecStart=/usr/sbin/fstrim --listed-in /etc/fstab:/proc/self/mountinfo --verbose --quiet-unsupported
PrivateDevices=no
PrivateNetwork=yes
PrivateUsers=no
ProtectKernelTunables=yes
ProtectKernelModules=yes
ProtectControlGroups=yes
MemoryDenyWriteExecute=yes
[email protected] @file-system @basic-io @system-service

come si vede è pilotato dal sistema è non da un servizio apparte è cambiato ancora qualcosa nellla gestione del sistema :slightly_smiling_face: p.s nell’altro post avevo scritto di provare ad aggiungere noatime come suggerito da @r3d3vil77 ma secondo mè non cambiava niente il motivo è questo :

[email protected] @file-system @basic-io @system-service

ormai anche ext4 supporta ssd , fino a qualche anno fà mi ricordo che in effetti si doveva aggiungere a fstab i parametri noatime discard , ma ho visto facendo una prova con il mio ssd ( che uso per le prove perchè preferisco gli hd ) che non cambia niente , installazione nuova destinazione ssd filesystem ext4 poi cè da tenere conto che non si usa più la partizione di swap perchè adesso il sistema usa zram , altro cambiamento che cè stato :slightly_smiling_face:

@edmondo
grazie, ma vai troppo nello specifico, per me…
In soldoni, che devo fare per attivare fstrim? Modificare a mano il file /usr/lib/systemd/system/fstrim.service ? E in che modo?

Vado a memoria.
sudo systemctl enable fstrim.timer --now

E per vedere quando girerà e quando è girato l’ultima volta
systemctl list-timers --no-pager

Ma serve ancora abilitare fstrim?

1 Mi Piace

In effetti: https://fedoraproject.org/wiki/Changes/EnableFSTrimTimer è abilitato di default dalla 32

Ciao @aiace prova a dare il comando :

systemctl status fstrim

è anche :

systemctl status fstrim.timer

posta il risultato che restituiscono i 2 comandi :slightly_smiling_face: @alciregi sull’astronave di @aiace cè sempre da aspettarsi di tutto , lo sò per esperienza :joy:

ehm, temo di essermi scordato di rispondere.
Se non è troppo tardi, ecco qui:

[[email protected] ~]$ systemctl status fstrim
● fstrim.service - Discard unused blocks on filesystems from /etc/fstab
Loaded: loaded (/usr/lib/systemd/system/fstrim.service; static)
Active: inactive (dead) since Mon 2021-11-08 01:23:04 CET; 24h ago
TriggeredBy: ● fstrim.timer
Docs: man:fstrim(8)
Process: 144355 ExecStart=/usr/sbin/fstrim --listed-in /etc/fstab:/proc/self/mountinfo --verbose>
Main PID: 144355 (code=exited, status=0/SUCCESS)
CPU: 463ms
nov 08 01:22:56 localhost.localdomain systemd[1]: Starting Discard unused blocks on filesystems from>
nov 08 01:23:04 localhost.localdomain fstrim[144355]: /boot/efi: 455,2 MiB (477339648 bytes) trimmed>
nov 08 01:23:04 localhost.localdomain fstrim[144355]: /: 77,5 GiB (83223580672 bytes) trimmed on /de>
nov 08 01:23:04 localhost.localdomain systemd[1]: fstrim.service: Succeeded.
nov 08 01:23:04 localhost.localdomain systemd[1]: Finished Discard unused blocks on filesystems from>

e il secondo comando:

[[email protected] ~]$ systemctl status fstrim.timer
● fstrim.timer - Discard unused blocks once a week
Loaded: loaded (/usr/lib/systemd/system/fstrim.timer; enabled; vendor preset: enabled)
Active: active (waiting) since Thu 2021-11-04 16:56:34 CET; 4 days ago
Trigger: Mon 2021-11-15 01:06:44 CET; 5 days left
Triggers: ● fstrim.service
Docs: man:fstrim

nov 04 16:56:34 localhost.localdomain systemd[1]: Started Discard unused blocks once a week.

Qualcuno (@edmondo, per esempio) mi aiuta a decifrare?
Grazie

Ciao @aiace non vedo anomalie perchè usi sia btrfs che ext4 sull’astronave , comunque posta anche :

cat /etc/fstab

che vediamo che modifiche hai fatto di nuovo , mi scuso che ti rispondo in ritardo ma ho dei problemi di salute è non sono più presente sul forum come prima :slightly_smiling_face:

ciao @edmondo
spero che non sia nulla di grave: sei una colonna portante del forum, non puoi mancare!
Ecco l’output del comando richiesto (ho solo cancellato le righe commentate):

[[email protected] ~]$ cat /etc/fstab

 /dev/nvme0n1p5          /                       btrfs   subvol=root00,compress=zstd:1 0 0 noatime
    UUID=f99ab5a7-ed12-4bf1-bf0c-1a6c702dd0cf /boot                   ext4    defaults        1 2
    UUID=DF19-F181          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
    UUID=bf0304c9-ff99-4b0b-a763-e4ffbc0ff551 /home                   ext4    defaults        1 2

Grazie sempre della premura e della collaborazione!