[Risolto -> Blender-SoftwareGL] Blender 2.81a non funziona

eseguendo Blender 2.81 e Blender 2.81a (nei repository test) danno il seguente errore:

$ blender Received X11 Error: error code: 165 request code: 151 minor code: 34 error text: GLXBadFBConfig Received X11 Error: error code: 165 request code: 151 minor code: 34 error text: GLXBadFBConfig Received X11 Error: error code: 165 request code: 151 minor code: 34 error text: GLXBadFBConfig Received X11 Error: error code: 165 request code: 151 minor code: 34 error text: GLXBadFBConfig Received X11 Error: error code: 165 request code: 151 minor code: 34 error text: GLXBadFBConfig Received X11 Error: error code: 165 request code: 151 minor code: 34 error text: GLXBadFBConfig Received X11 Error: error code: 8 request code: 151 minor code: 34 error text: BadMatch (invalid parameter attributes) Received X11 Error: error code: 8 request code: 151 minor code: 34 error text: BadMatch (invalid parameter attributes) Received X11 Error: error code: 8 request code: 151 minor code: 34 error text: BadMatch (invalid parameter attributes) Received X11 Error: error code: 8 request code: 151 minor code: 34 error text: BadMatch (invalid parameter attributes) Received X11 Error: error code: 8 request code: 151 minor code: 34 error text: BadMatch (invalid parameter attributes) Received X11 Error: error code: 8 request code: 151 minor code: 34 error text: BadMatch (invalid parameter attributes) Writing: /tmp/blender.crash.txt Segmentation fault (core dump creato)

Scaricato blender 2.81a dal sito di blender ed eseguendolo dalla shell mi segnala lo stesso errore.

Avendo installato in Virtualbox 6.1 Manjaro kde 18.1.0 provando blender 2.81a scaricato dal sito di blender il programma funziona regolarmente.

Costatato anche con la shell mi da la stesa lista di errori fino all’ultimo errore di X11 dopo avvia python ed il programma funziona regolarmente.

In Manjaro in virtualbox rispetto a Fedora 30 c’è il Kernel 5.4.2 e Mesa 19.2.7 con OpenGL 3.1

Secondo il mio parere per poter funzionare in Fedora 30 devono essere aggiornati Mesa e il Kernel ?

Ciao

N.B.: driver grafico: Nouveau NV92 OpenGL 3.3 – Blender 2.80 con fedora 30 in programma funziona regolarmente.

Con l’aggiornamento del Kernel 5.4.7 il programma da lo stesso errore.

Secondo il mio parere si vorrebbe aggiornato Mesa 19.2.8 ?

Ciao

Arrivato un altro aggiornamento del suddetto risultato idem con patate.

Ciao

Scaricando dal sito di blender la versione 2.82.

Eseguendo lo script blender-softwaregl il programma parte --> cambiando l’impostazione del motore di rendering in Workbench il programma funziona regolarmente.

Ciao

N.B.: In Fedora 30 Blender 2.81a nella directory /usr/bin non si trova lo script blender-softwaregl.

Con Fedora 32 64bit il problema persiste.

Trovato link : https://developer.blender.org/T76529 potrebbe essere questo il problema ?

Ciao

Ciao :slight_smile:
Se hai risolto usa il bottone “Soluzione” sul messaggio che contiene la soluzione, senza modificare il titolo :slight_smile: (evito di scriverlo anche sugli altri tuoi topic).