Stampante Laser Canon lbp2900 non riconosciuta

Ciao a tutti, la mia fedorina non riconosce la stampante come in oggetto. Girovagando su internet ho trovato quello per ubuntu ma per fedora nulla…qualcuno mi potrebbe aiutare?
la mia versione è la 30 a 64 bit.

Grazie a chi mi risponderà in anticipo.

Ciao, cosa hai trovato per ubuntu? Il driver? come si chiama?

Sul sito del produttore ho trovato questo, ma ovviamente non ho potuto usarlo:
https://www.canon-europe.com/support/consumer_products/products/printers/laser/i-sensys_lbp2900.html?type=drivers&driverdetailid=tcm:13-1057853&os=linux%20(64-bit)&language=en

Ciao, ho provato con i file .rpm come segnalati da te dal sito del produttore ed ho provato anche con “wine” con il file eseguibile di winzoz (.exe) e installati anche i pacchetti aggiuntivi come “wintricks” e “q4wine” ma in entrambi i casi mi restituiscono l’errore “wine cannot find the file “setup.ini” necessary for installation”, cosa mi suggerisci di fare?

di seguito ti riporto il link di ubuntu:
https://forum.ubuntu-it.org/viewtopic.php?p=4239485

Come hai installato gli rpm? Hai installato i 64bit, vero?

si, la versione 64, e l’ho installata con il metodo tradizionale ovvero clicca e installa.

Nella guida che si trova nel file scaricato (README-capt-2.71UK.txt) dice di installare:

<For Fedora 18/19/20/21(64-bit)> 
   # dnf install pangox-compat 
   # dnf install glibc.i686 *
   # dnf install libgcc.i686 *
   # dnf install libstdc++.i686 *
   # dnf install popt.i686 *
   # dnf install libxml2.i686 *

   * There may be cases where installation of the 64-bit library of the same 
     name (newest version) is required.
     Example:
     If the library installation fails with the command "yum install 
     glibc.i686," this may be remedied by executing "yum install glibc.i686" 
     after installing 64-bit glibc library with the command "yum install glibc".

# dnf install cndrvcups-capt-2.71-x.x86_64.rpm
# dnf install cndrvcups-common-3.21-x.x86_64.rpm

Con un’altra stampante CANON ImageRunner 2520 installa anche librerie 32bit.

Ciao

Ciao, ma sono alla versione 30 a 64 bit e andrebbe bene comunque la guida che mi ha segnalato delle versioni precedenti?

Non ti so rispondere, ma per la stampante CANON ImageRunner 2520 quando scarichi i driver c’è il comando install ed installa anche librerie 32Bit.

Trovata guida per installare questa stampante: https://forums.fedora-fr.org/viewtopic.php?id=60049

vedi se funziona.

guida ubuntu: https://wiki.ubuntu-it.org/Hardware/StampantiScanner/CanonLbp2900

Ciao

Ti sono servite le guide ?

Ciao

Ciao, non ho ancora provato e non appena ho un po’ di tempo le provo.Grazie

Ciao, allora ho provato tutte le guide che mi hai segnalato e non hanno dato esito positivo ma l’ultima quella di ubuntu quando inserisco la seguente stringa:

# /etc/init.d/cupsys stop

mi restituisce errore “no such file or directory” come dovrei procedere?
ovvero questi comandi che dovrei inserire vanno bene anche per fedora, visto che sono stati scritti per ubuntu?

# ln -s /etc/init.d/cups /etc/init.d/cupsys
# /etc/init.d/cupsys stop
# killall cupsd
# mkdir /var/ccpd
# mkdir /var/captmon
# mkfifo /var/ccpd/fifo0
# chmod 777 /var/ccpd/fifo0
# chmod -R a+rX /usr/share/cups/model

Mi sembra che questi comandi non vadano bene per fermare il server di stampa di Fedora:

https://askbot.fedoraproject.org/en/question/11012/how-to-stop-cupsd/https://askbot.fedoraproject.org/en/question/103800/cant-enable-cupsservice-to-boot/

Questi due link sono i comandi per Fedora per fermare o abilitare i server di stampa.

Trovata altra guida: https://forum.fedoraonline.it/viewtopic.php?id=18282

Se non hai trovato la soluzione con le guide da me suggerite non so come posso aiutarti.

Ciao

Ciao, ho seguito l’ultima guida che mi hai segnalato e che di seguito riporto:

[[email protected] linux-capt-drv-v271-uken]# cd /home/skiava/Scaricati/linux-capt-drv-v271-uken/64-bit_Driver/RPM
[[email protected] RPM]# ls
cndrvcups-capt-2.71-1.x86_64.rpm  cndrvcups-common-3.21-1.x86_64.rpm
[[email protected] RPM]# rpm -ivh cndrvcups-common-3.21-1.x86_64.rpm
Verifying...                          ################################# [100%]
Preparazione in corso...              ################################# [100%]
	il pacchetto cndrvcups-common-3.21-1.x86_64 è già installato
[[email protected] RPM]# rpm -ivh cndrvcups-capt-2.71-1.x86_64.rpm
Verifying...                          ################################# [100%]
Preparazione in corso...              ################################# [100%]
	il pacchetto cndrvcups-capt-2.71-1.x86_64 è già installato
[[email protected] RPM]# /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
[[email protected] RPM]# /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

 CUPS_ConfigPath = /etc/cups/
 LOG Path        = None
 UI Port         = 59787

 Entry Num  : Spooler	: Backend	: FIFO path		: Device Path 	: Status 
 ----------------------------------------------------------------------------
     [0]    : LBP2900 	: ccp 		: /var/ccpd/fifo0 	: /dev/usb/lp0 : New!!

[[email protected] RPM]# /etc/init.d/ccpd restart
Restarting ccpd (via systemctl):                             OK  ]
[[email protected] skiava]#  service ccpd status
/usr/sbin/ccpd: 5205 5197
[[email protected] RPM]# [email protected] RPM]# captstatusui -P LBP2900

(captstatusui:5236): GLib-CRITICAL **: 11:04:12.579: Source ID 13 was not found when attempting to remove it
[[email protected] RPM]#

ma arrivato al punto 11 della guida la stampante la vede ma non stampa…la finestra del “captstatusui” mi restituisce il codice di errore:

Check the followings:
Is the printer turned on?
Is the cable correctly connected?

i pacchetti installati sono i seguenti:

[[email protected] skiava]# rpm -qa | grep  cndrvcups-*
cndrvcups-capt-2.71-1.x86_64
cndrvcups-common-3.21-1.x86_64

riposto di seguito anche lo status del cups.service e del ccpd:

[[email protected] ~]$  systemctl status cups.service
● cups.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset>
   Active: active (running) since Tue 2020-02-18 11:03:00 CET; 1 day 21h ago
     Docs: man:cupsd(8)
 Main PID: 5152 (cupsd)
   Status: "Scheduler is running..."
    Tasks: 2 (limit: 4915)
   Memory: 22.4M
   CGroup: /system.slice/cups.service
           ├─5152 /usr/sbin/cupsd -l
           └─5288 /usr/lib/cups/notifier/dbus dbus://

feb 20 01:25:20 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 02:23:40 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 03:22:00 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 04:20:20 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 05:18:40 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 06:17:00 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 07:15:20 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
feb 20 08:13:40 skiava-sdt cupsd[5152]: REQUEST localhost - - "POST / HTTP/1.1">
Warning: Journal has been rotated since unit was started. Log output is incompl>
[[email protected] skiava]# systemctl restart ccpd.service
[[email protected] skiava]# systemctl status ccpd
● ccpd.service
   Loaded: loaded (/etc/rc.d/init.d/ccpd; generated)
   Active: active (running) since Thu 2020-02-20 09:07:43 CET; 25s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 30049 ExecStart=/etc/rc.d/init.d/ccpd start (code=exited, status=0/SUCCES>
    Tasks: 5 (limit: 4915)
   Memory: 11.9M
   CGroup: /system.slice/ccpd.service
           ├─ 4259 captmon2 --data-write-fd=7 --data-read-fd=11 --cmd-write-fd=12 -->
           ├─11239 captmon2 --data-write-fd=7 --data-read-fd=11 --cmd-write-fd=12 -->
           ├─30062 /usr/sbin/ccpd
           ├─30071 /usr/sbin/ccpd
           └─30101 captmon2 --data-write-fd=3 --data-read-fd=10 --cmd-write-fd=11 -->

feb 20 09:07:43 skiava-sdt systemd[1]: Starting ccpd.service...
feb 20 09:07:43 skiava-sdt ccpd[30049]: [40B blob data]
feb 20 09:07:43 skiava-sdt systemd[1]: Started ccpd.service.

[[email protected] skiava]# 

Infine, ho constatato dalla notifica della “segnalazione problemi” della stampante il seguente messaggio di errore:

Stampanti terminato inaspettatamente
L'applicazione ha riscontrato un errore e non può continuare (crash dell'applicazione).
Nome: gnome-control-center
Versione: 3.32.2-1.fc30.x86_64
Rilevato la prima volta: 3 days ago
Segnalazioni: ABRT Server

Questo problema è stato segnalato, ma non è stato aperto alcun ticket in Bugzilla. Gli sviluppatori hanno bisogno di maggiori informazioni per poterlo risolvere.
È utile segnalare il problema su Bugzilla per aggiungere le informazioni necessarie.

dove sbaglio e come dovrei procedere?

Ciao io ho una LBP 2900 i-sensys su fedora. Mi ha dato un po di guai ma funziona. Tin invio la procedura che ho seguito, sono la versione 2.40 e fedora 17 ma io uso la 2.71 e fedora 33:

Solved Fedora 17 and Canon LBP 2900
Hello.
I'm goingo to post the new guide for the installation of Canon LBP2900 series on Fedora 17.
I think that this guide may be useful for all Canon LBP series.

1)open root terminal and dont' connect the printer

2) install all dependancies
#yum install libc.so.6 libgcc_s.so.1 libpopt.so.0 libstdc++.so.6 libxml2.so.2 libz.so.1

5)install cndrvcups-common file
#rpm -ivh cndrvcups-common-2.40-1.x86_64.rpm

6)install cndrvcups-capt file

#rpm -ivh cndrvcups-capt-2.40-1.x86_64.rpm

7)switch on the printer and connect it on PC
wait the system to recognize the printer

8) record the printer on the Print Spooler
#/usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E

9)record the printer on daemon setup file
# /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

10)restart ccpd daemon

# systemctl restart ccpd

11) go to Applications/System Settings/Printers from Fedora menu.
You will find the printer. You can print a test page. Set it as default printer.

12)edit rc.local to start the ccpd daemon at boot
## echo /etc/init.d/ccpd start >> /etc/rc.local
# systemctl start ccpd
# systemctl enable ccpd

13)set cups service to start at boot
## chkconfig --level 35 cups on

14)set ccpd service to start at boot
#cd /etc/init.d
#sudo gedit ccpd
(replace "gedit" with "kwrite" or other test editor if you use KDE or other DE)

and paste under #!/bin/sh this
# chkconfig: 2345 95 20
# description: Some description
# What your script does (not sure if this is necessary though)
# processname: myscript

including in the copy also #
and save

15)
#chkconfig --level 35 ccpd on

16)you can reboot and good printing


If you have a LBP series different from 2900
you can replace the point 8) and 9) with the following command

# ls /usr/share/cups/model/ | grep CNCUPS

for see the list of drivers for the LBP series printers.
this is the result
CNCUPSLBP1120CAPTJ.ppd
CNCUPSLBP1120CAPTK.ppd
CNCUPSLBP1210CAPTJ.ppd
CNCUPSLBP1210CAPTK.ppd
CNCUPSLBP2900CAPTK.ppd
CNCUPSLBP3000CAPTJ.ppd
CNCUPSLBP3000CAPTK.ppd
CNCUPSLBP3200CAPTJ.ppd
CNCUPSLBP3200CAPTK.ppd
CNCUPSLBP3210CAPTJ.ppd
CNCUPSLBP3210CAPTK.ppd
CNCUPSLBP3300CAPTJ.ppd
CNCUPSLBP3300CAPTK.ppd
CNCUPSLBP3600CAPTJ.ppd
CNCUPSLBP5000CAPTJ.ppd
CNCUPSLBP5000CAPTK.ppd

there are two driver


*K.ppd

*J.ppd

you have to try first with file K.ppd

and to record printer on print spooler
# /usr/sbin/lpadmin -p [printer model] -m [printer driver file name] -v ccp:/var/ccpd/fifo0 -E

and to record printer on daemon setup file
# /usr/sbin/ccpdadmin -p [printer model] -o /dev/usb/lp0


#---------------------------
se da dmesg vedo usblp0: nonzero write bulk status received: -108
1) Edit /etc/modprobe.d/blacklist.conf adding a line

blacklist usblp

and then run the command

sudo rmmod usblp

NON SERVE: do
modprobe usblp
---------
uso system-config-printer
---------

risolto: mamcava lo spooling:
mkdir /var/ccpd
mkfifo /var/ccpd/fifo0

quando non stampa provare a riavviare: /etc/init.d/ccpd restart

auguri!

ciao Edmondo,

il readme che ho inviato in effetti e’ un po datato e funzionava all’epoca anche con yum ma l’avevo utilizzato inizialmente con con il pacchetto 2.70 e successivamente con 2.71 che indichi tu (o almeno credo sia lo stesso: linux-capt-drv-v271-uken.tar.gz). Lì dentro non ci sono unit di systemd: di fatto usa lo script /etc/rc.d/init.d/ccpd. In realta’ sarei ben contento di poter usare qualcosa di piu’ recente: spero mi sfugga qualcosa, se hai idee dimmi pure

Ciao

Davide

Ciao @dav il driver infatti è linux-capt-drv-v271-uken.tar.gz dentro hai il pacchetto x64.rpm lo installi è crei una voce in systemd per farlo partire , anzichè usare rc.local ormai deprecato crei un servizio deticato a ccpd , se guardi nella doc di fedora fà vedere degli esempi per creare un servizio systemd o se nò guarda quà https://blog.smsoft.it/2019/12/17/systemd-creare-un-nuovo-servizio/ a grosso modo spiega come creare un servizio per systemd , ovviamente non è semplice la prima volta ma ci si prende la mano :slightly_smiling_face: