Ancora e sempre freeze ,blocchi

Ciao a tutti ,
avevo fatto un post , vedi https://forum.fedoraonline.it/viewtopic.php?id=25523 , e poi dato per risolto ma il problema c’e sempre ,nonostante ora sia con F28 e abbia di nuovo aggiornato il bios , beta, e fatto vari tentativi per cercare di risolvere.
con Windows 10 che è sullo stesso SSD M2 Samsung da 250 gb non lo fa. Con un altro SSD non lo fa.
Ci sono blocchi totali della macchina ,sia lavorando che quando è inutilizzata ,a volte il mouse si muove a volte no ma comunque non agisce. L’altro giorno lavorando con Audacity si è bloccato tutto ma la riproduzione no , e ripeteva un breve loop;
l’unica soluzione è spegnere elettricamente.
Avevo installato i driver di una penna wifi vedi usb https://forum.fedoraonline.it/viewtopic.php?id=25480 . siccome abrt riporta errori ,

Errore di sistema inaspettato
Il sistema ha rilevato e ripristinato un errore.
impossibile da riportare
A kernel problem occurred, but your kernel has been tainted (flags:GOE). Explanation:
O - Out-of-tree module has been loaded.
E - Unsigned module has been loaded.
Kernel maintainers are unable to diagnose tainted reports.Moduli corrotti: rtl8812au.

è possibile che siano questi driver installati a creare i blocchi ? se è si come faccio a disinstallare il tutto ?

grazie
ciao

Possibile. Puoi mettere il modulo in blacklist, senza disinstallato. Ci sono varie possibilità: per fare una prova puoi fare il boot aggiungendo “module_blacklist=rtl8812au” come parametro.

Ciao frafra ,
grazie per la risposta ,ho aspettato per provare bene. lo fa meno ,ma purtroppo lo fa , 3 volte in questo tempo.
stamattina ho notato che anche mettendo il driver in blacklist come mi hai detto , il dongle usb funziona regolarmente.
fino ad ora non lo avevo più utilizzato , usando un altro ,non 5ghz.
Non è stato messo in blacklist bene? ho aggiunto la stringa , al fondo della riga del kernel nel boot.
grazie
ciao

Sì¸se funziona vuol dire che non è nella blacklist. Prova con:

# echo 'blacklist rtl8812au' > /etc/modprobe.d/disable-wifi-dongle.conf

grazie ,provo così .
il dongle non funziona , bene. Ora devo aspettare e vedere se si blocca.
grazie
ciao

Ciao ,
purtroppo lo fa , anzi oggi lo ha fatto anche con l’altro ssd con F27 , quindi devo ricominciare da zero a capire quale potrebbe essere il guaio. Motherboard ? ram?
è tutto nuovo , gennaio 2018. e il problema lo ha fatto dall’inizio.
Avevo seguito le indicazioni per riattivare il “reisub” ma non funziona.
grazie in anticipo
ciao

aggiungo : fatto memtest , nessun errore .

Dai una occhiata a cosa dice mcelog, che tiene traccia di varie cose strane che succedono all’hardware:

$ journalctl --unit mcelog

Controlla se il produttore della tua scheda madre ha rilasciato qualche aggiornamento (ormai le schede madri moderne sono piene di bug - pure i processori :D).

In passato ho visto un problema simile con una SSD OCZ, bisogna cercare di isolare il problema; è una scocciatura, lo so, ma è l’unica. Conviene farlo, così se si trattasse effettivamente di un difetto hardware puoi far valere la garanzia.

Allora , da utente dice “No entry” ma dice anche così non si possono vedere altri utenti e admin , ho dato il comando come root e sono usciti una marea di output ,non ho copiato tutto perché sono tantissimi ma sono tutti uguali

[[email protected] ~]# journalctl --unit mcelog
-- Logs begin at Mon 2018-04-30 07:59:49 CEST, end at Mon 2018-06-11 23:06:59 C>
apr 30 09:36:35 mycomputer systemd[1]: Started Machine Check Exception Logging >
apr 30 09:36:35 mycomputer mcelog[779]: mcelog: ERROR: AMD Processor family 23:>
apr 30 09:36:35 mycomputer mcelog[779]: CPU is unsupported
apr 30 09:36:35 mycomputer systemd[1]: mcelog.service: Main process exited, cod>
apr 30 09:36:35 mycomputer systemd[1]: mcelog.service: Unit entered failed stat>
apr 30 09:36:35 mycomputer systemd[1]: mcelog.service: Failed with result 'exit>
-- Reboot --
mag 01 10:48:03 mycomputer systemd[1]: Started Machine Check Exception Logging >
mag 01 10:48:03 mycomputer mcelog[774]: mcelog: ERROR: AMD Processor family 23:>
mag 01 10:48:03 mycomputer mcelog[774]: CPU is unsupported
mag 01 10:48:03 mycomputer systemd[1]: mcelog.service: Main process exited, cod>
mag 01 10:48:03 mycomputer systemd[1]: mcelog.service: Unit entered failed stat>
mag 01 10:48:03 mycomputer systemd[1]: mcelog.service: Failed with result 'exit>
-- Reboot --
mag 02 08:05:11 mycomputer systemd[1]: Started Machine Check Exception Logging >
mag 02 08:05:11 mycomputer mcelog[810]: mcelog: ERROR: AMD Processor family 23:>
mag 02 08:05:11 mycomputer mcelog[810]: CPU is unsupported
mag 02 08:05:11 mycomputer systemd[1]: mcelog.service: Main process exited, cod>
mag 02 08:05:11 mycomputer systemd[1]: mcelog.service: Unit entered failed stat>
mag 02 08:05:11 mycomputer systemd[1]: mcelog.service: Failed with result 'exit>
-- Reboot --
mag 02 10:31:39 mycomputer systemd[1]: Started Machine Check Exception Logging >
 CEST, end at Mon 2018-06-11 23:06:59 CEST. --
tarted Machine Check Exception Logging Daemon.
mcelog: ERROR: AMD Processor family 23: mcelog does not support this processor.>
CPU is unsupported
celog.service: Main process exited, code=exited, status=1/FAILURE
celog.service: Unit entered failed state.
celog.service: Failed with result 'exit-code'.

tarted Machine Check Exception Logging Daemon.
mcelog: ERROR: AMD Processor family 23: mcelog does not support this processor.>
CPU is unsupported
celog.service: Main process exited, code=exited, status=1/FAILURE
celog.service: Unit entered failed state.
celog.service: Failed with result 'exit-code'.
tarted Machine Check Exception Logging Daemon.
mcelog: ERROR: AMD Processor family 23: mcelog does not support this processor.>
CPU is unsupported
celog.service: Main process exited, code=exited, status=1/FAILURE
celog.service: Unit entered failed state.
celog.service: Failed with result 'exit-code'.
tarted Machine Check Exception Logging Daemon.
 EST. --
aemon.
mcelog does not support this processor.  Please use the edac_mce_amd module =exited, status=1/FAILURE
aemon.
mcelog does not support this processor.  Please use the edac_mce_amd module ins>
=exited, status=1/FAILURE
.aemon.
mcelog does not support this processor.  Please use the edac_mce_amd module ins>
=exited, status=1/FAILURE
aemon.
 Please use the edac_mce_amd module instead.

grazie
ciao

ciao ,
in rete ci sono parecchi bug ,su Redhat , sono tutti EOL ,iniziano da F20 sulle varie famiglie AMD .
Da anni , terza volta, assemblo il mio desktop sempre AMD e Fedora ,ma è la prima volta che ho questi problemi.
comunque leggendo un po’ tutti i bug report , ho trovato questi comandi, che ho dato

# systemctl disable mcelog
# dnf -y erase mcelog 

potrebbe andare ?
grazie
ciao

edit : come non detto , si è bloccato tutto appena inviato il post. ho dovuto come al solito spegnere e riaccendere.

Ah, è un Ryzen, carino. Non ti preoccupare di mcelog, puoi ignorarlo/disabilitarlo in questo caso.

Se guardi il boot precedente noti qualcosa di strano?

$ journalctl -b-1

Che GPU usi e con che driver? Aggiornamenti scheda madre? SSD?

Ciao frafra ,
si ,un Ryzen 1600 X ,
GPU AMD R5 230 Caicos , kernel driver radeon ;
ssd : Samsung 850 evo M2 250 gb , Samsung 840 pro 128gb ,del vecchio desktop ,firmware aggiornati.
motherboard AsRock AB350 pro4 ,bios aggiornatissimo all’ultima beta, 4.82.

$ journalctl -b-1
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal', 'wheel' can see all messages.
      Pass -q to turn off this notice.
-- Logs begin at Mon 2018-04-30 09:36:38 CEST, end at Tue 2018-06-12 11:14:23 C>
giu 12 08:48:18 mycomputer systemd[2975]: Listening on Sound System.
giu 12 08:48:18 mycomputer systemd[2975]: Reached target Timers.
giu 12 08:48:18 mycomputer systemd[2975]: Reached target Paths.
giu 12 08:48:18 mycomputer systemd[2975]: Starting D-Bus User Message Bus Socke>
giu 12 08:48:18 mycomputer systemd[2975]: Listening on D-Bus User Message Bus S>
giu 12 08:48:18 mycomputer systemd[2975]: Reached target Sockets.
giu 12 08:48:18 mycomputer systemd[2975]: Reached target Basic System.
giu 12 08:48:18 mycomputer systemd[2975]: Reached target Default.
giu 12 08:48:18 mycomputer systemd[2975]: Startup finished in 36ms.
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: (--) Log file rena>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: X.Org X Server 1.1>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Release Date: 2017>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: X Protocol Version>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Build Operating Sy>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Current Operating >
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Kernel command lin>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Build Date: 23 Apr>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Build ID: xorg-x11>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Current version of>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]:         Before rep>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]:         to make su>
giu 12 08:48:18 mycomputer /usr/libexec/gdm-x-session[2998]: Markers: (--) prob>

ci sono ancora molte righe ma aggiungo solo queste che sono in rosso

Process 3386 (abrt-applet) of user 1000 dumped core.          
           Stack trace of thread 3386:
           #0  0x00007f5c5702be35 g_hash_table_lookup (libglib-2.0.so.0)
           #1  0x00007f5c59d3fbed problem_data_get_content_or_NULL (libreport.s>
           #2  0x0000560b96b61182 show_problem_list_notification (abrt-applet)
           #3  0x0000560b96b61589 process_deferred_queue_timeout_fn (abrt-apple>
           #4  0x00007f5c5703a1cb n/a (libglib-2.0.so.0)
           #5  0x00007f5c5703d8ad g_main_context_dispatch (libglib-2.0.so.0)
           #6  0x00007f5c5703dc78 n/a (libglib-2.0.so.0)
           #7  0x00007f5c5703dfa2 g_main_loop_run (libglib-2.0.so.0)
           #8  0x00007f5c590347fd gtk_main (libgtk-3.so.0)
           #9  0x0000560b96b5f85a main (abrt-applet)
           #10 0x00007f5c56c5518b __libc_start_main (libc.so.6)
           #11 0x0000560b96b5f9ca _start (abrt-applet)
           
           Stack trace of thread 3404:
           #0  0x00007f5c56d21589 __poll (libc.so.6)
           #1  0x00007f5c5703dbe6 n/a (libglib-2.0.so.0)
           #2  0x00007f5c5703dfa2 g_main_loop_run (libglib-2.0.so.0)
           #3  0x00007f5c5762e6ba n/a (libgio-2.0.so.0)
           #4  0x00007f5c57065f2a n/a (libglib-2.0.so.0)
           #5  0x00007f5c54b9c594 start_thread (libpthread.so.0)
           #6  0x00007f5c56d2c00f __clone (libc.so.6)
           
           Stack trace of thread 3402:
           #0  0x00007f5c56d21589 __poll (libc.so.6)
           #1  0x00007f5c5703dbe6 n/a (libglib-2.0.so.0)
           #2  0x00007f5c5703dd10 g_main_context_iteration (libglib-2.0.so.0)
           #3  0x00007f5c5703dd61 n/a (libglib-2.0.so.0)
           #4  0x00007f5c57065f2a n/a (libglib-2.0.so.0)
           #5  0x00007f5c54b9c594 start_thread (libpthread.so.0)
           #6  0x00007f5c56d2c00f __clone (libc.so.6)
           
           Stack trace of thread 4659:
           #0  0x00007f5c56d21589 __poll (libc.so.6)
           #1  0x00007f5c5703dbe6 n/a (libglib-2.0.so.0)
           #2  0x00007f5c5703dd10 g_main_context_iteration (libglib-2.0.so.0)
           #3  0x00007f5c3cc6ee4d dconf_gdbus_worker_thread (libdconfsettings.s>
           #4  0x00007f5c57065f2a n/a (libglib-2.0.so.0)
           #5  0x00007f5c54b9c594 start_thread (libpthread.so.0)
           #6  0x00007f5c56d2c00f __clone (libc.so.6)
.desktop[4720]: Fontconfig warning: "/etc/fonts/fonts.conf", line 5: unknown el>
.desktop[4720]: Fontconfig warning: "/etc/fonts/fonts.conf", line 6: unknown el>
.desktop[4720]: Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attr>
.desktop[4720]: Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attr>
.desktop[4720]: Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attr>
.desktop[4720]: Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attr>
.desktop[4720]: Fontconfig warning: "/etc/fonts/fonts.conf", line 9: unknown el>
.desktop[4720]: Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf",>
.desktop[4720]: Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf",>
.desktop[4720]: Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", l>
.desktop[4720]: Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", l>


       Stack trace of thread 3386:
           #0  0x00007f5c5702be35 g_hash_table_lookup (libglib-2.0.so.0)
           #1  0x00007f5c59d3fbed problem_data_get_content_or_NULL (libreport.s>
           #2  0x0000560b96b61182 show_problem_list_notification (abrt-applet)
           #3  0x0000560b96b61589 process_deferred_queue_timeout_fn (abrt-apple>
           #4  0x00007f5c5703a1cb n/a (libglib-2.0.so.0)
           #5  0x00007f5c5703d8ad g_main_context_dispatch (libglib-2.0.so.0)
           #6  0x00007f5c5703dc78 n/a (libglib-2.0.so.0)
           #7  0x00007f5c5703dfa2 g_main_loop_run (libglib-2.0.so.0)
           #8  0x00007f5c590347fd gtk_main (libgtk-3.so.0)
           #9  0x0000560b96b5f85a main (abrt-applet)
           #10 0x00007f5c56c5518b __libc_start_main (libc.so.6)
           #11 0x0000560b96b5f9ca _start (abrt-applet)
           
           Stack trace of thread 3404:
           #0  0x00007f5c56d21589 __poll (libc.so.6)
           #1  0x00007f5c5703dbe6 n/a (libglib-2.0.so.0)
           #2  0x00007f5c5703dfa2 g_main_loop_run (libglib-2.0.so.0)
           #3  0x00007f5c5762e6ba n/a (libgio-2.0.so.0)
           #4  0x00007f5c57065f2a n/a (libglib-2.0.so.0)
           #5  0x00007f5c54b9c594 start_thread (libpthread.so.0)
           #6  0x00007f5c56d2c00f __clone (libc.so.6)

_table_lookup (libglib-2.0.so.0)
m_data_get_content_or_NULL (libreport.so.0)
roblem_list_notification (abrt-applet)
s_deferred_queue_timeout_fn (abrt-applet)
ibglib-2.0.so.0)
_context_dispatch (libglib-2.0.so.0)
ibglib-2.0.so.0)
_loop_run (libglib-2.0.so.0)
in (libgtk-3.so.0)
abrt-applet)
_start_main (libc.so.6)
 (abrt-applet)
 (libc.so.6)
ibglib-2.0.so.0)
_loop_run (libglib-2.0.so.0)
ibgio-2.0.so.0)
ibglib-2.0.so.0)
thread (libpthread.so.0)
e (libc.so.6)

           Stack trace of thread 3386:
           #0  0x00007f5c5702be35 g_hash_table_lookup (libglib-2.0.so.0)
           #1  0x00007f5c59d3fbed problem_data_get_content_or_NULL (libreport.s>
           #2  0x0000560b96b61182 show_problem_list_notification (abrt-applet)
           #3  0x0000560b96b61589 process_deferred_queue_timeout_fn (abrt-apple>
           #4  0x00007f5c5703a1cb n/a (libglib-2.0.so.0)
           #5  0x00007f5c5703d8ad g_main_context_dispatch (libglib-2.0.so.0)
           #6  0x00007f5c5703dc78 n/a (libglib-2.0.so.0)
           #7  0x00007f5c5703dfa2 g_main_loop_run (libglib-2.0.so.0)
           #8  0x00007f5c590347fd gtk_main (libgtk-3.so.0)
           #9  0x0000560b96b5f85a main (abrt-applet)
           #10 0x00007f5c56c5518b __libc_start_main (libc.so.6)
           #11 0x0000560b96b5f9ca _start (abrt-applet)
           
           Stack trace of thread 3404:
           #0  0x00007f5c56d21589 __poll (libc.so.6)
           #1  0x00007f5c5703dbe6 n/a (libglib-2.0.so.0)
           #2  0x00007f5c5703dfa2 g_main_loop_run (libglib-2.0.so.0)
           #3  0x00007f5c5762e6ba n/a (libgio-2.0.so.0)
           #4  0x00007f5c57065f2a n/a (libglib-2.0.so.0)
           #5  0x00007f5c54b9c594 start_thread (libpthread.so.0)
           #6  0x00007f5c56d2c00f __clone (libc.so.6)[/code]

grazie

Consiglio l’opzione -l per evitare che l’output venga tagliato ad 80 colonne.
Quindi abrt-applet va in crash, forse perché c’è qualcos’altro che fallisce prima; da abrt dovresti vederlo e se hai fortuna anche a segnalarlo. Magari poco prima dell’output che ci hai passato si nota qualcosa di insolito. Hai provato magari ad usare Xorg anziché Wayland quando selezioni la sessione di Gnome?

ciao frafra,

abrt riporta oltre a quello del post #1 ,

PackageKit terminato inaspettatamente
L'applicazione ha riscontrato un errore e non può continuare.
packagekitd killed by SIGSEGV

poi abrt fallisce il “riporta”

]Elaborazione non riuscita
 --- Running report_uReport ---
Fallito il caricamento dell'uReport sul server 'https://retrace.fedoraproject.org/faf' con curl: OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to retrace.fedoraproject.org:443 
Errore: curl_easy_perform: SSL connect error
('report_uReport' è uscito con 1)

uso sempre Xorg

grazie
ciao

Proverei ad avviarlo con modalità grafica sicura/driver VESA, per escludere si tratti di problemi legati alla scheda video, ma ora sono un po’ preso e non ho modo di cercare la procedura, scusami :slight_smile:

grazie frafra , per il prezioso aiuto,
ho messo “xdriver=vesa” nel boot .per ora non si è bloccato ,ma è casuale,può stare tanto senza farlo, in genere quando credo di aver risolto, lo fa :smiley: .
ciao

ciao,
allora il problema si è ripetuto ,ma non sono proprio sicuro se era veramente in modalità vesa , aggiungendo “xdriver=vesa” alla riga del boot.
grazie

Verifica con:

$ for i in {1..10}; do journalctl -b$i | grep 'Command line:'; done

Grazie frafra della risposta,
no , non compare nessuna aggiunta , ho provato a mettere sia dopo rhgb quiet oppure alla fine della riga.
il comando da $ non da risultati ,solo l’avviso che non posso vedere altri users ,root .
Ho dato il comando da root ,per vedere i risultati.

Chiedo scusa, manca un “-”, altrimenti non ti mostra gli ultimi.

$ for i in {1..10}; do journalctl -b-$i | grep 'Command line:'; done

si , ma sempre solo come root, compaiono gli ultimi boot , si vede xdriver=vesa ; quindi il problema è un altro.
grazie
ciao