Kernel 5.11.8 non parte gdm con i driver nvidia

Ciao a tutti ,
purtroppo sono costretto ad aprire un altro thread …
Sul mio notebook Qosmio ,avevo installato i driver Nvidia , vedi
ora aggiornando il kernel e già anche con il precedente 5.11.7 -200.fc33.x86_64 ,
il portatile non parte ,il boot si ferma a " ok started gnome display manager "
cosa posso fare ?
grazie
ciao
aggiungo che con un kernel più vecchio 5.10 .x parte regolarmente e con i driver Nvidia ho risolto i problemi di micro freeze, ma se con i nuovi kernel non va , non posso più aggiornarli

Ciao @yum_yoshi quando arrivi al blocco clicca crtl +alt +f3 quando sei alla console ti logghi è :

sudo akmods --force

se ti parte la sessione grafica spegni il pc è riaccendilo dovrebbe andare senza problemi se invece riscontri problemi a loggarti in console 3 ti spiego come fare da grub in fase di boot (magari sei già capace di farlo ) :slightly_smiling_face:

@edmondo
Ciao , grazie per il suggerimento .
io ho rimosso il 5.11.7 quando ho visto che non andava ,ho aspettato il 5.11.8
e ho rimosso anche questo ,per rimanere sempre con dei kernel che il notebook funziona.
Ora riproverò ad installare un kernel nuovo e fare come dici.
grazie
ciao

@edmondo
Allora ,ho dato akmos --force , risponde kmods esiste ,ma al riavvio rimane bloccato .
l’altra procedura quale sarebbe? devo rimuovere i driver nvidia ?
ora sono con il vecchio kernel ,va tutto regolare ; che problemi ci sono se non aggiorno più i kernel?
grazie
ciao

Ciao @yum_yoshi metti provvisoriamente i kernel-longterm :
https://copr.fedorainfracloud.org/coprs/kwizart/kernel-longterm-5.10/ questi sono gli lts della versione 5.10 con fix sicurezza ma non eseguono l’upgrade alla versione 5.11 , con questi funziona senzi problemi è hai le patch di sicurezza , vediamo con il rilascio del kernel 5.11.12 se il problema persiste , perchè stanno pulendo il codice , è ovviamente le schede nvidia sono le prime che ci vanno di mezzo (quelle vecchie) :slightly_smiling_face: p.s per una corretta installazione :

dnf copr enable kwizart/kernel-longterm-5.10 

po installa :

dnf install kernel-longterm  kernel-longterm-devel kernel-longterm-headers 

:slight_smile:

@edmondo
grazie , anche per aver corretto il titolo , così si capisce meglio .
Allora aspetto il 5.11.12 ,se non va installo quelli longterm.
grazie
ciao

1 Mi Piace

Ciao @yum_yoshi :joy: scusa per la risata ma ho appena finito di scriverti nell’altro che ti risaluto in questo , allora speriamo che sia solo un difetto del kernel perchè anche su ask fedora cè un discorso simile , che dopo aver aggiornato al riavvio schermo nero , sembrerebbe propio il kernel difatti hanno ripiegato sulla versione 10 , se non dovesse andare apposto puoi mettere il longterm , io personalmente con una scheda più recente con il rilascio del kernel . 5.9 ho avuto lo stesso problema è ho usato il longterm per guasi 10 rilasci del kernel , ogni tanto facevo una prova se non partiva , riavviavo è partivo con il longterm , eliminado il kernel che avevo installato , il copr è sicuro , usato moltissimo da molti utenti che hanno hardware datato , che con i kernel nuovi crea problemi difatti ha anche una versione 4 del kernel :slightly_smiling_face: